dslreports logo
site
spacer

spacer

spacer




how-to block ads



TekSavvy DSL page on DSLReports
Six Month Rating

Reviews:
bullet 1126 reviews (931 good) (80 bad)
bullet Submit a review by email click here
bullet login for new review notification feature

Review by ekster See Profile

  • Location: Lachine,QC
  • Cost: $43 per month
Good "Price, support"
Bad "They depend on Bell's lines"
Overall "If you want DSL, go with them. Half the price and twice the service of Bell"
Pre Sales information:
Install Co-ordination:
Connection reliability:
Tech Support:
Services:
Value for money:
(ratings match consensus)

My Other Reviews

·FreePhoneLine
Called them on Monday to set up a dry-loop DSL, they said we'll be connected on Friday. On Friday, a Bell tech came in for a few seconds to check the signal and that was it.

The set up went flawless, the price, the plans and support is WAY better than anything Bell offers. It's like paying less for more! Sure, Bell currently offers better speeds, but what's the point when your usage is limited to 20-30 GB a month when TSI has 300 GB (used to be 200GB) - unlimited for less.

More than happy to have switched to them!

Update: After more than a year, my only trouble is that Bell randomly disconnected me from the remote. TSI's support was pretty good and got me back online pretty quick. Only drawback is that Bell moved me off the remote and to the CO now, resulting in a slightly slower speed.

member for 4 years, 2331 visits, last login: 1 days ago
updated 2.6 years ago

Comments:

TSI Pierre
Baby, Wanna see what 300Gigs looks like?
Premium
join:2011-09-23
Chatham, ON

Thank You

Hi ekster,

Thanks for sharing your positive feedback!

Pierre A

Roger75

@cogentco.com

Intermittent Outages

Starting October 2011, I am getting 5 to 7 outages a day lasting from a few minutes to 45 minutes. I asked TSI technical support for the cause and they are not able to tell me. This is very annoying and frustrating. I am located in Thornhill.

Cobalt

@bell.ca

Re: Intermittent Outages

yeah you probably have a problem with the bell lines .... ask them to send a tech out