dslreports logo
site
spacer

spacer
 
    All FAQs Site FAQ DSL FAQ Cable Tech About DSL Distance DSL Hurdles »»
spc

spacer




how-to block ads



Suggested prerequisite reading:
»Cisco Forum FAQ »Things to expect when setup network for home or small business

For many cable and DSL internet connections, the ISPs inform their customers (subscribers) to set their router to receive IP address from them using username and password. This means that the ISPs treat their subscriber's router as PPP client.

When this is your case, then the following sample configuration is a good starting point to help you configure the router. If your ISP requires you to use PPPoE for Internet access, the general idea is that you configure the router as PPPoE client to the ISP.

Following is the sample configuration using Cisco 2514 with IOS image version 12.3. Even though the example uses 2514 router, the configuration applies to any router that utilizes two ethernet interfaces for connection; including 871 router and 1841 router though you may need to adjust your configuration when the router run IOS image version different than 12.3 one.

Typical network environment that might utilize following sample router configuration is as follows
* There is a modem in front of the router, which the modem connects to the ISP
* ISP is providing Public IP address to the router via PPPoE
* There is NAT/PAT in place on the router to translate internal IP addresses to the ISP-provided Public IP address

This sample configuration applies to the setup where the modem is external as you may notice. If you have modem/router combo, then following FAQ is suggested.
»Cisco Forum FAQ »Configuring router with integrated ADSL modem running PPPoE

This sample router configuration assumes the followings
* Internal private IP subnet (for hosts behind the router): 10.10.10.0/24
* All of the hosts' gateway would be the router inside interface IP address: 10.10.10.1
* The IP address range of 10.10.10.2-10.10.10.254 would be available for hosts within your LAN
* When all hosts behind the router go out to the Internet, the hosts would be using the router outside interface IP address (which is the ISP-assigned Public IP address)
* The router is not setup as DHCP server to LAN machines. You can check out the next PPP router sample configuration to illustrate of setting up a router as the DHCP server.

Sample Configuration
version 12.3
no parser cache
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service dhcp
!
hostname Router
!
!
enable password xxxxxxxxxx
no aaa new-model
ip subnet-zero
ip cef
!
!!!!! Configure Router as PPPoE Client to the ISP
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!!!!!
!
!
!
interface Ethernet0
description My LAN Interface
ip address 10.10.10.1 255.255.255.0
!!!! When NAT/PAT occurs, this interface is the source candidate (inside local)
ip nat inside
!!!!
no ip mroute-cache
no cdp enable
!
interface Ethernet1
description Physical ADSL Interface (Facing the ISP)
no ip address
no ip mroute-cache
!!!! Ties this interface to the Dialer interface 
pppoe enable
pppoe-client dial-pool-number 1
!!!!
no cdp enable
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
no cdp enable
!
interface Serial1
no ip address
no ip mroute-cache
shutdown
no cdp enable
!
interface Dialer1
description Logical ADSL Interface
ip address negotiated
ip mtu 1492
!!!! When NAT/PAT occurs, this interface is the destination candidate (inside global)
ip nat outside
!!!!
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
!!!!! Ties this logical interface to the proper physical interface
dialer pool 1
!!!!!
!!!!! Passing the protocol allowed by the "dialer-list" command
dialer-group 1
!!!!!
no cdp enable
ppp authentication chap pap callin
ppp chap hostname [your username, provided by ISP]
ppp chap password 0 [your username password, given by ISP]
ppp pap sent-username [the username] password 0 [the password]
!!!! Default Gateway to the ISP
ppp ipcp route default
!
ppp ipcp dns request accept
ppp ipcp address accept
!
!!!! PAT subnets allowed by the ACL 10
ip nat inside source list 10 interface Dialer1 overload
!!!!
no ip http server
ip classless
!!!!
!
!
!!!! ACL 10 determines which subnet to be PATed
access-list 10 permit 10.10.10.0 0.0.0.255
!!!!
!!!! Determine which protocol to pass through
dialer-list 1 protocol ip permit
!!!!
no cdp run
!
!
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
length 0
!
scheduler max-task-time 5000
end
 

A Walkthrough
»Cisco Forum FAQ »Walkthrough of Configuring Cisco Routers for ADSL PPPoE using external modem

Note:
For those of you who curious to learn more of the PPPoE client configuration on Cisco router, you may issue the ? (questions mark) command to find out the available protocol list to do the VPDN dial. As a headsup, the pppoe may not show when you issue the ?. However when you enter the pppoe command, the router will take it without problem. In other words, the pppoe protocol choice command may somewhat be hidden.

More PPPoE sample configuration
»Cisco Forum FAQ »Wireless Router Sample Configuration

Some discussions
»getting my hand wet over cisco!! please help
»[Config] Cisco 1701 cant access some websites

Troubleshooting
PPPoE Troubleshooting Guide from official Cisco website in case something goes wrong

Side Note:
Some might argue that the configuration only applies to dynamic ISP IP address assignment. That when using static, the command under interface Dialer1 is "ip address x.x.x.x x.x.x.x" instead of "ip address negotiated". However, you may have to use "ip address negotiated" on static IP address to make everything work (the VPN, public server access, etc.) in some cases.

Check out the following FAQ for more info
»Cisco Forum FAQ »Between DHCP, PPP, Dynamic, and Static IP Address

Tips:
To find out the DNS IP addresses from your ISP for you to use through the ppp ipcp dns request accept, run debug ppp packet and terminal monitor commands. Watch the scrolling lines during this debug, especially regarding the IP address for the router and the DNS IP addresses. Once you see the DNS IP addresses from one of the scrolling lines, you can stop the debug and monitoring by issuing undebug ppp packet and terminal no monitor commands.

Feedback received on this FAQ entry:
  • This is perfect.thanks a lot.

    2013-07-10 02:44:16



Expand got feedback?

by aryoba See Profile
last modified: 2013-12-30 06:44:32