dslreports logo
site
spacer

spacer
 
    «« DSL Hurdles Share Tool
spc

spacer




how-to block ads



Some references
PPPoA Baseline Architecture
Cisco DSL Router Configuration and Troubleshooting Guide - PPPoA Online Form

The sample configuration provided in the thread should work with any Cisco router with integrated ADSL modem running PPPoA; such as 827, 837, 857, 877, and on.

Since the configuration is coming from ISP UK Zen customer, some parameters might not work for your ISP (i.e. the VPI/VCI or PVC value). Following is some ISP known parameters which may change at anytime.

Orange
VPI/VCI pair 8/35
PPPoA service, with provided username and password
PPP authentication method is either PAP or CHAP

As with any ISP connection using ADSL, please confirm the ISP DSL signaling and VPI/VCI values.

version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname adsl-router
!
boot-start-marker
boot-end-marker
!
logging buffered 16256 debugging
logging rate-limit 15
enable secret 5 xxx
!
clock timezone GMT 0
clock summer-time BST recurring 3 Sat Mar 1:00 last Sun Oct 2:00
no aaa new-model
!
!
ip subnet-zero
no ip source-route
ip cef
!
!
!
!
no ip bootp server
!
!
interface ATM0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
!
interface FastEthernet0/0
 description LAN
 ip address 192.168.1.1 255.255.255.0
 speed 100
 full-duplex
 ip nat inside
!
interface Dialer1
 description WIC1-ADSL Dialer to Zen
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 2
 dialer idle-timeout 0
 no cdp enable
 ppp chap hostname zenxxx@zen
 ppp chap password 7 xxx
 ppp pap sent-username zenxxx@zen password 7 xxx
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
!
!
!
ip nat inside source list 1 interface Dialer1 overload
no ip http server
no ip http secure-server
ip classless
!
!
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
dialer-list 2 protocol permit ip
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
 

More Sample Configuration

Official Cisco documentation
Configuring a Cisco 827 Router Using PPPoA With CHAP and PAP

Some discussions

»Anyone successfully using a Cisco 877 with Qwest?
»[Config] Configuring an 877W for use on BT Broadband help please

Tips:
To find out the DNS IP addresses from your ISP for you to use through the ppp ipcp dns request accept, run debug ppp packet and terminal monitor commands. Watch the scrolling lines during this debug, especially regarding the IP address for the router and the DNS IP addresses. Once you see the DNS IP addresses from one of the scrolling lines, you can stop the debug and monitoring by issuing undebug ppp packet and terminal no monitor commands.

Expand got feedback?

by aryoba See Profile
last modified: 2014-05-08 14:56:24