dslreports logo
site
spacer

spacer
 
    All FAQs Site FAQ DSL FAQ Cable Tech About DSL Distance DSL Hurdles »»
spc

spacer




how-to block ads



Sample Configurations

Example 1: Dual Voice Gateway routers

Voice Gateway 1
VG1#show running
version 15.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname VG1
!
boot-start-marker
boot-end-marker
!
!
logging buffered 10000000
no logging rate-limit
no logging console
no logging monitor
!
no aaa new-model
clock timezone EST -5 0
clock summer-time EDT recurring
!
ip cef
!
ip traffic-export profile test mode capture
  bidirectional
!
!
!
!
!
ip domain name diablo.com
ip name-server 4.2.2.2
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
 sip
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 4 ilbc
 codec preference 5 g729br8
 codec preference 6 g729r8
!
!
voice iec syslog
!
!
voice translation-rule 1
 rule 1 /^9/ //
!
voice translation-rule 2
 rule 1 /^\........../ /\1/
 rule 2 /..../ /8435555089/
!
voice translation-rule 3
 rule 1 /\(.*\)/ /91\1/
!
voice translation-rule 7
 rule 1 /00\.*/ /\1/
!
!
voice translation-profile InBound_CallerID_SIP
 translate calling 3
!
voice translation-profile OutBound_CallerID_SIP
 translate calling 2
!
voice translation-profile Outbound_SIP
 translate called 1
!
voice translation-profile Translate_SIP00_out
 translate calling 2
 translate called 7
!
!
!
license udi pid CISCO2921/K9 sn ********
license accept end user agreement
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
!
redundancy
!
!
ip ssh version 2
!
class-map match-all L3-to-L2_VoIP-Cntrl
 match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
 match ip dscp ef
class-map match-all SIP
 match protocol sip
class-map match-all RTP
 match protocol rtp
!
policy-map output-L3-to-L2
 class L3-to-L2_VoIP-RTP
  set cos 5
 class L3-to-L2_VoIP-Cntrl
  set cos 3
policy-map EthOut
 class RTP
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Voice Provider 1 SIP Internal
 ip address 10.1.102.8 255.255.255.0
 ip traffic-export apply test size 50000000
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description Voice Provider 2 SIP External
 ip address 172.16.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 10.1.102.1
!
ip sla auto discovery
!
!
snmp-server community ****** RO
snmp-server community public RO
snmp-server community private RO
snmp-server enable traps entity-sensor threshold
!
control-plane
!
!
call filter match-list 1 voice
 incoming calling-number 8465551070
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
 !
 !
 !
!
!
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 10.1.102.111 identifier 1 version 7.0
sccp ccm 10.1.102.112 identifier 2 version 7.0
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/0
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 3 register TRANROUTER1
 associate profile 1 register CONFROUTER1
 associate profile 2 register MTPROUTER1
!
dspfarm profile 3 transcode universal
 codec g729r8
 codec g729br8
 codec ilbc
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 20
 associate application SCCP
!
dspfarm profile 1 conference
 description Conferencing resources
 codec g722-64
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 16
 associate application SCCP
!
dspfarm profile 2 mtp
 description Conferencing resources
 codec g711ulaw
 maximum sessions software 400
 associate application SCCP
!
dial-peer cor custom
 name internal_only
 name PRI_only
 name intl_only
 name longdist_only
 name backup_PRI
 name SIP_only
!
!
dial-peer cor list call
!
dial-peer cor list SIP
 member SIP_only
!
dial-peer cor list internal
 member internal_only
!
dial-peer cor list PRI
 member PRI_only
!
dial-peer cor list Intl
 member intl_only
!
dial-peer cor list longdist
 member PRI_only
 member SIP_only
!
dial-peer cor list international
 member PRI_only
 member intl_only
 member SIP_only
!
!
dial-peer voice 300 voip
 description **Incoming Call from SIP Trunk**
 session protocol sipv2
 session target sip-server
 incoming called-number .
 voice-class codec 1
 dtmf-relay rtp-nte sip-kpml
!
dial-peer voice 301 voip
 translation-profile outgoing Outbound_SIP
 huntstop
 preference 8
 destination-pattern 91[2-9]..[2-9]......
 session protocol sipv2
 session target ipv4:172.16.1.1
 voice-class codec 1
 dtmf-relay rtp-nte sip-kpml
 no vad
!
dial-peer voice 302 voip
 translation-profile outgoing Outbound_SIP
 preference 8
 destination-pattern 911
 session protocol sipv2
 session target ipv4:172.16.1.1
 voice-class codec 1
 dtmf-relay rtp-nte sip-kpml
 no vad
!
dial-peer voice 303 voip
 translation-profile outgoing Outbound_SIP
 preference 8
 destination-pattern 9[2-9]11
 session protocol sipv2
 session target ipv4:172.16.1.1
 voice-class codec 1
 dtmf-relay rtp-nte sip-kpml
 no vad
!
dial-peer voice 304 voip
 translation-profile outgoing Outbound_SIP
 preference 1
 destination-pattern 9011T
 session protocol sipv2
 session target ipv4:172.16.1.1
 voice-class codec 1
 dtmf-relay rtp-nte sip-kpml
 no vad
!
dial-peer voice 100 voip
 description Calls to Publisher
 translation-profile outgoing InBound_CallerID_SIP
 preference 10
 destination-pattern ....
 session protocol sipv2
 session target ipv4:10.1.102.111
 voice-class codec 1
 dtmf-relay sip-kpml
!
dial-peer voice 101 voip
 description Calls to Subscriber
 translation-profile outgoing InBound_CallerID_SIP
 preference 2
 destination-pattern ....
 session protocol sipv2
 session target ipv4:10.1.102.112
 voice-class codec 1
 dtmf-relay sip-kpml
!
dial-peer voice 2595 pots
 destination-pattern 1012595
 port 0/1/0
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 video
 srst mode auto-provision all
 max-ephones 110
 max-dn 400
 ip source-address 10.1.102.8 port 2000
 system message Diablo SRST
 cnf-file location flash:
 cnf-file perphone
 time-zone 13
 max-conferences 8 gain -6
 transfer-system full-consult
!
!
!
line con 0
 exec-timeout 30 0
 logging synchronous
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 logging synchronous
 login local
 transport input ssh
line vty 5 15
 privilege level 15
 logging synchronous
 login local
 transport input ssh
!
scheduler allocate 20000 1000
ntp server pool.ntp.org
!
end
 

Voice Gateway 2
VG2#show running
version 15.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname VG2
!
boot-start-marker
boot-end-marker
!
!
logging buffered 10000000
!
no aaa new-model
clock timezone EST -5 0
clock summer-time EDT recurring
!
ip cef
!
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
 import all
 network 10.10.10.0 255.255.255.248
 default-router 10.10.10.1
 lease 0 2
!
!
!
ip domain name diablo.com
ip name-server 4.2.2.2
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
voice service voip
 ip address trusted list
  ipv4 2.1.2.9 255.255.255.255
  ipv4 2.1.2.10 255.255.255.255
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
 sip
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 4 ilbc
 codec preference 5 g729br8
 codec preference 6 g729r8
!
!
!
!
voice translation-rule 1
 rule 1 /^9/ //
!
voice translation-rule 2
 rule 1 /^\........../ /\1/
 rule 2 /..../ /6455555280/
!
voice translation-rule 7
 rule 1 /00\.*/ /\1/
!
!
voice translation-profile OutBound_CallerID_SIP
 translate calling 2
!
voice translation-profile Outbound_SIP
 translate called 1
!
voice translation-profile Translate_SIP00_out
 translate calling 2
 translate called 7
!
!
!
license udi pid CISCO2921/K9 sn *****
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
redundancy
!
!
ip ssh version 2
!
class-map match-all L3-to-L2_VoIP-Cntrl
 match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
 match ip dscp ef
class-map match-all SIP
 match protocol sip
class-map match-all RTP
 match protocol rtp
!
policy-map output-L3-to-L2
 class L3-to-L2_VoIP-RTP
  set cos 5
 class L3-to-L2_VoIP-Cntrl
  set cos 3
policy-map EthOut
 class RTP
  set dscp ef
 class SIP
  set dscp af31
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Voice Provider 2 SIP Router internal
 ip address 10.1.102.9 255.255.255.0
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description Voice Provider 2 SIP Router external
 ip address 2.2.2.2 255.255.255.252
 duplex auto
 speed auto
 service-policy output EthOut
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip flow-export source GigabitEthernet0/0
ip flow-export version 5
ip flow-export destination 10.1.101.129 9996
!
ip route 0.0.0.0 0.0.0.0 2.2.2.1
ip route 10.0.0.0 255.0.0.0 10.1.102.1
!
ip sla auto discovery
!
!
snmp-server community ****** RO
snmp-server community public RO
snmp-server community privat RO
snmp-server enable traps entity-sensor threshold
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
 !
 !
 !
!
!
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 10.1.102.112 identifier 2 version 7.0
sccp ccm 10.1.102.111 identifier 1 version 7.0
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/0
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 2 register MTPROUTER2
 associate profile 1 register CONFROUTER2
 associate profile 3 register TRANSROUTER2
!
dspfarm profile 3 transcode universal
 codec g729r8
 codec g729br8
 codec ilbc
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 20
 associate application SCCP
!
dspfarm profile 1 conference
 description Conferencing resources
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec g722-64
 maximum sessions 16
 associate application SCCP
!
dspfarm profile 2 mtp
 description Conferencing resources
 codec g711ulaw
 maximum sessions software 400
 associate application SCCP
!
dial-peer cor custom
 name internal_only
 name PRI_only
 name intl_only
 name longdist_only
 name backup_PRI
 name SIP_only
!
!
dial-peer cor list call
!
dial-peer cor list SIP
 member SIP_only
!
dial-peer cor list internal
 member internal_only
!
dial-peer cor list PRI
 member PRI_only
!
dial-peer cor list Intl
 member intl_only
!
dial-peer cor list longdist
 member PRI_only
 member SIP_only
!
dial-peer cor list international
 member PRI_only
 member intl_only
 member SIP_only
!
!
dial-peer voice 300 voip
 description **Incoming Call from SIP Trunk**
 session protocol sipv2
 session target sip-server
 incoming called-number .
 voice-class codec 1
 dtmf-relay rtp-nte
!
dial-peer voice 301 voip
 translation-profile outgoing Outbound_SIP
 preference 8
 destination-pattern 91[2-9]..[2-9]......
 session protocol sipv2
 session target ipv4:2.1.2.9
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 302 voip
 translation-profile outgoing Outbound_SIP
 preference 8
 destination-pattern 911
 session protocol sipv2
 session target ipv4:2.1.2.9
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 303 voip
 translation-profile outgoing Outbound_SIP
 preference 8
 destination-pattern 9[2-9]11
 session protocol sipv2
 session target ipv4:2.1.2.9
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 304 voip
 translation-profile outgoing Outbound_SIP
 preference 1
 destination-pattern 9011T
 session protocol sipv2
 session target ipv4:2.1.2.9
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 100 voip
 description Calls to Publisher
 preference 1
 destination-pattern ....
 session protocol sipv2
 session target ipv4:10.1.102.111
 voice-class codec 1
 dtmf-relay rtp-nte
!
dial-peer voice 101 voip
 description Calls to Subscriber
 preference 2
 destination-pattern ....
 session protocol sipv2
 session target ipv4:10.1.102.112
 voice-class codec 1
 dtmf-relay rtp-nte
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 sdspfarm units 1
 sdspfarm transcode sessions 20
 video
 srst mode auto-provision all
 ip source-address 10.1.102.9 port 2000
 system message Diablo SRST
 cnf-file location flash:
 cnf-file perphone
 time-zone 13
 max-conferences 8 gain -6
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
!
line con 0
 logging synchronous
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 logging synchronous
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 logging synchronous
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server pool.ntp.org minpoll 10
!
end
 

Related sample configuration
Implementing SIP Gateways in CUCM

Description
* This sample configuration assumes SIP trunk is implemented
* The Voice Providers 1 and 2 are considered PSTN
* The Voice Gateways 1 and 2 are doing SIP trunking, which VG1 trunks with Provider 1 and VG2 trunks with Provider 2
* Depending on your voice network requirement, there may be SIP trunks to some internal recording servers; which is implemented on your IP-PBX system. In a case of CUCM Publisher and/or Subscriber server implementation, the servers may have SIP trunks with those recording servers

Cisco website

Understanding Dial Peers and Call Legs on Cisco IOS Platforms
Understanding the Operational Status of Dial Peers on Cisco IOS Platforms
Dial Peer Configuration Examples
Configuring Dial Plans, Dial Peers, and Digit Manipulation

Discussions

»Help with 5 router Frame Relay Config
»Accept Local call and Restrict long distance all
»[voice] unknown number when dialing

Expand got feedback?

by aryoba See Profile
last modified: 2014-11-05 15:45:47