dslreports logo
site
spacer

spacer
 
    All FAQs Site FAQ DSL FAQ Cable Tech About DSL Distance DSL Hurdles »»
spc

spacer




how-to block ads



This is a sample configuration for interconnecting a Cisco router with an ADSL2+ capable HWIC or builtin ADSL2+ capable port to either Be Broadband or O2 where the package purchased from O2 is ADSL2+.

The IP address should be provided by the service provider in the format 188.0.0.0.1 / 255.255.248.0 or similar or even a range of IP addresses such as 188.0.0.1 - 188.0.0.7 / 255.255.248.0

In addition, the service provider will provide the IP address of the default gateway or router and the DNS IP addresses.

They will just be in the format of an IP address such as 188.0.7.254 for the default gateway and 188.0.0.7.1 and 188.0.7.2 for the DNS servers.

The following config is required in all situations


The basic configuration for the ATM interface is as follows:

interface ATM0
!
! MAC address required. Please use a MAC that is different to the one below.
! You can even use the MAC of the router's interface but changing the middle
! hexadecimal sequence to a random sequence, such as 001d.7186.b56e on the LAN
! interface of the router can be changed to 001d.7197.b56e:

mac-address 0014.0000.000
no ip address
ip virtual-reassembly
no atm ilmi-keepalive
dsl operating-mode auto
!
!
! Create a new point to point sub-interface and assign it the IP address or one
! of the IP addresses provided by O2 or BB:

interface ATM0.1 point-to-point
ip address 188.0.0.1 255.255.248.0
!
! Add the command IP NAT OUTSIDE to enable your LAN IP to be NATted to the IP
! assigned.

ip nat outside
ip virtual-reassembly
!
! Add the following commands:

atm route-bridged ip
pvc 0/101
encapsulation aal5snap
!

Then add the static route to allow traffic to be routed out to the internet:

ip route 0.0.0.0 0.0.0.0 188.0.7.254

Then configure the NAT statement to specify what hosts will get NATted and to what:

!
ip nat inside source list 102 interface ATM0.1 overload
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
!

If the hosts on the LAN are not statically assigned IP addresses, then a DHCP server will need to be setup for that purpose on the router as follows:

!
! Exclude the IP address of the router's VLAN/BVI interface as well as any other statically configured
! hosts

ip dhcp excluded-address 10.10.10.254
!
! Name of DHCP pool

ip dhcp pool lan-pool
import all
!
! Network range to assign IP addresses in

network 10.10.10.0 255.255.255.0
!
! DNS servers' IP addresses provided by BB or O2

dns-server 188.0.0.7.1 188.0.0.7.2
default-router 10.10.10.254
lease 0 12
!

Choose either option 1 or 2 depending on your situation, not both.


(1.) If using a bridged interface, then the following is relevant:

!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
! Creation of a Bridge Virtual Interface with the internal LAN IP address
interface BVI1

ip address 10.10.10.254 255.255.255.0
!
! Add the command IP NAT INSIDE to allow the internal hosts to get NATted

ip nat inside
ip virtual-reassembly
!

(2.) OR if not using the bridged interface, then add the internal LAN IP address if not already present to VLAN 1:

!
interface Vlan1
ip address 10.10.10.254 255.255.255.0
!
! Add the command IP NAT INSIDE to allow the internal hosts to get NATted

ip nat inside
!



Credit to bigsy See Profile and the anon user Nubbins for posting his config.

Expand got feedback?

by Covenant See Profile
last modified: 2010-08-19 07:04:02