dslreports logo
site
spacer

spacer
 
    All FAQs Site FAQ DSL FAQ Cable Tech About DSL Distance DSL Hurdles »»
spc

spacer




how-to block ads



Some references
PPPoA Baseline Architecture
Cisco DSL Router Configuration and Troubleshooting Guide - PPPoA Online Form
Cisco DSL Router Configuration and Troubleshooting Guide - PPPoE Online Form
Cisco DSL Router Configuration and Troubleshooting Guide - PPPoE: DSL Router as a PPPoE Client Troubleshooting

Note: the steps here are only for the purpose of getting connected to your ISP. Other issues like security and features are not inclusive. They are where you enter your details. You will need to edit this for your use.

PPPoA

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface ethernet 0
router(config)#no ip http server
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface dialer 0

If you are assigned a static IP by your ISP, then follow this command
Router(config-if)#ip address [YOUR IP ADDRESS ASSIGNED BY ISP] [SUBNET MASK]

If you are assigned a dynamic IP address by your ISP, then follow this command
Router(config-if)#ip address negotiated

Continue with the rest of command
Router(config-if)#ip nat outside
Router(config-if)#encapsulation ppp
Router(config-if)#dialer pool 1
Router(config-if)#ppp pap sent-username password
Router(config-if)#exit
Router(config)#interface atm 0
Router(config-if)#pvc
Router(config-if-atm-vc)#en aal5mux ppp dialer
Router(config-if-atm-vc)#dialer pool-member 1
Router(config-if-atm-vc)#no shutdown
Router(config-if)#exit
Router(config)#ip nat inside source list 1 interface dialer 0 overload

If you are assigned a static IP by your ISP, then follow this command
Router(config)#ip route 0.0.0.0 0.0.0.0

If you are assigned a dynamic IP address by your ISP, then follow this command
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 0

Continue with the rest of command
Router(config)#access-list 1 permit 10.10.10.0 0.0.0.255
Router(config)#exit
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#


PPPoE
!
!
!
!
Configuration for PPPoE with NAT
Note: Pls note that the steps here are only for the purpose of getting connected with your ISP. Other issues like security and features are not inclusive. They are where you enter your details

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#no ip http server
Router(config)#vpdn enable
Router(config)#vpdn-group ppoe
Router(config-vpdn)#request-dialin
Router(config-vpdn-req-in)#protocol pppoe
Router(config-vpdn-req-in)#exit
Router(config-vpdn)#exit
Router(config)#interface ethernet0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface atm0
Router(config-if)#pvc
Router(config-if)#no shutdown
Router(config-if-atm-vc)#pppoe-client dial-pool-number 1
Router(config-if-atm-vc)#exit
Router(config-if)#exit
Router(config)#int dialer 1

f you are assigned a static IP by your ISP, then follow this command
Router(config-if)#ip address [YOUR IP ADDRESS ASSIGNED BY ISP] [SUBNET MASK]

If you are assigned a dynamic IP address by your ISP, then follow this command
Router(config-if)#ip address negotiated

Continue with the rest of command
Router(config-if)#ip mtu 1492
Router(config-if)#ip nat outside
Router(config-if)#dialer pool 1
Router(config-if)#ppp authentication pap callin
Router(config-if)#ppp pap sent-username password
Router(config-if)#exit
Router(config)#ip nat inside source list 1 interface dialer 1 overload
Router(config)#ip classless

If you are assigned a static IP by your ISP, then follow this command
Router(config)#ip route 0.0.0.0 0.0.0.0

If you are assigned a dynamic IP address by your ISP, then follow this command
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 1

Continue with the rest of command
Router(config)#no ip http server
Router(config)#access-list 1 permit 10.10.10.1 0.0.0.255
Router(config)#exit
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#

This FAQ provided by member sanchito75 See Profile

Expand got feedback?

by nozero See Profile edited by aryoba See Profile
last modified: 2012-09-12 09:13:20