dslreports logo
site
spacer

spacer
 
    «« DSL Hurdles Share Tool
spc

spacer




how-to block ads




2.7 Cisco Router Setup Information

The problem is that you cannot pass subnet information to a PPPOE client, nor can you have a single subnet running on multiple interfaces of a Cisco router. So, to get around that we have to be creative.

This base config that should get you up and running. Please adjust the basic info (username, password, interface names, etc) to match your router and account. This config should work on any Cisco with 2 ethernet ports running an IOS DSL Plus image of at least version:
12.2(4)T
12.1(5)YB4
12.2(2)XH
12.2(2)XQ

!!!begin config !!!
!
vpdn enable
no vpdn logging
!--- default
!
vpdn-group pppoe
request-dialin
!--- we are the PPPoE client requesting to establish
!--- a session with the aggregation unit (6400 NRP)
protocol pppoe
!
int Dialer1
ip unnumbered FastEthernet0
encapsulation ppp
mtu 1492
!--- Ethernet MTU is 1500 by default
!--- (1492 + 8 byte PPPoE headers = 1500)
ip tcp adjust-mss 1460
dialer pool 1
!--- ties to interface Ethernet0
dialer-group 1
ppp authentication chap callin
ppp chap yourusername@static_ameritech.net
ppp chap yourpassword
!
!
!--- internal FastEthernet network
!
interface FastEthernet0
ip address !your primary static here! 255.255.255.248
!
interface Ethernet0
pppoe enable
pppoe-client dial-pool-number 1
ip tcp adjust-mss 1460
!--- The PPPoE client code ties into a dialer
!--- interface upon which a virtual-access
!--- interface is cloned.
!
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
dialer-list 1 protocol ip permit
!
end

Make sure that all computers behind the router have their MTU set to 1492 or lower to avoid fragmentation issues that can render some websites unreachable.

by dflanigan See Profile edited by lev See Profile
last modified: 2006-02-16 17:46:01

Here ya go. This is an Cisco827-V4 running 12.2.2XH2.

Current configuration : 1256 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable password
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no ip subnet-zero
!
no ip dhcp-client network-discovery
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
!
!
!
interface Ethernet0
ip address xxx.xxx.xxx.xxx 255.255.255.xxx
ip tcp adjust-mss 1450
no cdp enable
!
interface ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 0/35
pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip unnumbered Ethernet0
ip mtu 1492
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp chap hostname
ppp chap password
ppp pap sent-username
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
dialer-list 1 protocol ip permit
no cdp run
!
line con 0
stopbits 1
line vty 0 4
password
login
!
scheduler max-task-time 5000
end

by RadioDoc See Profile edited by lev See Profile
last modified: 2006-02-16 17:46:21

(Submitted by jmdomini See Profile)

Thought you might find this useful. It's the Cisco 827 config for the 5 static IP package using NAT. The one that is presently posted is for straight routing.

I also have to point out that this router works great with SBC DSL. None of the MTU issues that I had with other routers and I have been able to go months without power cycling.

!Cisco 827-IOS Version 12.2(8)YM
service password-encryption
ip source-route
service timestamps debug uptime
service timestamps log uptime
no service tcp-small-servers
no service udp-small-servers

!
hostname Cisco827
enable secret
username Cisco827 password
!
vpdn enable
no vpdn logging
vpdn-group pppoe
request-dialin
protocol pppoe
!
!
ip classless
ip subnet-zero
ip routing
ip http server
ip pim bidir-enable
!
interface ethernet0
keepalive 10
no shutdown
ip address 172.16.0.1 255.255.0.0
ip address 10.10.10.1 255.255.255.0 secondary
ip tcp adjust-mss 1452
ip route-cache
ip nat inside
!
interface atm0
no ip address
bundle-enable
dsl operating-mode auto
!
interface atm0.1 point-to-point
no ip address
no ip directed-broadcast
pvc 0/35
pppoe-client dial-pool-number 1
!
interface dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer remote-name redback
dialer-group 1
ppp chap hostname
ppp chap password
ppp pap sent-username password
!
ip nat translation timeout 86400
ip nat translation tcp-timeout 86400
ip nat translation udp-timeout 300
ip nat translation dns-timeout 60
ip nat translation finrst-timeout 60
!
ip nat pool ISPNATPool 67.x.x.49 67.x.x.51 netmask 255.255.255.248
ip nat inside source list 7 pool ISPNATPool overload
!add lines like below if you want static-nat mapping- if not using !static-nat set the above pool to all 5 static IP's.
!ip nat inside source static 172.16.0.52 67.x.x.52
!ip nat inside source static 172.16.0.53 67.x.x.53

!
ip route 0.0.0.0 0.0.0.0 dialer1
access-list 7 permit 172.16.0.0 0.0.0.255
access-list 7 permit 10.10.10.0 0.0.0.255
access-list 23 permit 172.16.0.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.255
dialer-list 1 protocol ip permit

!
line con 0
exec-timeout 120 0
stopbits 1
logging synchronous
!
line vty 0 4
access-class 23 in
exec-timeout 120 0
login local
logging synchronous
length 0
!
scheduler max-task-time 5000
end

by RadioDoc See Profile edited by lev See Profile
last modified: 2006-02-16 17:46:36