dslreports logo
site
spacer

spacer
 
    All FAQs Site FAQ DSL FAQ Cable Tech About DSL Distance DSL Hurdles »»
spc

spacer




how-to block ads




50.2 UBR Cable Modem/Router

Below is the default configuration for a UBR9xx (904/905/924/925) Cablemodem/Router. When you use this, the cablemodem will automatically add some lines for IP addressing, ranging, etc. You will need to setup passwords for enable secret and telnet/console ports if you want security on them.

-----START-----

version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
enable secret
!
!
!
!
!
clock timezone - 6
ip subnet-zero
no ip routing
!
!
!
!
!
voice-port 0
input gain -2
!
voice-port 1
input gain -2
!
!
!
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
ip access-group 102 in
ip access-group 102 out
no ip route-cache
no ip mroute-cache
bridge-group 59
bridge-group 59 spanning-disabled
!
interface cable-modem0
ip address negotiated
ip access-group 101 in
ip access-group 102 out
no ip route-cache
no ip mroute-cache
cable-modem boot admin 2
cable-modem boot oper 5
bridge-group 59
bridge-group 59 spanning-disabled
!
ip default-gateway 10.155.88.1
ip classless
no ip http server
!
access-list 101 deny 53 any any
access-list 101 deny 55 any any
access-list 101 deny 77 any any
access-list 101 deny pim any any
access-list 101 deny icmp any any
access-list 101 deny tcp any eq 4444 any
access-list 101 deny tcp any eq 135 any
access-list 102 permit tcp any any
access-list 102 permit udp any any
access-list 102 permit ip any any
snmp-server engineID local 00000009020000036BBD5CEC
snmp-server community colorado RO
snmp-server location Your City, State
snmp-server contact Your email address
snmp-server manager
banner motd ^
****************************************************************
* *
* WARNING: System is RESTRICTED to authorized personnel ONLY! *
* Unauthorized use of this system will be logged and *
* prosecuted to the fullest extent of the law. *
* *
* If you are NOT authorized to use this system, LOG OFF NOW! *
* *
**************************************************************** ^
!
line con 0
password
login
transport input none
line vty 0 4
password
login
!
end

Some discussions

»Need Help setting up ubr924 with adelphia
»UBR924 getting CMAC_LOG_DRIVER_INIT_IDB_RESET

by SolarPup See Profile edited by aryoba See Profile
last modified: 2010-09-28 13:04:06

Short answer: NO!

Long answer: Unfortunately on ubr9xx there is no command like mac-address like other routers' interface to clone a different mac address. Also, there are no plans to implement this feature on any cisco cable modem because DOCSIS standard does not allow this.

Cable modem specifications can be found at:

»www.cablemodem.com/specification ··· s10.html



By rhodium_uk

by Covenant See Profile edited by aryoba See Profile
last modified: 2005-11-12 08:00:01

Here is a configuration for a uBR924 that was loaded on a unit. It was for use with Optimum Online, but the configuration should be simular (if not the same) for all ISP's assuming they allow you to use a uBR modem...

This router also had a VPN tunnel established, which was removed from the config as well as any personally identifiable information.

The IOS version is 12.2.10b and the boot flash version is also 12.2.10b. The router has been up approx 7 weeks.

!
version 12.2
service nagle
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ubr924
!
aaa new-model
enable secret 5
!
clock timezone - -5
clock summer-time EDT recurring
ip subnet-zero
no ip source-route
ip tcp synwait-time 5
ip telnet source-interface Loopback0
ip dhcp excluded-address 192.168.2.1 192.168.2.100
!
ip dhcp pool LOCAL_NET
network 192.168.2.0 255.255.255.0
!the next line will be created automatically
!default-router 192.168.2.1
dns-server
!
ip audit notify log
ip audit po max-events 100
call rsvp-sync
!
!
!
!
!
!
!
!next two lines will be created automatically
!interface Loopback0
! ip address
!
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
ip nat inside
no ip mroute-cache
no cdp enable
!
interface cable-modem0
ip access-group 130 in
ip nat outside
no ip mroute-cache
no cable-modem compliant bridge
cable-modem dhcp-proxy nat PUBLIC
!
ip default-gateway x.x.x.x netmask
ip nat inside source route-map nonat pool PUBLIC overload
ip classless
ip pim bidir-enable
ip http server
ip http cable-monitor advance 192.168.2.1 255.255.255.0
!
access-list 1 permit 192.168.2.0 0.0.0.255 log
access-list 120 permit ip 192.168.2.0 0.0.0.255 any
access-list 130 deny udp any any eq snmp log-input
access-list 130 deny udp any any eq snmptrap log-input
access-list 130 permit ip any any
no cdp run
route-map nonat permit 10
match ip address 120
!
snmp-server packetsize 4096
snmp-server enable traps tty
snmp-server manager
!
!
!
line con 0
line vty 0 4
access-class 1 in
password 7
!
scheduler max-task-time 5000
ntp clock-period 17248359
ntp server 209.81.9.7 source Loopback0
ntp server 63.149.208.5 source Loopback0
ntp server 128.118.25.3 source Loopback0
end

This FAQ provided by N251EA See Profile.

by nozero See Profile edited by aryoba See Profile
last modified: 2005-11-12 08:00:20

Here is a configuration for a uBR925 that was loaded on a router for use for Optimum Online. The configuration should be similar for other ISP assuming they allow you to use this model.

This router had 2 GRE tunnels and multiple vpn tunnels configured. I have removed all that information before posting the configuration (i.e. simplified the config) the IOS version is 12.3.1a and bootflash is 12.3.2T and has been up for a week. Please note, I did NOT write this, it was provided by another member.

version 12.3
service nagle
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service internal
!
hostname ubr925
!
enable secret 5
!
!
!
clock timezone EDT -5
clock summer-time EDT recurring
aaa new-model
!
!
aaa session-id common
ip subnet-zero
no ip source-route
ip tcp synwait-time 5
ip telnet source-interface Loopback0
ip tftp source-interface cable-modem0
ip domain lookup source-interface Loopback0
ip dhcp database tftp://192.168.20.8/router-dhcp[?] write-delay 120
ip dhcp excluded-address 192.168.20.1
!
ip dhcp pool LOCAL_NET
import all
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
lease 1 12
!
ip audit notify log
ip audit po max-events 100
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh source-interface Loopback0
no ftp-server write-enable
!
voice rtp send-recv
!
voice service pots
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
!
!
!
! adjust the buffers with extreme caution!!!!!
buffers small permanent 325
buffers small max-free 370
buffers small min-free 45
buffers middle permanent 95
buffers middle max-free 125
buffers middle min-free 30
! adjust the buffers with extreme caution!!!!!
!
!
interface Loopback0
description Virtual interface - outside, gets registerd IP via DOCSIS/DHCP
!
interface Ethernet0
description Inside interface - Home network
ip address 192.168.20.1 255.255.255.0
ip nat inside
ip route-cache
!
interface cable-modem0
description Cable link to Optimum Online/CableVision, private 10 IP via DHCP
ip access-group 180 in
ip nat outside
ip route-cache
load-interval 30
no cable-modem compliant bridge
cable-modem dhcp-proxy nat PUBLIC
cable-modem boot admin 3
cable-modem boot oper 5
cable-modem downstream frequency 603000000 only
no keepalive
hold-queue 400 in
!
interface usb0
ip address negotiated
no ip mroute-cache
shutdown
arp timeout 0
!
!
ip nat translation timeout 3600
ip nat translation tcp-timeout 1200
ip nat translation finrst-timeout 15
ip nat translation syn-timeout 45
ip nat pool PUBLIC netmask
ip nat inside source route-map nonat pool PUBLIC overload
ip classless
ip http server
ip http secure-server
ip http cable-monitor advance 192.168.20.1 255.255.255.0
no ip http ezvpn
!
logging trap debugging
logging facility local1
logging source-interface Ethernet0
logging 192.168.20.8
access-list 100 permit ip 192.168.20.0 0.0.0.255 any log
access-list 100 deny ip any any log
access-list 120 permit ip 192.168.20.0 0.0.0.255 any
access-list 180 deny udp any any eq snmp log-input
access-list 180 deny udp any any eq snmptrap log-input
access-list 180 permit ip any any
route-map nonat permit 10
match ip address 120
!
snmp-server ifindex persist
snmp-server packetsize 4096
snmp-server enable traps tty
snmp-server manager
snmp mib persist circuit
!
banner login 
KEEP OUT!

alias interface s shut
alias interface ns no shut
alias interface e end
alias configure a alias
alias configure e end
alias exec srb sho runn | b
alias exec ct conf t
alias exec sr sho run
alias exec sb sho ip int brie
alias exec acl sho access-l
alias exec c0 int c0
alias exec sl sho log
alias exec cc cle access-l cou
alias exec cl cle log
alias exec ci cle cou
alias exec si sho int
alias exec end exit
alias exec e exit
alias exec se0 s int e0
alias exec sc0 s int c0
alias exec ca cle access-l cou
alias exec sd sho deb
alias exec srr sho int | i ^[A-Z]|^[a-z]|ts/se.+[1-9] pa|ts/se.+[0-9][0-9] pa
alias exec sri show run | include
!
line con 0
exec-timeout 0 0
exec prompt timestamp
line vty 0 4
access-class 100 in
exec-timeout 0 0
password 7
exec prompt timestamp
transport input telnet ssh
!
exception core-file crash
exception protocol ftp
exception dump 192.168.20.8
scheduler max-task-time 5000
ntp clock-period 17179953
ntp server 209.81.9.7 source Loopback0 prefer
ntp server 63.149.208.5 source Loopback0
ntp server 128.118.25.3 source Loopback0
!
end

This FAQ provided by member N251EA.

by nozero See Profile
last modified: 2008-05-15 18:13:14