dslreports logo
spacer
1
spacer
 
    All FAQs Site FAQ DSL FAQ Cable Tech About DSL Distance DSL Hurdles »»
spc

spacer

This FAQ text is copyright dslreports.com
Reproduction of all or part only with our permission..
This FAQ is edited by: JerryC23 See Profile, redxii See Profile
It was last modified on 2006-04-08 15:33:25

0 ISDN Faq

How do I contribute to this FAQ?

By simply clicking here. Please click it logged in or you will not get credit, and it may be ignored.

We are looking for:
•Useful information,•Fixes or solutions to common problems,• or tweaks, etc..

1 Definition of ISDN

Definiton of ISDN

Click for the The definition of ISDN.

Integrated Services Digital Network (ISDN) is a digital telephone connection that provides two digital phone lines capable of carrying voice, data, or a combination of the two. Each digital channel can support 64kbps (56kbps on some systems) of bi-directional data and the two channels of an ISDN Basic Rate Interface (BRI) line can be combined together to produce speeds of up to 128kbps.

ISDN phone lines are all digital which results in cleaner, error-free, and reliable data transmission. Analog phone lines used by modems are subject to data errors caused by line noise and other numerous transmission interruptions. An ISDN modem will dial and connect much faster than an analog modem. Many times it can dial, connect, be authenticated and online in less than 5 seconds.

ISDN is not very well known by the average computer user because local phone companies do not promote the service. However, unlimited ISDN service is a cost competitive service that is available to many homes and business in the US. Considering the overall improvement of bandwidth, reliability and cost, ISDN has become a viable solution for businesses and power-users who are unable to get DSL, cable modems, or other broadband connections. Additionally, with local ping-times typically under 100ms it is very popular with those who like to play games online.

Broadband ISDN (B-ISDN)

Broadband ISDN is a standard for transmitting voice, video and data at the same time over fiber optic telephone lines. It can support data rates of 1.5 megabits per second (Mbps), but it has not been widely implemented because not a lot of areas are wired to fiber optic.

Broadband ISDN is an ISDN Primary Rate Interface (PRI) line. This type of line is primarily used for businesses because it is comprised of 23 data channels and is much more expensive than the 2-channel Basic Rate Interface (BRI) ISDN line installed in the typical user's home.

2 General Questions

How fast is ISDN?

ISDN is capable of speeds up to 64kbps, or up to 128kbps with both B channels bonded. Just like most connections, it is subject to line overhead. You will generally see in the neighborhood of 80 - 95% of 128kbps. ISDN is a symmetrical line meaning both the download and the upload speed are the same.

Where is ISDN available?

ISDN is available just about anywhere, because it has no distance limitations. It can be obtained through your local telephone company, or search for an ISP at findanisp.com.

How much does ISDN cost?

There are two costs associated with an ISDN line:

    • The cost of the ISDN line itself from your local phone company, and,•The cost of your Internet Service Provider (ISP) to allow you to access the internet.

The cost of the line varies widely. You must call your local phone company to find out the cost. But it generally costs between $60 and $80 a month for the phone line itself for most people but it can vary as widely as $40 to $120 a month. The cost of an ISP will generally be between $19 and $50 a month.

Why would I want to pay $100 a month for only 128kbps?

Good question. The answer is simple. If ISDN is all you can get then you may be very happy to pay a premium price for a high quality digital phone line with speeds as much as 4 times faster than an analog modem line. If you can get DSL or a cable modem then by all means go for it. But if you cannot get DSL because your town doesn't have it or you are too far away from the CO then you may want to consider ISDN.

I can't get DSL or cable. Why would I want ISDN instead of Satellite?

You may have priced both satellite and ISDN and noticed that they are close to the same monthly cost. But you heard that satellite download speeds can be 1.5Mbps (that's Megabits per second) and ISDN is only 128kbps. So why wouldn't I want to get satellite internet?

Satellite has a very large delay when sending data back and forth between you and the internet. That delay can cause problems with certain programs, most notably online gaming. The delay for a satellite connection can be a half a second to a second (500ms to 1,000ms) because the signal travels thousands of miles above the Earth and back to you. The delay on an ISDN line is typically only 50ms to 150ms. That is a big difference. This delay can also affect how "snappy" your browsing experience is. When you click a link in your browser using ISDN it almost instantly begins to load. On satellite this can take a full second to begin loading.

Satellite performance is also subject to weather conditions. And as of the time of this writing, the Hughes Direcway satellite system is far from perfect. Some users have experienced only 40kbps download speeds during peak times of the day and evening. That is slower than a dialup modem.

ISDN is a more stable and predictable connection. It may be slower much of the time but it is usually a rock solid connection.

There is no clear answer to this question. Satellite vs. ISDN is a decision that needs to be made after you have learned all the pros and cons of both technologies.

Where can I find an ISP that supports 128K ISDN?

Good, cheap, fully-supported ISDN access? Nothing could be sweeter, but it's not always easy to find. An ISP that works for some may not work for others due to location (not every ISP has a local number in every area) or equipment (the same ISP may support ISDN on one phone number but not another).

To the uninitiated, it may come as a surprise to learn that an ISDN modem can connect each of its two 64K data channels (B-channels) to an ISP's 56K V.90 modem and get something that acts like a single 128K connection.

The tricky part is that the router that you connect to must somehow know that both of these incoming connections are really supposed to be grouped into one combined connection. In order to do this the ISP's router must support a protocol called "Multilink PPP" (dialing in with your second line is sometimes referred to as "joining the MP bundle" in router logs). Of course, your TA or router must be configured properly to use both channels as well.

Some ISPs explicitly support ISDN and Multilink PPP while others only claim to offer normal 56K dialup but some of their phone numbers actually do work with ISDN. Be aware that using ISDN with an ISP that doesn't officially support it may be in technical violation of the TOS (Terms of Service) agreement and your clever hookup could stop working at any time. That being said, many people have had good success with these ISPs.

Caveat: The information in the following table is subjective and may become out of date. ISPs without explicit ISDN support may or may not work for you even if they have worked for others.



ISPCoverageExplicit
Support
Cost Per MonthComments
MonsterUSA nationwideyes$19.95 (USD)No frills, includes email and web space
SBC Yahoo!USA nationwideno$21.95 (USD)Bundled with Yahoo! tie-ins, additional features available
MSN DialupUSA nationwideno$21.95 (USD)Bundled with "MSN 8" tie-ins, additional features available


2.1 Connection & Tweaking

Speed up your COM port

If you have a newer ISDN modem, you may be able to take advantage of a little extra speed boost. Windows 95 through 98SE allow you to only go as high as 115200bps on the port speed. This tweak can help you go up to 921600!

This tweak can be found here.

Note: XP and 2000 default at a top speed of 128000bps which should be fast enough for 128kbps ISDN. Windows ME tops at 921600 by default. If for some reason you can't get higher than 115,200 on these OSes, then it may not hurt to apply the tweak but I have not tested it myself in NT-based operating systems.

Setting the speed:

Windows 9x:

    •Right click My Computer on your Desktop and click Properties. Click the Device Manager tab:


    •Open Ports (COM and LPT). Choose the port your modem is installed on, right-click it and choose Properties.
    •Go to the Port Settings tab. By Bits pPer second:, choose the speed you want. I recommend you pick 230400 to be on the safe side.


    •Restart your computer for the changes to take effect.

Windows XP and 2000:
    •Right click My Computer on your Desktop and click Properties. Click the Hardware tab then click on Device Manager.•Open Ports (COM and LPT). Choose the port your modem is installed on, right-click it and choose Properties.

    •Go to the Port Settings tab. By Bits per second:, choose 128000.

    •Restart your computer for the changes to take effect


Can I use a 1010 long distance service with ISDN?

If you do not choose a long distance carrier when you establish your ISDN phone line you will not be able to make a long distance call unless you use one of the 1010 (also known as a dial-around) number. Even if you do have a long distance company assigned to your line you may still have some reason to use a dial-around number.

It appears as though a digital ISDN long distance call is handled differently than a voice call. Because of this, some long distance carriers may not work when trying to place a long distance call using their dial-around network.

User "Roamer1" had this information in a forum post:

1010321 (Telecom*USA = MCI) works, but you can only do 56k data calls, as 1010321 calls are trunked differently than regular MCI customers who are PICed to (101)0222 (please do NOT dial this unless you are PICed to MCI as you will be GOUGED.) You can try 1010345 (Lucky Dog = AT&T) but I'm not sure if that will even work.

Most of the cheaper dial-arounds (1010811, 1016868, etc.) don't support ISDN data at all.

If you want to do DOV and not normal ISDN data, the only carrier I've had any luck with is AT&T.


3 Hardware

What kind of modem do I need for ISDN?

To use your ISDN phone line you will need either an ISDN Terminal Adapter
(TA) or an ISDN LAN Router.

ISDN Terminal Adapter
An ISDN TA acts very much like a standard analog modem by connecting to your computer and then plugging into the ISDN phone line. In fact, Windows uses a TA just like a modem; requesting it to go off hook, dial, etc. To use a TA you use standard Dial-Up-Networking in Windows. The TA connects to your computer by either a serial port cable (just like a standard modem) or USB.

ISDN LAN Router
An ISDN LAN Router is very much like a network hub, but it also connects to your ISDN phone line. Your computers will connect to the router via an Ethernet cable and are configured to route all requests for internet activity to the router. When your computer requests a web page from the router the router will dial your ISP and connect to the internet. The router is configured with all the information it needs to know to call your ISP (user name, password, phone number, etc).

Should I use a TA or a Router?

You should first make sure you understand the advantages and disadvantages of each type of hardware.

Pros and Cons of a TA
    •If your TA connects to your computer via the serial port the speed of your connection will be limited to the speed of the serial port. Most serial ports run at a max speed of 115kbps. Your ISDN line can potentially run at a max speed of 128kbps. You may be wasting a small amount of speed because the ISDN line and TA can run faster than the serial port.
    •You will get better performance by using a USB connection to your TA.
    •A TA is great for connecting one computer to the ISDN line and internet. If you want to share your internet connection with more than one computer you will need to use Windows Internet Connection Sharing.
    •All configuration is typically done in Windows dial-up=networking.

Pros and Cons of a Router
    •A router is operating system independent. Any computer on your network can connect to the router via the Ethernet connection regardless of its OS.
    •You can easily share the internet connection between multiple computers in your home without using Windows Internet Connection Sharing and requiring the gateway computer to remain turned on.
    •You will usually realize the fastest speed when using a router because you are not limited by a serial port connection to the computer.
    •The router configuration is done in the router itself, either via special software, Telnet, or a browser interface to the router configuration screens.

OK, so which one should I use?
Most folks in the forum will recommend a router. They are easy to setup and it is very easy to share the internet connection with several computers in your home. But a TA will work just fine too, so if you are more comfortable with a "modem like" device connected directly to your computer or have found a great deal on a TA then its fine to use a TA. Just make sure you know the difference between the two types of hardware before making your decision.

Can you recommend any brands/models of hardware?

In the US you want to make sure that the hardware you get has a "U" interface. This is different than the S/T interface used in Europe. eBay is a very popular place to get good quality used hardware at very cheap prices. For example, a 3COM 3C892A LAN Router sells for about $300 new but you can easily pick one up on eBay for under $100 (many times under $50). Just make sure you get a "U" interface for use in the US. If the auction doesn't specify the model of the unit then ask the seller before bidding.

Many people in the forums have recommended the following hardware:

Where can I find an RJ11 to an RJ45 Jack for my ISDN TA?

While it might be difficult to find an RJ11 to RJ45 cable, you don't need to find it. A regular RJ11 to RJ11 will work.

RJ11 to RJ11 is a regular phone cable. They're cheap and super easy to find. It will fit into the RJ45 jack on your modem. Since ISDN only uses the center 2 pins on an RJ45, and an RJ11 has 2 pins in the center ones, you don't need the extras.

3.1 Cisco

How do I configure my Cisco 80x router for ISDN

The following SAMPLE is a basic config file to get you started. You will need to edit for your SPID's, directory numbers (DN's), router name, user name & password for your ISP.

!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname
!
boot-start-marker
boot-end-marker
!
enable secret
!
!
pots country US
!
no aaa new-model
no ip subnet-zero
ip name-server <1st ISP dns server IP here>
ip name-server <2nd ISP dns server IP here>
!
isdn switch-type basic-ni
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shutdown
!
interface BRI0
no ip address
no ip redirects
no ip unreachables
no shutdown
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 <1st SPID here> <1st phone number here>
isdn spid2 <2nd SPID here> <2nd phone number here>
no cdp enable
ppp multilink
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip split-horizon
ip tcp header-compression
dialer pool 1
dialer idle-timeout 2147483
dialer string
dialer hold-queue 10
dialer load-threshold 1 either
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username password
ppp multilink
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp *l port on box you want raffic forwarded to> interface Dialer0 *orwarded>
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
access-list 1 permit any
access-list 20 permit 192.168.1.0 0.0.0.255
access-list 20 deny any
access-list 110 deny ip 10.0.0.0 0.255.255.255 any
access-list 110 deny ip 172.16.0.0 0.15.255.255 any
access-list 110 deny ip 192.168.0.0 0.0.255.255 any
dialer-list 1 protocol ip permit
!
!
line con 0
transport preferred all
transport output all
stopbits 1
line vty 0
access-class 20 in
exec-timeout 0 0
password
login
transport preferred all
transport input all
transport output none
line vty 1 4
login
transport preferred all
transport input all
transport output all
!
!
end

3.2 Belkin