dslreports logo
site
spacer

spacer
 
    «« DSL Hurdles Share Tool
spc

spacer




how-to block ads




1.1 Setup

1. Check your change log to see what you've recently changed. Try turning off or backing-out the change. If a change causes a problem right away -- it is easy to see the cause and effect. But sometimes it takes a few days for a problem to be noticed. Keeping a written change log (in a notebook) can make tracking the source of problems a lot easier.

If you revert to an earlier version of the Linksys firmware, be sure to read the FAQ on updating firmware first.

2. Check the wiring. It is easy for physical connections to come loose. If wiring is walked on or pinched by desktops against walls the conductors and shields inside the wires can fail (intermittently fail or fail completely).

The lights on the router and the NIC (network interface card in your computer) can be a tip off.

Try replacing the wires, or swapping wires with another computer.

3. In setup, which WAN connection setting do you all have?

If you have PPPoE, try increasing the Keep Alive Time to 180 seconds. Too short a keep alive time causes problems (with any router).

4. Ideally the MTU should match between your PC, router and ISP. Especially with PPPoE this can cause problems.

Your own ISP is the only definitive source to tell you what you range your MTU should be set in; there is no alternative to checking with them. Still, you may have to try adjusting the MTU up and down slightly from the number they give you.

Configure your router to have that MTU, and use Dr. TCP to configure your PC to use that MTU. Dr TCP is available here

With my ISP the correct MTU turned out to be 1362. A larger MTU caused the email connection to fail, but only when sending attachments.

5. Another thing that commonly causes problems is software firewalls. If you run a software firewall (ZoneAlarm, NIS, Kerio, etc.) you may need to put the IP of your ISP's DNS (Domain Name Server) in the trusted zone for the software firewall.

You can determine the IP of your ISP's DNS from the Router's Status Panel.

The symptom you would see would be events from you ISPs DNS in your firewall log, and your connection failing, but not necessarily at the same time. Doing something to cause a release/renew on the connection would temporarily solve the problem.

6. Search the BBR forums for the router and / or the operating system to see if someone has had a similar problem recently.

7. It is possible that the component of your operating system called the Winsock has been corrupted by some ill behaved network software. There are utilities for fixing the winsock here:

For Windows 98, 98SE, or Me
For Windows XP
For Windows 95 with Winsock2, 98, 98SE, Me, 2000 or XP

by keith2468 See Profile edited by Lanik See Profile
last modified: 2006-03-16 21:58:31

This is usually caused by an MTU error. While MTU discovery should take care of this by itself, sometimes it doesn't. This may be because of the site you are trying to reach, or it may just be another of those annoying Linksys quirks.

The solution which has worked for many is: Adjust MTU down in 20 byte increments and try again. Start at 1500 for a cable connection or 1492 for a DSL connection. You will eventually find a value which will allow the site to load normally.

Feedback received on this FAQ entry:
  • I had the same problem, some website never stop loading, my router default MTU was 1492, so i reduce it to 1472 and everything is working perfectly now, thx a lot for the tip!

    2010-01-23 11:01:14



by lev See Profile edited by Lanik See Profile
last modified: 2005-06-22 00:05:22

First off, make sure that "detect proxy settings" is not enabled in IE. Having that turned on can cause this behavior, as will any manual proxy setting in IE or Internet properties. After checking that, go to the password tab on the router. Erase the password in both fields > apply > continue. Set the password back up again > apply > continue. The router didn't store the password correctly so once you do that it should work again regardless of firmware you are using.

by Lanik See Profile
last modified: 2005-06-22 00:05:41

After spending many "useless" hours getting wrong answers from both Verizon (our ISP) and Linksys in Irvine, CA - we finally (on the 3rd day and many hours) got hold of someone who said: "simple solution - some of our Routers require a crossover Cat 5 cable rather than a Patch cable. We put a crossover cable between the Verizon Modem and our Linksys Router and it lit up like the proverbial Christmas (OK - a Hanukkah Bush)tree.

So if you're having problems setting up your Linksys Router, try a crossover cable. Solved our problem in the time it took to plug in both ends.

by SALA7 See Profile edited by Lanik See Profile
last modified: 2005-06-22 00:06:02

See the Linksys Blue-Box Router HOWTO here for tips on how to use, administer and troubleshoot Linksys boxes from a Linux system.

by esr See Profile edited by Lanik See Profile
last modified: 2005-06-22 00:06:33