dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
561
share rss forum feed

andy99

join:2001-09-27
San Francisco, CA

can I copy config from one cisco router to another

Hi,
I have a cisco 2600 router that is acting up (hardware issues). I need to make sure that it is the source of the problem. I want to replace it with another cisco router (maybe 1600). What is the easiest way to rest the configuration on the 1600 and copy the same configuration on the 2600?
I have never done this and would like to know if this is an easy thing to do or not.
Thanks


aryoba
Premium,MVM
join:2002-08-22
kudos:4

You may be able to use 2600's config on 1600. But you have to make sure that both routers' specification and features are matching. When there is a different in just one thing, the 1600 router will issue error message.

But even if you do get the message, it should be an easy fix (it's not like the 1600 will blow up or something ... ). So go ahead and do it, and see what happen. Anything confusing, just ask ....


andy99

join:2001-09-27
San Francisco, CA

thanks. I have never configured a cisco router before and was hoping that someone will be able to help me figure it out. I have the configuration from the 2600 in text file and want to just copy that to the 1600. How can I do that?



ponline

join:2004-03-04
presheva

Well I dont think you can copy it as a txt file
You need to set up a TFTP server, copy the config from cisco 2600 to tftp server, and then copy the config from tftp server to cisco 1600.


andy99

join:2001-09-27
San Francisco, CA

ok. then how can I setup the 1600 so it will have the same config as this (I'm blocking the ip addreses here)
Thanks

Current configuration : 2486 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service hide-telnet-addresses
!
hostname cisco2600
!
no logging buffered
no logging console
no logging monitor
no logging on
enable password xxxxxxxxxx
!
!
!
!
!
ip subnet-zero
no ip finger
ip domain-name ALTER.NET
ip name-server 198.6.1.5
!
!
!
buffers huge size 100000
!
interface Loopback0
ip address xxx.xxx.xxx.xxx 255.255.255.255
!
interface FastEthernet0/0
description To Office FastEthernet
ip address xxx.xxx.xxx.xxx 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0
description To UUNET
bandwidth 1536
no ip address
encapsulation frame-relay IETF
no fair-queue
frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
bandwidth 1536
ip unnumbered FastEthernet0/0
frame-relay interface-dlci 500 IETF
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0.1
no ip http server
!
no logging trap
access-list 3 deny 66.51.135.0 0.0.0.255
access-list 3 deny 209.171.61.0 0.0.0.255
access-list 3 deny 216.133.249.0 0.0.0.255
access-list 3 deny 217.10.143.0 0.0.0.255
access-list 3 deny 151.189.24.0 0.0.0.255
access-list 3 deny 193.111.120.0 0.0.0.255
access-list 3 deny 204.89.131.0 0.0.0.255
access-list 3 deny 204.152.186.0 0.0.0.255
access-list 3 deny 69.61.52.0 0.0.0.255
access-list 3 deny 65.95.118.0 0.0.0.255
access-list 3 deny 64.251.27.0 0.0.0.255
access-list 3 deny 67.92.242.0 0.0.0.255
access-list 3 permit any
privilege exec level 15 who
privilege exec level 15 show
privilege exec level 15 access-enable
privilege exec level 15 where
privilege exec level 15 udptn
privilege exec level 15 tunnel
privilege exec level 15 terminal
privilege exec level 15 systat
privilege exec level 15 resume
privilege exec level 15 name-connection
privilege exec level 15 mtrace
privilege exec level 15 mstat
privilege exec level 15 mrinfo
privilege exec level 15 lock
privilege exec level 15 disable
privilege exec level 15 clear
privilege exec level 15 access-profile
!
line con 0
password yyyyyyyy
login
transport preferred none
transport input none
line aux 0
password yyyyyyyy
login
modem InOut
transport preferred none
transport input all
transport output pad v120 telnet rlogin udptn
stopbits 1
flowcontrol hardware
line vty 0 4
session-timeout 60
access-class 3 in
exec-timeout 60 0
password yyyyyyyy
login
transport preferred none
!
no scheduler allocate
end


aryoba
Premium,MVM
join:2002-08-22
kudos:4

1 edit

andy99,

You can move the 2600 config to the 1600 as ponline suggest. You can also do it manually by entering the command one by one. After that you can reload the 1600 and see if it gives you any error messages.

Btw, you ACL 3 is very long and inefficient. Are you trying to restrict telnet access to the router?


andy99

join:2001-09-27
San Francisco, CA

thanks. The router was configured by our ISP. I asked them to help but they said that since they don't manag the router, they can't help with anyhting.



dpocoroba
Premium
join:2000-11-14
224.0.0.5
reply to andy99

You can just copy and paste the config. There are a few tricks though. First you need to be in global config mode ( Router(config)# is the prompt you want). Then you can just paste in what you have shown from your running config. All of the access-lists, loopbacks and name servers shouldn't be a problem. The issue will come up with the interfaces as pointed out previously. You may have to set those up manually but you have a simple config so it shouldn't be to hard.HTH

DP
--
"Knowledge is contagious, infect"



NO7

@range217-44.btcentra

Well the 1600 router has only an ethernet not a Fastethernet LAN interface and the interface numbering differs between the platform other than that the config should be pretty much the same.(*providing of course youve got a similar IOS vesrion /featureset in either router)
TRY:-

service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service hide-telnet-addresses
!
hostname cisco1600
!
no logging buffered
no logging console
no logging monitor
no logging on
enable password xxxxxxxxxx
!
!
!
!
!
ip subnet-zero
no ip finger
ip domain-name ALTER.NET
ip name-server 198.6.1.5
!
!
!
buffers huge size 100000
!
interface Loopback0
ip address xxx.xxx.xxx.xxx 255.255.255.255
!
interface Ethernet0
description To Office LAN
ip address xxx.xxx.xxx.xxx 255.255.255.240
no shut
!
interface Serial0
description To UUNET
bandwidth 1536
no ip address
encapsulation frame-relay IETF
no fair-queue
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
bandwidth 1536
ip unnumbered Ethernet0
frame-relay interface-dlci 500 IETF
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0.1
no ip http server
!
no logging trap
access-list 3 deny 66.51.135.0 0.0.0.255
access-list 3 deny 209.171.61.0 0.0.0.255
access-list 3 deny 216.133.249.0 0.0.0.255
access-list 3 deny 217.10.143.0 0.0.0.255
access-list 3 deny 151.189.24.0 0.0.0.255
access-list 3 deny 193.111.120.0 0.0.0.255
access-list 3 deny 204.89.131.0 0.0.0.255
access-list 3 deny 204.152.186.0 0.0.0.255
access-list 3 deny 69.61.52.0 0.0.0.255
access-list 3 deny 65.95.118.0 0.0.0.255
access-list 3 deny 64.251.27.0 0.0.0.255
access-list 3 deny 67.92.242.0 0.0.0.255
access-list 3 permit any
privilege exec level 15 who
privilege exec level 15 show
privilege exec level 15 access-enable
privilege exec level 15 where
privilege exec level 15 udptn
privilege exec level 15 tunnel
privilege exec level 15 terminal
privilege exec level 15 systat
privilege exec level 15 resume
privilege exec level 15 name-connection
privilege exec level 15 mtrace
privilege exec level 15 mstat
privilege exec level 15 mrinfo
privilege exec level 15 lock
privilege exec level 15 disable
privilege exec level 15 clear
privilege exec level 15 access-profile
!
line con 0
password yyyyyyyy
login
transport preferred none
transport input none
line aux 0
password yyyyyyyy
login
modem InOut
transport preferred none
transport input all
transport output pad v120 telnet rlogin udptn
stopbits 1
flowcontrol hardware
line vty 0 4
session-timeout 60
access-class 3 in
exec-timeout 60 0
password yyyyyyyy
login
transport preferred none
!
no scheduler allocate
end