dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1095
share rss forum feed

TalkingLama

join:2005-03-10
Sultan, WA

Cisco 804 flaky 2nd channel issues

I have a Verizon ISDN line which I just had tested, the tech said it was very clear with zero loss.

My Cisco 804 rarely connects with two channels. 95% of the time only the first channel comes up. I have a 3com ISDN TA which I can use to bring both channels up every time. I REALLY like my 804 which has run solid for about 1.5 years. I also have a 1604R which shows the same problems as the 804, which leads me to believe that there is something in the config(as I'm running the same config).

I'm posting my config in hopes that someone smarter then me can throw me a bone and point out my issue
Thanks

Commands Shown are:
Sh run
sh ver
sh isdn status
debug results from:
debug ISDN all
debug ppp multilink events

JW_ISDN#sh run
Building configuration...

Current configuration : 4196 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname JW_ISDN
!
boot-start-marker
boot-end-marker
!
no logging console
no logging monitor
!
!
dial-peer voice 1 pots
caller-id
call-waiting
ring 0
no silent-fax
registered-caller ring 1
port 1
volume 3
destination-pattern 7945603
!
dial-peer voice 2 pots
caller-id
call-waiting
ring 0
no silent-fax
registered-caller ring 1
port 2
volume 3
destination-pattern 7948392
!
pots country US
!
aaa new-model
!
!
aaa session-id common
ip subnet-zero
no ip source-route
no ip domain lookup
!
ip dhcp pool DHCPPoolLAN_0
network 172.28.1.0 255.255.255.0
default-router 172.28.1.1
domain-name test.net
dns-server 204.122.16.8 204.122.16.9
!
ip inspect name firewall cuseeme
ip inspect name firewall fragment maximum 256 timeout 1
ip inspect name firewall ftp
ip inspect name firewall http
ip inspect name firewall h323
ip inspect name firewall realaudio
ip inspect name firewall smtp
ip inspect name firewall sqlnet
ip inspect name firewall streamworks
ip inspect name firewall tftp
ip inspect name firewall vdolive
ip inspect name firewall tcp
ip inspect name firewall udp
isdn switch-type basic-ni
username JW_ISDN password 7
username justin password 7
!
!
!
interface Ethernet0
ip address 172.28.1.1 255.255.255.0
no ip proxy-arp
ip nat inside
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 36079456030101 7945603
isdn spid2 36079483920101 7948392
isdn incoming-voice modem
ppp authentication chap pap callin
ppp multilink
!
interface Dialer1
description ISP
ip address negotiated
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip split-horizon
dialer pool 1
dialer remote-name Cisco1
dialer idle-timeout 1200
dialer string 4257402016 class DialClass
dialer hold-queue 1
dialer load-threshold 2 either
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password 7
ppp pap sent-username password 7
ppp multilink
!
ip nat inside source list 18 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
map-class dialer DialClass
logging trap debugging
logging 172.28.1.100
access-list 18 permit 172.28.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
snmp-server community wzone RW
snmp-server trap-source Ethernet0
snmp-server chassis-id ISDN804
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server enable traps isdn isdnu-interface
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 0 0
!
!
time-range TIME
periodic daily 0:00 to 23:59
!
end

JW_ISDN#
JW_ISDN#
JW_ISDN#
JW_ISDN#
JW_ISDN#
JW_ISDN#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C800 Software (C800-OY6-MW), Version 12.3(21), RELEASE SOFTWARE (fc2)
Technical Support: »www.cisco.com/techsupport
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Mon 06-Nov-06 16:52 by ccai
Image text-base: 0x000F5000, data-base: 0x009EE000

ROM: TinyROM version 1.4(1)
JW_ISDN uptime is 14 minutes
System returned to ROM by reload
System image file is "flash:c800-oy6-mw.123-21.bin"

Cisco C804 (MPC850) processor (revision 1) with 53560K bytes of virtual memory.
Processor board ID JAD05300GFD (265086476)
CPU part number 0x2101
Bridging software.
Basic Rate ISDN software, Version 1.1.
2 POTS Ports
1 Ethernet/IEEE 802.3 interface(s)
1 ISDN Basic Rate interface(s)
12M bytes of physical memory (DRAM)
8K bytes of non-volatile configuration memory
8M bytes of flash on board (4M from flash card)
Configuration register is 0x2102
JW_ISDN#
JW_ISDN#
JW_ISDN#
JW_ISDN#
JW_ISDN#
JW_ISDN#
JW_ISDN#
JW_ISDN#Configuration register is 0x2102
JW_ISDN#sh isdn status
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 82, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
TEI 82, ces = 1, state = 8(established)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 73, tid = 1
TEI Not Assigned, ces = 2, state = 3(await establishment)
spid2 configured, spid2 NOT sent, spid2 NOT valid
Layer 3 Status:
1 Active Layer 3 Call(s)
CCB:callid=8001, sapi=0, ces=1, B-chan=1, calltype=DATA, hdlctype=HDLC-TRUNK
CCB:callid=0, sapi=0, ces=2, B-chan=0, calltype=INTERNAL (BR0) SPC Call
CCB:callid=801A, sapi=0, ces=2, B-chan=2, calltype=DATA, hdlctype=HDLC-TRUNK
Active dsl 0 CCBs = 3
The Free Channel Mask: 0x80000000
Total Allocated ISDN CCBs = 3
JW_ISDN#
JW_ISDN#

debug ISDN all results (order reversed)

264: *Mar 1 00:23:19.553: ISDN BR0 **ERROR**: host_disconnect_ack: Call rejected cause Recovery on timer expiry(0x66) call id 0x802B
263: *Mar 1 00:23:19.549: ISDN BR0 EVENTd: calltrkr_call_cleared: isdn_info=0x029CC8E0, call_id=0x802B
262: *Mar 1 00:23:19.545: ISDN BR0 EVENTd: process_rxstate: cause=0x66 (102), cause_present=1
261: *Mar 1 00:23:19.545: ISDN BR0 PACKET: process_rxstate: 0x060002802B00180188080280E6
260: *Mar 1 00:23:19.545: ISDN BR0 EVENT: process_rxstate: ces/callid 2/0x802B calltype 1 HOST_DISCONNECT_ACK
259: *Mar 1 00:23:19.541: ISDN EVENTd: cc_clear_free_list freed 0x2C3C264
258: *Mar 1 00:23:19.537: ISDN BR0 TGRM: update_tgrm_call_status: Calling TGRM with tgrm_call_isdn_update: idb 0x29D702C bchan 2 call state 0 call type 0 call dir 1
257: *Mar 1 00:23:19.533: ISDN BR0 TGRM: update_tgrm_call_status: idb 0x29D702C bchan 2 availability state 1 call state(prev,new) (1,0), dsl 0
256: *Mar 1 00:23:19.533: ISDN BR0 TGRM: get_tgrm_avail_state: idb 0x29D702C bchan 2 service_state 0 call_state 0 false busy 0x0 dsl 0
255: *Mar 1 00:23:19.529: ISDN BR0 CC: CCBRI_Go: call id 0x802B call ref 0x2B state 10 event 0x91 Src->L3
254: *Mar 1 00:23:19.525: ISDN BR0 CC: CCBRI_Go: source id 0x300, state 1, call id 0x802B, event 0x341
253: *Mar 1 00:23:19.525: ISDN LIFd: isdn_L3_timer_process: event_count (1)
252: *Mar 1 00:23:19.521: ISDN BR0 Q931d: L3_state_change: callref 0x002B old CALL_INIT, new NULL_STATE
251: *Mar 1 00:23:19.521: ISDN BR0 Q931d: L3_ProcessEvent: callref = 0x002B T303_EXPIRY:U1_T303Expiry(nlcb)
250: *Mar 1 00:23:19.517: ISDN BR0 Q931d: L3_Go: call_id 0x802B cr 0x2B state 1 event 0x1313 ces 2
249: *Mar 1 00:23:19.513: ISDN BR0 Q931d: L3_Go: source = 0x300, event = 0x1313, call id = 0x2B, int id = 0x0
248: *Mar 1 00:23:19.513: ISDN LIFd: l3_timer: timer Expiry (0x2C3BFE0), timer_type (0x1313)
247: *Mar 1 00:23:15.993: ISDN Q921d: isdn_l2d_srq_process: event_count 1
246: *Mar 1 00:23:15.993: ISDN BR0 Q921: User TX -> RRf sapi=0 tei=82 nr=0
245: *Mar 1 00:23:15.993: ISDN BR0 Q921f: User TX -> 0x02A50101
244: line_status[0] = IF_ACTIVE
243: priv_ln = 4, int_id = 43872300, datasize = 4
242: dest_id = 0, source_id = 522, prim = 140
241: *Mar 1 00:23:15.989: ISDN BR0 PACKET: handle_l2d_srq_mail: received:
240: *Mar 1 00:23:15.985: ISDN Q921d: isdn_l2d_srq_process: QUEUE_EVENT
239: *Mar 1 00:23:15.985: ISDN BR0 LIFd: LIF_StartTimer: timer (0x2B8F7A4), ticks (30000), event (0x1250)
238: *Mar 1 00:23:15.981: 02A50101
237: *Mar 1 00:23:15.981: ISDN BR0 PACKET: L2IF_DispPak: packet - start(BBDE8), size (20) 0x029D702C0000020A0140040C00015521
236: datastart = BBDE8, netstart = BBDF8, datasize = 20
235: priv_ln = 4, int_id = 43872300
234: dest_id = 0, source_id = 522, prim = 140
233: *Mar 1 00:23:15.977: ISDN BR0 PACKET: L2IF_SendPkt: Sending from L2
232: *Mar 1 00:23:15.973: ISDN BR0 PACKET: L2IF_DispPak: packet - start(BBDF8), size (4) 0x02A50101
231: pkt (0x2ABA9C4), msecs (0x0), priority (0xA)
230: chan_id (0x0), int_id (0x29D702C), free_pkt (0x1),
229: sapi (0x0), ces (0x1), call_id (0x0),
228: dest_id (0x200), event (0x140),
227: source_id (0x20A), state (0x7),
226: *Mar 1 00:23:15.973: ISDN BR0 PACKET: L2IF_SendPkt:
225: chan_id (0x0), int_id (0x29D702C), free_p (0x1), pkt (0x2C3E58C), msecs (0x0), priority (0xA)


rolande
Certifiable
Premium,Mod
join:2002-05-24
Dallas, TX
kudos:6
Reviews:
·AT&T U-Verse
·ViaTalk
You have ppp multilink configured both on the physical BRI interface and on the Dialer interface. You should really just configure it on the virtual Dialer interface, since you aren't using the physical BRI configuration mode. That is the only obvious thing I can see that would cause the router to clear the second channel like that. PPP is always a likely suspect in that scenario. Both the physical and logical interface may be attempting to negotiate ppp multilink and defeating each other.

You also have your dialer load-threshold set to 2. Set it to 1 so it brings up the 2nd channel instantly.
--
Ignorance is temporary...stupidity lasts forever!

TalkingLama

join:2005-03-10
Sultan, WA
Thanks rolande,

when I took the encapsulation off of the BRI 0 interface it switched the ecapsulation to the default - HDLC. All the examples I've seen, including those from Fast Step show ppp encapsulation on both the BRI and the Dialer interface.

I think your on the right track with ppp issues, but I still have the problem.

thanks
justin


rolande
Certifiable
Premium,Mod
join:2002-05-24
Dallas, TX
kudos:6
Reviews:
·AT&T U-Verse
·ViaTalk
There are 2 ppp config commands on the physical interface. One sets the encapsulation. That must be set to ppp. However, do not use the command 'ppp multilink' on the physical BRI interface. Remove that command and only set the ppp multilink option on the Dialer interface.
--
Ignorance is temporary...stupidity lasts forever!

TalkingLama

join:2005-03-10
Sultan, WA
got it....thanks for the help. It seems to be stable now.

much appreciated!


rolande
Certifiable
Premium,Mod
join:2002-05-24
Dallas, TX
kudos:6
Good deal. I had a feeling it was the ppp multilink config doing it to you. Glad I could be of help.
--
Ignorance is temporary...stupidity lasts forever!