dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
10733
share rss forum feed


CC7

join:2001-03-03
Riverside, CA

[Modem] Using Linksys router with SpeedStream 4100 B

I am trying to hook up my parents' new ATT DSL line all afternoon. The DSL works fine with only one computer plugged in directly to the SS4100 but I am not able to get it working with the Linksys BEFSR41W router. I know the Linksys router works fine with a cable modem.

I have read all the possible solutions such as setting the router to 192.168.2.1, entering the IP and DNS address manually, PPP on the modem, PPP on the computer. I give up!!

Searching for other posting here led me to believe that not many people have problem with this. Is my router too old?

What are people's experience with hooking up the 4100B with a router? Should I get a newer Linksys router or is another brand, such as Dlink, works better with the 4100B?



AlphaOne
I see
Premium
join:2004-02-21
Reviews:
·AT&T Yahoo

When you said everything is working fine with just the computer plugged into the modem, let's assume the following:
modem - doing the PPPoE login
computer - on DHCP

Now, try to reset your Linksys router, to bring back the factory default settings (to simplify things as we don't what got changed).

Turn of the computer, and plugged it into one of the router's LAN port. Turn the computer on.
You must be able to access the router's config GUI through 192.168.1.1. Make sure it's set to DHCP and MTU to 1492.
That's all you need to do, then save the settings.

Now plug the router into the modem. You should be set to go.

Once everything is working, you can now change the router's password, and other things you like to change.



CC7

join:2001-03-03
Riverside, CA

Hi AlphaOne,

I just got home after 6 hours trying all different variations of setup. I need to get some food and sleep.

Yes, the modem is doing the PPPoE login and the computer is basically setup to automatically detect settings. As I recall the 4100B assigned the computer IP to 192.168.1.64. Connecting the computer directly to the modem worked perfectly.

On the router, I assume I should NOT select PPPoE and NOT put in the username and password? The default should be "Obtain an IP address automatically." Should I just leave the default modem IP address, 192.168.1.1, alone too? You are right, I should try to do a hard reset on the router. The router was working perfectly with the cable modem, so I thought it would be easy just hooking it up to the dsl modem.

I have to look around for the MTU setting... in the Advanced section. I don't think it was ever changed. What does MTU do anyway?



AlphaOne
I see
Premium
join:2004-02-21
Reviews:
·AT&T Yahoo

Yes, set your router to obtain ip automatically. And it's ok to set the router's LAN ip address to the default 192.168.1.1. You can change that later, if you need to.

With AT&T DSL here in CA, set the MTU to 1492 (instead of the default 1500) because of the overheads. Not sure where to set this with the BEFSR41W though.



helper2007

@sbcglobal.net
reply to CC7

said by CC7:

On the router, I assume I should NOT select PPPoE and NOT put in the username and password? The default should be "Obtain an IP address automatically." Should I just leave the default modem IP address, 192.168.1.1, alone too?

I have to look around for the MTU setting... in the Advanced section. I don't think it was ever changed. What does MTU do anyway?
When you set the modem to PPoE on the computer it basically just acts as a forward point from the dsl line. So dsl comes from the wall, into the modem, recognized by the modem, passed to the router. At that point ATT is asking the router, hey PPoE, what's your username and password? And your router is saying "you should already know me" ... but it doesn't... ATT knows the modem, but not your 3rd party router. Put everything back to default, make sure it's PPoE on the router, put in username and password, and try it [try it means: power off the modem, router and disable the connection on the computer... then turn on modem, wait 30 sec, turn on router wait 30 sec, enable ethernet]. If that doesn't work, go in to the router config and select "use this mac address" and find the mac address on the bottom of the modem and enter it in to the router config. Try that. If that doesn't work, do the same thing but this time use the mac address of the computer that CAN connect via modem. Go to START -> RUN -> cmd [press enter] then type "getmac" .. you may have to do a getmac /? to get the options... find your network card and look for the mac address.. there you can enter it in to the router... try that. If that doesn't work, get a new router.. email me with questions

cheers


myosh

join:2001-05-03
Cupertino, CA
reply to CC7

I can say from experience that AlphaOne's instructions are correct. I have setup two DSL connections using a Linksys router and both were setup like AlphaOne suggests.

Do NOT set the connection type to be PPPoE as helper2007 suggests.

One other thing, after putting the Linksys in between the modem and your computer, can you access the DSL modem (192.168.0.1) and if so, check to see if you're logged in. If you see a login screen, enter your username and password for the DSL account.


codemonkey2

join:2002-10-13
Oakland, CA
reply to CC7

Okay I need some help from the experts. Basically identical problem that CC described.

I have a Linksys WRT54G v2.0 that I have used without issue for several years with a Speedstream 5360. The 5360 died (the dreaded all leds - except power - blink). I ordered a Siemens 4100b to replace it.

Short story - plug the ethernet from the new modem into a computer; works like a charm. plug the ethernet into the router; nada.

Longer version - With PPPoE on the modem and the router set to DHCP the router status page shows what looks like reasonable WAN IP and gateway addresses. The DNS gets set to 192.168.0.1. DNS resolution doesn't work and I can't ping internet addresses (using dotted-quad) from PC.

With PPPoE on the router, again the WAN IP and gateway addresses look reasonable. I get 2 DNS server addresses that look reasonable. DNS resolution does work, but I still can't ping internet addresses.

At this point I suspect either the modem is specifically preventing the packets from reaching the internet (detecting that there is a router/NAT) or that there is some low level issue between my version of the linksys and this modem. By the way, I have the firmware for my hardware version of the WRT54G - I beleive it is 4.21.

Any suggestions welcome.

--Jeff



d_l
Barsoom
Premium,MVM
join:2002-12-08
Reno, NV
kudos:7

This set up method doesn't work?»/faq/12670



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC
reply to AlphaOne

said by AlphaOne:

Yes, set your router to obtain ip automatically. And it's ok to set the router's LAN ip address to the default 192.168.1.1. You can change that later, if you need to.
Watch it with some models of Netgear, though. When the router is set to obtain an IP address automatically, and pulls it from the SS4100, it always pulls 192.168.1.64. Some models of Netgear don't like a WAN IP address in the LAN IP address subnet, and will automatically reconfigure the LAN to a range in the 10.0.0.0/8 block of RFC 1918 reserved IP addresses; with potentially unpredictable results on the LAN.

A good rule of thumb with routers and SS4100s is to avoid using a router LAN IP address in either 192.168.0.0/24 (overlaps the SS4100),or 192.168.1.0/24 (overlaps the modem DHCP assigned IP address on the router WAN port).
--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum

tonydi
Premium,MVM
join:2001-05-11
San Jose, CA
reply to codemonkey2

If the setup outlined in the FAQ that d_l See Profile gave you doesn't work, with the modem doing the PPPoE, try doing a hardware reset on the Linksys and then configure it again.


codemonkey2

join:2002-10-13
Oakland, CA
reply to d_l

Click for full size
Router Status
I tried this and it didn't work either. Again I got DNS but still cannot ping WAN addresses. Cannot get the modem config page either

--Jeff

codemonkey2

join:2002-10-13
Oakland, CA
reply to tonydi

I'll give it a try tonight and let you know how it goes...

--Jeff



d_l
Barsoom
Premium,MVM
join:2002-12-08
Reno, NV
kudos:7

1 edit
reply to codemonkey2

Do you use a software firewall such as ZoneAlarm or XP's firewall? Those programs must be configured to trust the modem's IP at 192.168.0.1.

Also your router's subnet mask should be set to 255.255.255.0. Edit: This is for the LAN setting.

You might try setting the login type to static IP (instead of automatic) and:
192.168.1.64 for the IP address
255.255.0.0 for the subnet mask
192.168.0.1 for the default gateway
192.168.0.1 for DNS server.

Not sure if that will make a difference though, but some Linksys routers have an appearance of "locking up" when receiving the DHCP address from the modem if the public IP passthrough is used. It takes 10 minutes of waiting or a modem reset to fix this.



wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1

1 edit
reply to codemonkey2

Make sure you change the routers default lan IP address to 192.168.2.5 and reboot all computers using DHCP.


Wan Lan Settings

codemonkey2

join:2002-10-13
Oakland, CA
reply to CC7

Okay, I just did the hard reset. It worked. After the reset the only thing I changed were the routers LAN IP - 192.168.2.1 - and disabled wireless. The default login type was DHCP (on the linksys) so I left that and power cycled the linksys and all PCs. Then I power cycled the modem. From a PC I was then able to get to the modem's admin page and ping internet addresses (and do name resolution - DNS).

If I run across a setting in the router that causes things to break, I'll report back.

--Jeff



wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1

Here's some FAQ's on the modem
Where are the Line Stats in a 5100b or 4100
Explaination of the lights on the Speedstream 4100 DSL modem
What the hell is PPPoE anyway

--
God bless our troops



myosh

join:2001-05-03
Cupertino, CA

1 edit
reply to codemonkey2

--- Never mind, I re-read codemonkey2's last post and it looks like he got it solved.


tivoboy

join:2004-05-10
Menlo Park, CA

So, I am having some similar problems.

now using a linksys with tomato running, pppoe on the MODEM and DHCP on the router.

question is, the modem requires the authentication to be ACTIVATED, meaning, if the modem resets, or power fluctuates, one has to go into the modem and CLICK, CONNECT. Is there any way around this? I go away for periods of time, and would normally have the pppoe on the router, but that hasn't seem to work at this new address.



Mountaineer1
Big WVU Fan
Premium,MVM
join:2002-01-12
Universe
kudos:2

Did you select"Always Attempt to Connect" in the Connection Configuration tab?
--
Got a Clark,Crown,Drexel forklift and need technical advice? Ask me about it.



wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1
reply to tivoboy

Are you certain that only one device is set to do the PPPoE?
2 devices set for PPPoE can cause problems like you describe in your other thread.

The modem has 3 connection types:
Smart keep alive it will keep the PPPoE session alive until the ethernet link goes down. When the ethernet link is up a PPPoE session is started/maintained. This is the default connection type and it works well with a router.
--
God bless our troops


tivoboy

join:2004-05-10
Menlo Park, CA

Will smart keep alive, reconnect the pppoe session at the modem if the power goes out and back?

I have tried to set it to Always attempt to reconnect. Last night, however, it went out again (and this is a NEW modem) and the lights were on but the internet light was just blinking, and of course the router had nothing, no DHCP other than the .64, which basically means the modem is not connected.

I just don't know where to go with this. Worst connectivity i have had in seven years with ATT. Nobody seems to be able to fix it, but it looks like I am going to have to have the tech come, take ANOTHER day off work and pay them 100+$ to try to trouble shoot it here at the residence. At some point, I'm just switching to comcast


tivoboy

join:2004-05-10
Menlo Park, CA

So, another question is.

When I have to do a reboot, as if the power went out, I get the login screen again, I CANNOT get to the modem over the lan. So, connect a pc to the modem, to do the connect button, but it will ALWAYS ask me for the MODEM code when I click the connect button.

So, I ask, how could the modem do this on it's own? how could the modem run the connect script and somehow put in the modem code? It doesn't appear to be a hard coded in when I type it in, and it of course doesn't appear to be able to reset on its own.



d_l
Barsoom
Premium,MVM
join:2002-12-08
Reno, NV
kudos:7

I gather from your concern about power fluctuations causing problems that you don't have your modem and router on a UPS?

I recommend that you get one for your just broadband connection. It doesn't have to be a big expensive model. Even an APC BE325 power back up unit would prevent short-duration power outage resets on your modem and router. All you need is 300 to 500 VA of power and the high end of that range would only be if you wanted to outlast an hour-long outage.


tivoboy

join:2004-05-10
Menlo Park, CA

everything is indeed on a ups. But, since something is happening with the modem, either possibly a line issue, or a DSL configuration issue. That, a reboot is constantly necessary at this point. Not sure why, not sure how to change. But, historiclaly, I was able to tell people "okay, just reboot the modem, THEN reboot the router and you should be okay"

Unfortunatly, that isn't working at all.

I might try going back to the Router running the PPPOE and see how that fits.

Should the modem be in Bridge, or PPPoe on router for that solution.



d_l
Barsoom
Premium,MVM
join:2002-12-08
Reno, NV
kudos:7

If you are going with the router handling the PPPoE, then I prefer using "PPPoE on the computer" mode in the modem.

Were you trying to pass the public IP from the modem to the router when you had your posted problems? I have had problems with two different Linksys routers trying to do that and gave up messing with set up method.

If you want ready modem access AND the public IP at your router, the last method in this FAQ works well: »SBC DSL FAQ »How do I access the modem GUI thru a router - advanced methods?. All you need is a five-port switch or hub or even the switch side of an old router. If you use the modem in "PPPoE on computer mode", you will absolutely need to use static IPs on your LAN or have your router's DHCP server issue static Ips by MAC address. I don't know how well this method will work with the modem bridged, because with I can't test that. It should work ok though.



wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1
reply to tivoboy

said by tivoboy:

Will smart keep alive, reconnect the pppoe session at the modem if the power goes out and back?
Yes it will
If you have not powered down the modem for a day or longer. Would you copy the contents of the modems log to a text file and upload the file to your other thread:
[Line Problem] DSL disconnect EVERY night! Tried a bunch of thi

It won't help your issue, I would like to see 24 hours or more of your modems log. Your description of your modems operation is very unlike how its suppose to function
--
God bless our troops

tivoboy

join:2004-05-10
Menlo Park, CA

will do,
however, the log seems to be flushed even though I have set it to KEEP LOG ON REBOOT and warns me against that.

I'll try to put the log up tomorrow AM

THANKS!!!



lev
Smells better here without the monkey
Premium,Ex-mod 2002-08
join:2001-05-30
Chicago, IL
kudos:2
reply to CC7

(topic move) [Modem] Using Linksys router with SpeedStream 4100

Moderator Action
The post that was here (and all 1 followups to it), has been moved to a new topic .. »[Modem] Using Linksys router with SpeedStream 4100 B