dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
11353
share rss forum feed


JoshC12

@alltel.net

Windstream blocking ports?

I'm having a problem connecting to an online game called starcraft through my DSL connection at home. I have a 5200 series modem with WRT54G linksys router. I have tried connecting directly to the DSL modem and used the port forwarding option; this is the info. that I port forwarded to the modem (ip address for modem= 192.168.254.2):

Application: Starcraft
Starting port: 6112
Ending port: 6112
port forwarded to: 192.168.254.2

I also enabled the DMZ on my modem to that same ip address that I port forwarded to. There is no lag when I am directly connected to my DSL modem, but when I connect the DSL modem to a router and the router to my computer, I have latency issues. I tried going back into the modem page and erasing the port forwarding information and port forwarding to my router (WRT54G linksys), enabling DMZ on the router, and disabling the firewall on my router. Again, connecting directly to the modem with ports forwarded TO the modem and the DMZ on the modem activated allows lag-free gaming on starcraft, but when I try to connect to the router and port forward/enable DMZ on router/disable firewall, the lag is still present.

Other information: DHCP enabled

Other thoughts: Is it necessary to create static IP to forward ports for router? I don't do that for modem and everything works fine.

I'm kinda confused about what I should do because I don't know what to do now. Can anybody help?



evilghost
Premium
join:2003-11-22
Springville, AL

Windstream doesn't block ports.

Are you forwarding TCP or UDP 6112? Starcraft uses UDP.

If you're using your router + modem, and your modem isn't in bridge mode, then you're doing double-NAT which could account for the latency issues as well as forwarding issues. Only one device needs to act as a NAT.



The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2

OK! How do you set modem into bridge mode? Actually, from my sources, both TCP and UDP ports 6112 have to be opened. HOW HOW HOW?



evilghost
Premium
join:2003-11-22
Springville, AL

1 edit

said by The Limit:

OK! How do you set modem into bridge mode? Actually, from my sources, both TCP and UDP ports 6112 have to be opened. HOW HOW HOW?
Looks like it does use 6112 TCP as the controlling port, and UDP 6112 for game data.

Reset the modem to factory defaults by holding in the reset button on the rear. Don't configure any PPPoE settings, it's in bridge mode after a 'reset to defaults'. No configuration should be necessary.

Configure your StinkSys to handle PPPoE with the 5200 plugged in the WAN port. Configure your port forwarding on the StinkSys.

I recommend against using a DMZ since it leaves the destination computer vulnerable.


The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2
reply to JoshC12

I just realized that my modem is already in bridge mode...now what do you mean about NAT settings and putting PPPoE on linksys router? attach a screenshot if you can or type step by step on how to put linksys into PPPoE settings.



JoshC111

@alltel.net
reply to evilghost

Don't know if you got the last post or not, but my modem IS indeed in bridge mode (that's on the home page of the modem right?)

2684(0) 0/35-BRG UP - this is bridge mode right? Anyway I tried forwarding port to my router (192.168.1.100- ip address assigned by router) with ports 6112-6112. I have the router on DHCP so it auto. configures my router. Do I have to put the router on PPPoE? I didn't do that at my work with the EXACT same router on the EXACT same modem (one of the modems i own, the other is my dad's and is same model) and it worked so IDK what the deal is. All i did with the EXACT same router with my 5200 modem was enable dmz on modem and forward ports to the router; that fixed the problem at my work. Why do I have to do something different in this case?



evilghost
Premium
join:2003-11-22
Springville, AL

1 edit

said by JoshC111 :

Don't know if you got the last post or not, but my modem IS indeed in bridge mode (that's on the home page of the modem right?)

2684(0) 0/35-BRG UP - this is bridge mode right? Anyway I tried forwarding port to my router (192.168.1.100- ip address assigned by router) with ports 6112-6112. I have the router on DHCP so it auto. configures my router. Do I have to put the router on PPPoE? I didn't do that at my work with the EXACT same router on the EXACT same modem (one of the modems i own, the other is my dad's and is same model) and it worked so IDK what the deal is. All i did with the EXACT same router with my 5200 modem was enable dmz on modem and forward ports to the router; that fixed the problem at my work. Why do I have to do something different in this case?
I have no idea what you're telling me. Why would you port forward from a bridge device to your router, if that's what you're saying? You're not trying to port forward on the 5200 are you?

If the 5200 is in bridge mode then it's not a layer 3 device, you need to handle forwarding on the router since the bridge is operating at layer 2.


evilghost
Premium
join:2003-11-22
Springville, AL
reply to JoshC12

You need to use this layout:

L = LAN switch port
W = WAN port

{5200 Modem, in Bridge Mode} (Do nothing here, leave at default)
             |
             W
      [StinkSys Router] (PPPoE here)
       L    L    L      (Port forward here)
       |    |    |
      [PC] [PC] [PC]
 


The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2
Reviews:
·Windstream
reply to JoshC12

Ok, I did everything you asked me to do and I'm having trouble putting my "stinksys" router into PPPoE mode. When I put my stinksys router into PPPoE, I try to load a web page and it says that the "address is not valid" when in PPPoE. Why can't i just leave the router in automatic DHCP?
And yes, when I am directly connected to the modem, I do forward the ports to the modem and enable DMZ and starcraft runs lag-free in gaming.



The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2
reply to evilghost

Another thing: I have a WGT624v3 netgear router. Would that make a difference if I tried to use that router? If so, could you show me how to configure the router for port forwarding/PPPoE?



The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2
Reviews:
·Windstream
reply to evilghost

Ok, I did everything you asked me to do and I'm having trouble putting my "stinksys" router into PPPoE mode. When I put my stinksys router into PPPoE, I try to load a web page and it says that the "address is not valid" when in PPPoE. Why can't i just leave the router in automatic DHCP?
And yes, when I am directly connected to the modem, I do forward the ports to the modem and enable DMZ and starcraft runs lag-free in gaming.

(not sure if you got the last post or not thats why i am reposting..net sucks here)



evilghost
Premium
join:2003-11-22
Springville, AL
reply to JoshC12

said by JoshC12 :

Why can't i just leave the router in automatic DHCP?
If you do this you create a double-NAT.

Here's another approach you can use. You can use the Linksys router as a switch and bypass the WAN port.

On the Linksys:
* Disable the DHCP service (as it will conflict with the 5200)
* Set the IP Address of the router to be in the 192.168.254.0/24 scope (unless you've changed the addressing scheme on the 5200), 192.168.1.253 would be a good IP to use.
* Remove the 5200 from the WAN port and move it to the LAN port.

On the 5200:
* Configure it for PPPoE
* Configure it to handle port-forwarding

In this configuration the 5200 is the NAT/Router device and your Linksys is nothing more than a switch. This avoids double-NAT and eliminates putting the 5200 into bridge mode and using the LinkSys as the PPPoE client/router.


The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2
Reviews:
·Windstream

Tried your advice, and it didn't work. My modem is configured for PPPoE. It is also in bridge mode. One thing I keep noticing is the fact that as soon as I connect to the router WHILE in bridge mode and forward ports in router, I still lag. I tried assigning static ip and that didn't work either. Is there a type of router or switch that I can buy that does NOT have this issue? I know that the modem is not causing this problem; I also tried disabling DHCP and enabling PPPoE on the router and entering my user name and password, but I still get the same message when I try to load a web page: "address not valid."



evilghost
Premium
join:2003-11-22
Springville, AL

1 edit
reply to JoshC12

I'm going to have to tap out of this thread, hopefully someone else can come along and give you a hand. Good luck.

In the interim it may be a good idea to familiarize yourself with networking and the OSI layer as well as routing/NAT.



The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2

i reposted new thread to draw other people's attention and maybe find somebody who can help me with my problem. sorry for making you guys upset by reposting new thread.



evilghost
Premium
join:2003-11-22
Springville, AL

said by The Limit:

i reposted new thread to draw other people's attention and maybe find somebody who can help me with my problem. sorry for making you guys upset by reposting new thread.
No problem, I promise this thread is getting visibility, there are 5 people reading it now.


fourboxers
Co-Lead Mod
join:2003-05-04
Toronto, ON

1 recommendation

reply to The Limit

It's because it causes duplicate effort. This way people know what you've already tried.



The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2

Just to let you know, your icon is scary =)



sashwa
Premium,Mod
join:2001-01-29
Alcatraz
kudos:17

2 edits

1 recommendation

Just wait until fb puts the Halloween duds on.



The Limit
Premium
join:2007-09-25
Greensboro, NC
kudos:2
Reviews:
·Windstream
reply to evilghost

One question: would you happen to have any reading material on OSI layer and routing/NAT? If so, could you find it in college libraries? I really would like to be informed on this stuff .