dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
200925
share rss forum feed


BKJ

@verizon.net
reply to yubin7

Re: Make your actiontec a bridge with VOD working with REV D

did you get it?


BKJ

@verizon.net
reply to Yubin
ok have a yahoo account. how can i get you my screen name w/o posting to the world. Yes, i know what dhcp relay is and how it works (thanks).


BKJ

@verizon.net
reply to Yubin
ok i created an yahoo account: builtbygeek

yubin7

join:2008-02-17
Desoto, TX
I added you.

BKJ

join:2006-02-27
Woodbridge, VA
ugg.. FINALLY with the help of yubin I was able to get things working. My issue was that new bridge being created (in step 14/15) failed to add/pickup a lan ip. So if things are not working check that the new bridge is picking up an ip.

baygins

join:2002-06-18
Arlington, VA
yubin,
It's an interesting setup with the DHCP Relay. I am wondering if this is bypassing the AT QoS settings that it automatically assigns to the STBs in the 192.168.1.x range (.100 usually).
Any thoughts on that?

portwashguy7

join:2008-02-08
Port Washington, NY
reply to Yubin
This question probably shows my lack of detailed knowledge but:

What is the advantage of the setup you are describing compared to simply running a second router off the actiontec router by plugging the 2nd router with a cat5 cable into one of the actiontac's lan ports?

(I needed a router with better range, so I am using this config with a "N" router as the wnd router.)

baygins

join:2002-06-18
Arlington, VA
To take advantage of the advanced routing, QoS and wireless capabilities of your "_insert_3rd_party_router_name_" box rather than being restricted to the capabilities offered by AT (e.g., extremely limited NAT table).


cookymonsta

@verizon.net
reply to Yubin
Can one of you help me out, i have been trying this for weeks. tried the step by step here, i can get everything to work but the VOD. Anyone on yahoo?

Hooper
Premium
join:2001-10-22
Castle Rock, CO
reply to baygins
said by baygins:

yubin,
It's an interesting setup with the DHCP Relay. I am wondering if this is bypassing the AT QoS settings that it automatically assigns to the STBs in the 192.168.1.x range (.100 usually).
Any thoughts on that?
QoS is out the window with this setup. HOWEVER, this config only impacts QoS on your local LAN. WAN QoS is handled by Verizon to support multiple HD streams by dynamically adjusting throughput/caps on your line. The biggest problem you may face with this setup is that your 3rd party router might not have the WAN throughput to support the amount of traffic that can be generated.

Hooper
Premium
join:2001-10-22
Castle Rock, CO
reply to cookymonsta
said by cookymonsta:

Can one of you help me out, i have been trying this for weeks. tried the step by step here, i can get everything to work but the VOD. Anyone on yahoo?
Are you getting guide data? Have you unplugged all your set top boxes?

cookymonsta

join:2008-02-18
said by Hooper:

said by cookymonsta:

Can one of you help me out, i have been trying this for weeks. tried the step by step here, i can get everything to work but the VOD. Anyone on yahoo?
Are you getting guide data? Have you unplugged all your set top boxes?
the box is not getting an ip. yeah i unplugged it, plugged it back in. if i enable dhcp on the ethernet interface on the fios router the box will pull a 192.168.3.100 address, but that wont work ether.

Hooper
Premium
join:2001-10-22
Castle Rock, CO

1 edit
Click for full size
Click for full size
So if the box is pulling a 192.168.3.x address, it sounds like the Coax interface is not part of the new bridge that was created in step 15.

15) Select Network Bridge -> Next -> Select Add a New bridge -> Next -> Check Broadband Ethernet and Coax. Uncheck Wireless. -> Click Next.

cookymonsta

join:2008-02-18
i used these steps, i can try the bridge right now. but any idea why these wont work?

==============================net================================
Please note that these are MoCA instructions, not Ethernet. I'm providing this as an effort to help those out still experiencing problems with the original guide.

Performed on the following:

Router: MI424-WR Rev D. w/MoCA WAN
Current Firmware Version: 4.0.16.1.56.0.10.7

Please let me know if I have left anything, if something is incorrect or unclear. After a week I have this finally working after trying non-stop, these were the steps I took. I was able to get VOD working, but didn't include those instructions. I can write that up too if there is a demand for it.

I take no responsibility for anything that goes wrong (even though not much can, it's all configuration).

1) Connect your computer to the MI424-WR using an Ethernet connection.

2) Open your web browser and type in 192.168.1.1 in the URL and press "enter"

3) The default username and password for the MI424-WR is "admin" and "password; however Verizon techs tend to change the password to "password1". If neither works, you will need to do a hard reset on the router (hold down the reset pinhole with a paperclip for about 10 seconds).

4) Once you are logged in, reset the router to the default settings. To reset the config to defaults, click on "Advanced" at the top, and then click yes in the confirmation box. You will then see "Restore Defaults" at the lower left side of the screen (under the red toolbox icon). The router will now reboot itself. Remember that the username and password resets itself to the Action Tec default of "admin" and "password". It's a good idea to change the password after this is all done.

5) Log back into the router after you have "Restore Defaults", you will now need to go to back to “Advanced” at the top of your screen. Click on “System Settings”, and then scroll all the way to the bottom. Change the Auto Wan to disabled. This will disable the router from automatically trying to regain its MoCA IP address when you release it (later on). Apply these settings.

The why (if you care to read): If you noticed, or at least I did when the tech was on my computer - he ran some scripts off of an usb flash drive. These scripts first wrote some configuration to the router, and then updated it to the latest firmware. This means the configuration written on your updated firmware was made for an older firmware (why some of you got an error trying to load it after restoring factory defaults). I took a text compare program and compared the configuration you save first vs. the configuration you save after your router has been reset to factory defaults & they are VERY different, but the router still can load it (but won’t if you try when the firmware is updated and reset back to it's new way of handling config files). You can go to Advanced on the top of your screen once logged into the MI424-WR, downgrade the firmware, and load the configuration file (usually called 'Wireless') then update back to the latest firmware if you choose to do so. Long process for no reason, but this was the only way I got it to work. Anyways…

6) Log back into the router then click on "My Network" at the top of the screen. Once you are there, click on "Network Connections" at the menu on the left.

7) You should now see a list of interfaces that exist in the router. To see them all, click on the "Advanced" button below that list.

8) Now you will need to release your MI424-WR's IP from the ONT. To do this, click on the "Broadband Connection (Coax)" from the connection list. Then click on the "Settings" button at the bottom. You will now see a bunch of settings for this interface. Make sure the "Privacy" option is enabled (if you have reset your MI424-WR to defaults earlier, it maybe disabled, but on the newer routers it’s permanently enabled and grayed out). Not having the privacy setting enabled will cause the connection to the ONT to fail. Click the "Release" button FIRST and then change the "Internet Protocol" option to "No IP Address" (default setting is "Obtain an IP Address Automatically") then apply these settings.

9) In the connection list, click on "Network (Home/Office)", and then click on the "Settings" button. You will see a list of interfaces under "Bridge". Check the box next to the "Broadband Connection (Coax)", and then check the box under the STP column. Apply these settings.

10) Click on "Wireless Access Point" in the interface list and then click on "Disable".

11) Disable the built-in firewall also. Click on "Firewall Settings" and then select "Minimum", then click on "Apply". Also while going through the connections you can uncheck any boxes that state “Firewall” & apply them.

12) The MI424-WR should still have a connection to the ONT but be offline to the internet. You can check this by going back into "My Network", then "Network Connections", then clicking on the "Full Status" button at the bottom of the list. "Broadband Connection (Coax)" Should say it's connected still.

13) You will now need to go to back to “Advanced” at the top of your screen. Click on the MAC Cloning from the drop down list select "Broadband Connection (Coax)" and on a piece of paper or in Notepad write down the MAC address of the "Broadband Connection (Coax)" that’s currently being used. After you have that information replace the "Broadband Connection (Coax)" MAC with the MAC of the 3rd party router that you’re going to hook up to it or to the MAC of your PC’s NIC. Apply these settings.

14) Next, disconnect all computers from the MI424-WR, then connect Ethernet to & setup your 3rd party router. Change its WAN MAC to the one you wrote down above for the "Broadband Connection (Coax)". Make this router obtain an IP address automatically but for the LAN distribution change it to the 192.168.0.1 network (for simplicity sake). After everything has been setup, connect an Ethernet cable from the WAN port of your 3rd party router to port 1 (again, for simplicity sake) of the MI424-WR’s switch.

15) With any luck your 3rd party router should have pulled an IP from Verizon.

16) Because your Ethernet is bridged under the "Network (Home/Office)" connection (which we did not release an IP address from), your computer WILL still get an IP address on the 192.168.1.1 network. Just connect an Ethernet cable from your PC to the MI424-WR's switch (any port). You will do this to connect to the MI424-WR from now on.

==============================vod=================================

To get VOD working:

First, get the above working

Now that your 3rd party router has an IP address, and you can get to the internet through one of it's switch ports (or through it wirelessly) we will start to isolate the switch port 1 on the MI424-WR into it's own VLAN so you can get VOD / other services that rely on the MI424-WR to work.

1) Log back into the MI424-WR (using the IP address of 192.168.2.1 to connect) by attaching Ethernet to one of it's switch ports (not port 1 where you have your 3rd party router, use 2, 3, or 4) then click on 'My Network' at the top of the screen. Once you are there, click on 'Network Connections' at the menu on the left.

2) You should now see a list of interfaces that exist in the router. To see them all, click on the 'Advanced' button below that list.

3) If you have been following verbatim, under the 'Network (Home/Office)' connection bridge should be 'Ethernet', 'Broadband Connection (Coax)', 'Coax', and 'Wireless Access Point'.

4) We will remove Ethernet first, so In the connection list, click on 'Network (Home/Office)', and then click on the 'Settings' button. You will see a list of interfaces under 'Bridge'. Uncheck the box next to the 'Ethernet', and then uncheck the box under the STP column. Apply these settings.

5) Ethernet will now be removed from the bridge and be automatically assigned a different network. Because we removed only this first, it will be given the 192.168.2.1 network.

6) Do a start, run, type cmd (enter), then type ipconfig /release (enter) then ipconfig /renew (enter)

NOTE: For Vista it's just start then type cmd in the white box on the bottom.

7) In your browser change the 192.168.1.1 to 192.168.2.1 and reconnect to the MI424-WR.

8) Once back on go back to the 'Network Connections' view. Ethernet should now be separated from the Network (Home/Office) connection. 'Broadband Connection (Coax)', 'Coax', and 'Wireless Access Point' should still be in the (Home/Office) connection.

9) In Network (Home/Office)'s settings, do the same thing (uncheck boxes for it and STP) for 'Coax', and 'Wireless Access Point'. Apply these settings.

NOTE: The MI424-WR acts funny when you remove 'Coax' out of the Network (Home/Office) bridge, or at least it did for me when I had Auto Wan enabled. If you notice your router going into an repetitive reboot, unplug the actual coax line that's feeding into the back of the MI424-WR and it will come up without rebooting.

10) Now the only thing that should be in the 'Network (Home/Office)' bridge is 'Broadband Connection (Coax)' by itself. Click on 'Ethernet', 'Settings'. At the bottom of this next view you will change 'hide' to 'show' for the 4 port switch and all 4 ports will be shown. Click the 'Edit' button for port 1, then change Ingress policy to tagging and change the PVID from 0 to 1 (doing this will also add this port into VLAN 1 - so you don't need to bother adding this port into VLAN 1). Apply these settings.

11) Back at the 'Network Connections' view, Click 'Add' Select 'VLAN Interface' then next, select 'Ethernet' from the drop down, and enter 1 for the VLAN. Apply these settings.

12) In 'Network (Home/Office)', 'Settings' - Check the box for 'Ethernet 2' and STP under the bridge. Also select 'No IP Address' from the 'Internet Protocol' drop down. Apply these settings.

13) Back at the 'Network Connections' view open 'Broadband Connection (Ethernet)', 'Settings'. Take a Ethernet cable and attach one side of it to the MI424-WR's Ethernet WAN port and the other to your 3rd party router's switch port 1 (for simplicity sake). Next you will enable this connection, and apply the settings.

14) 'Broadband Connection (Ethernet)' should now be connected, and your 'Network (Home/Office)' bridge should only contain 'Ethernet 2' and 'Broadband Connection (Coax)'.

Check your router status to see if it has a 192.168.0.X IP address.

Hooper
Premium
join:2001-10-22
Castle Rock, CO
If the Coax connection is not bridged (look at my first image above --> Coax needs to be indented in the Network Connections status page) , the set top boxes will not pull an IP address from your 3rd party router. As a result, Internet connectivity may be limited depending on your exact setup.

cookymonsta

join:2008-02-18
said by Hooper:

If the Coax connection is not bridged (look at my first image above --> Coax needs to be indented in the Network Connections status page) , the set top boxes will not pull an IP address from your 3rd party router. As a result, Internet connectivity may be limited depending on your exact setup.
ok i did that now broadband Ethernet (coax) says "down" after i enable it.

I am supposed to be hooked into port one on the actiontec router right?

So it goes Actiontec (PORT 1) -> 3rd party router WAN port?

BKJ

join:2006-02-27
Woodbridge, VA
Cookymonsta:

You may also need to alter the config of:

Coax -> Actiontec -> Actiontec:Ethernet connection1:RJ45 -> 2ND Router Internet Port(WAN Connection)-> 2ND Router:Ethernet port 1:RJ45 -> Actiontec:WAN (Internet)ethernet port.(Sounds redundant but your second router is the new DHCP and the actiontec uses that dhcp to give itself an internal ip and provide internet for your STB's

to

Coax -> Actiontec -> Actiontec:Ethernet connection1:RJ45 -> 2ND Router Internet Port(WAN Connection)-> 2ND Router:Ethernet port 1:RJ45 -> LAN Switch:RJ45 -> LAN Switch:RJ45 -> Actiontec:WAN (Internet)ethernet port.(Sounds redundant but your second router is the new DHCP and the actiontec uses that dhcp to give itself an internal ip and provide internet for your STB's

If I didnt make the above change I could not get out to the internet.

For simplicity here is my setup:

Hardware:
linux fw/router with 2 interfaces (1 wan - 1 lan)
cisco 2900 switch
Actiontec

Config:
linux fw/router wan port to actiontec ethernet port (can be any of the 4)
linux fw/router lan to cisco switch
cisco switch to actiontec wan port

cookymonsta

join:2008-02-18
holy crap. ITS WORKING! i have been at this for WEEEEEKS! THANK YOU!!!!

i didn't know why i needed actiontec switch to linksys wan then linksys switch to aniontec wan.

Can anyone explain the reasons for that?

Is it because of the two bridges that were created?

yubin7

join:2008-02-17
Desoto, TX
First, sorry gents for not responding, I've been under the weather the last couple of days. If anyone has any questions or needs any help, please let me know and I'll do what I can for you.

For the previous comment made by cookymonsta.....

The actiontec lan -> Linksys WAN and Linksys Lan -> actiontec Wan is simple.

the actiontec bridge passes the external information through to the linksys and then the linksys uses it's own dhcp and provides all LAN ports with ip addresses. The actiontec still needs an ip with internet access for the VOD to work. there for, the actiontec will pull an ip on it's own WAN port thinking it's the internet and the linksys provides it one.

Kind of circular thinking, but it works.

baygins

join:2002-06-18
Arlington, VA
The real question is, why doesn't Verizon setup a small side data channel using an "unused" frequency for the STB to get the VoD data without having to get a separate IP from the router.
Think about the 2B+D in the ISDN World.

BKJ

join:2006-02-27
Woodbridge, VA
reply to yubin7
Yubin, a present is in the mail heading your way!

yubin7

join:2008-02-17
Desoto, TX
Xmas came early!!! Thanks a lot bud. You really shouldn't have.

SnipingWaste

join:2008-02-20
Garland, TX
reply to Yubin
I can get VOD to work now but play back is very chopping. Any way to fix that?

SnipingWaste

join:2008-02-20
Garland, TX
reply to Yubin
Sorry I should post the router I'm using too. Its a Linksys SRX 200 also known at WRT54 GX2. Every thing works with the linksys doing all the routing but the VOD is very choppy with artifacts in the video and the sound cutting in and out.

yubin7

join:2008-02-17
Desoto, TX
Sniping, I had that problem at first, but it all works smooth now. It could just be your router, but I don't think so.

Mine was choppy for about a day, after that it was fine


More Fiber
Premium,MVM
join:2005-09-26
West Chester, PA
kudos:32
reply to SnipingWaste
Did you try setting QOS for the VOD?
QOS in on for VOD by default in the Actiontec.


Raere

@verizon.net
reply to Yubin
You are a god among men Yubin. I've been waiting for an easy guide, and yours worked. Many, many thanks.

yubin7

join:2008-02-17
Desoto, TX
Raere, thanks for the kudos, but I did this for the many people out there who are as frustrated as I was with all of the other How-Tos. I hope everyone else finds this an easy guide as well.

-Yubin


More Fiber
Premium,MVM
join:2005-09-26
West Chester, PA
kudos:32
Why don't you submit your instructions to the FIOS FAQ:

»Verizon Online FiOS FAQ


rtcy_at_work

@level3.net
can this be made to work for those of us that have ethernet turned on ?

I will attempt it, but I might as well ask. I tried all of yesterday and failed. will try to apply these steps to my set up and see where it gets me.

any help from those that have done it is welcomed