dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
6601
share rss forum feed

YqE41k24
Premium
join:2004-05-02
Tarrytown, NY

Actiontec and "static connections", "static lease types"

I want to pre-assign some of my MACs to fixed IP addresses. This is often done via something called static DHCP. It looks like the Actiontec MI424-WR supports static DHCP, but I can't make it work. Has anyone done this? Any special tricks that I should use?

Here's what I'm trying:
Open the router's web page, select Advanced -> IP Address Distribution -> Connection List. And then there seems to be two places to mark things static. There's a "New Static Connection" button, and if you click on the middle icon in the Action column (Edit), there's a checkbox for Static Lease Type.

But these settings don't seem to stick. If I create a new static connection for a MAC, the host, IP and address doesn't appear in the DHCP Connections list. And Static Lease Types eventually go away.

If anybody knows anything about this, I'd like to hear it.



cdru
Go Colts
Premium,MVM
join:2003-05-14
Fort Wayne, IN
kudos:7

Your doing it right. The current firmware version is broken. You may be able to revert to the previous version of the firmware (dated February IIRC). However version has a habit of forcing upgrades and the latest version will eventually revert back, despite trying to prevent it.

I finally got frustrated enough with that along with a small NAT table causing lockups that I put the AT router behind my WRT54GS running DD-WRT. The only thing the AT router is there for is the EthernetMOCA bridge for TV service.


YqE41k24
Premium
join:2004-05-02
Tarrytown, NY

I was using it as a bridge also, but my prior router tops at 12Mbps. Perhaps I'll play around with alternate DHCP servers. Thanks for the confirm on the broken firmware.



cdru
Go Colts
Premium,MVM
join:2003-05-14
Fort Wayne, IN
kudos:7

said by YqE41k24:

I was using it as a bridge also, but my prior router tops at 12Mbps. Perhaps I'll play around with alternate DHCP servers. Thanks for the confirm on the broken firmware.
If you have another router that does support static DHCP, you can also just disable the DHCP server on the AT and use the DHCP server internal to your other router. You'll need to run a patch cable between the routers. Be sure to use one of the switched ports on the other router and leave the WAN port empty.

tmuth

join:2008-12-04
Bethesda, MD
reply to YqE41k24

A solution that worked for me was to export the configuration file, make a backup copy, then edit it manually with a text editor. Just look for the MAC Address of the device, then you can set the parameters you like and reload the config file. Below is the config for one of my entries:

          (10
(visible_to_dns(1))
(ip(192.168.1.211))
(hostname(elevendottwo))
(start_time(1228410561))
(end_time(1228496961))
(uid)
(hardware_mac(00:0c:29:bc:eb:0c))
(is_dynamic(0))
(valid_time(1))
(is_ms_null_terminated(0))
(is_abandoned(0))
(stability(2))
(is_ever_acked(1))
(is_hostname_fixed(0))
(vendor_id)
(is_detected(0))
(display
(client_type(default))
)
)


Did I mention you should back up the file before making any changes? ;)

Good luck,
Tyler