dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
61244
share rss forum feed

antoine7

join:2009-02-25
K1T4N5
reply to Guspaz

Re: Single-link MLPPP on Windows with Virtualbox (instructions)

I have seen some posts that these Single-Link MLPPP instructions only work on computers that plug directly into the DSL modem. Is this true, and could this be causing my issue in my earlier post?

Is there no way to get them to work if you have a router between your computer and your DSL modem? This is my situation right now - I have a DLINK DI-655 gigabit router between my DSL modem and my computer.

Thanks,
Antonio

mhartman
warty

join:2008-11-29
Kingston, ON
Works fine for me and I have a router between me and the modem.

omarak22290

join:2009-01-23
Scarborough, ON
reply to Guspaz
It doesn't work for me for some reason. I have to set up a static IP and when I did, my internet stopped working. Maybe I wasn't doing it right. I haven't set up a static IP in a while so I forgot how to set it up properly.

phil615

join:2008-01-24
reply to Guspaz
Hey antoine,

Your not alone. I'm using DI-604 and an airport express. Couldn't get it to work. I think I'm going to retry today with a fresh mind. Not the same setup as yours but I'll keep you posted nevertheless.

Phil


QCTLG

join:2008-01-20

1 edit
reply to antoine7
Antonio,

I have the same router and it works great here.
When you launch Virtualbox, you need to disconnect your connection and then reconnect and it then connects through Virtualbox.

Anyways that's the way it works for me.

Good luck


arxa

@dsl.sentex.ca
reply to Guspaz
Anyone know if this method will work with non-TSI MLPPP-enabled ISPs? Mine is Sentex, and I get stuck at 20/22. The ZS PPPoE interface won't connect:

Connect: ppp0 /dev/pts/0
LCP: timeout sending Config-Requests
Connection terminated.
Using interface ppp0
Connect: ppp0 /dev/pts/1
tcflush failed: Bad file descriptor
Exit.

ETH00 is definitely bound to host interface. Can't ping google.

omarak22290

join:2009-01-23
Scarborough, ON

1 edit
reply to Guspaz
I got everything to work properly. The only problem I have now is port forwarding. I followed the instructions from earlier in this thread and I still get that yellow exclamation mark in uTorrent. I also have a question. I frequently use RapidShare to download files and to get around the wait after downloading files, I usually renew my IP (I would reconnect to my PPPOE connection). Is there anyway I can do that with this?

Thanks


arxa

@xDSL-1mm.sentex.ca
reply to arxa
Never mind, I found the problems ... I needed to connect directly to the modem instead of through the router, AND my ISP does NOT support MLPPP.


l0thar

join:2005-12-29
Far Far Away
kudos:1

1 edit
reply to Guspaz
Big thank you to Guspaz for such a nice, easy to follow guide to set this up. Well done!

Followed it, and got ZS working.

Although it seems some days the infernal, hellish throttling boxes seem to detect p2p traffic even if I am using ZS, and uTorrent alpha 1.9, with all the encryption on.

EDIT : just found the Port Forwarding instructions in the other thread ( »Re: Single-link MLPPP on Windows with Virtualbox (instructions) ) and thanks again, it's nice to see the Green light on uTorrent while running ZS. Speeds are up, let's see how it goes for the next few hours.


scegg

@163data.com.cn
reply to Guspaz
After I install path C100, I cannot start ZeroShell again.
lots of "FAILED".


b34tBoX
Premium
join:2003-12-28
Ontario, CAN

3 edits
reply to Guspaz
I got it working connecting directly to the modem.
However behind my router (DIR-655) I cannot attach the virtual machine to my host for networking.
Unable to ping anything while in shell prompt. (or do step 22)
What options in the router interface should I change to allow connectivity? (ie. port forwards..etc)
--
All Your Bass Are Belong To Us.


Ocean69

@teksavvy.com
reply to Guspaz
Hey,

I am having a a host not found error. on step 22. I saw that someone earlier had this but nobody answered the fix....I did read ALL the pages. I have talked to teksavvy so my internet was set up right (he said not to play around with the internet address just check off the box in networking..settings...multi link) He said DON'T do what the thread says to just tick the box.

Guspaz replied earlier "Case sensitivity would give you a 404 error, not a host not found error."

I am running thompson st516 v6 (one connection lol) and no router.

can anyone help?

tks


l0thar

join:2005-12-29
Far Far Away
kudos:1

1 edit
reply to Guspaz
Maybe it's time to update some of the links on the original (and excellent) post?

** Virtual Box 2.2.2 has been released, and can be found here : »download.virtualbox.org/virtualb···-Win.exe -- This is both x86 and 64 bit versions in one package.

Poking around fixppp.org, there is a newer alpha version of the mlppp module : »fixppp.org/downloads/zeroshell-m···.tar.bz2

Guspaz has mentioned an alpha 8 version is on the works, but the 5 is the last one linked to the web site directly.

Command to get it directly from ZeroShell command line becomes :

 
wget http://fixppp.org/downloads/zeroshell-mlppp-mz1alpha5.tar.bz2
 

... instead of the "ZeroShell-MLPPP-1.0beta11-mp1alpha3.tar.bz2" mentioned in the original post.

Hope these updates are OK and beneficial to people.

EDIT : had some problems with this new VirtualBox, so I am back to 2.1 version. :(

New is not always better, it seems.
--
Compare prices for Canadian retailers, Find 'Hot Deals', meet nice people at PriceNetwork.ca


l0thar

join:2005-12-29
Far Far Away
kudos:1

1 edit
Responding to my own post above...

Today I got a newer version (alpha 8) of the mlppp package installed.

As part of that process, I had to get an update for ZeroShell, which is described at »www.zeroshell.net/eng/patch-details/#C100

Turns out this is probable an important update - it's described as "Security Fix - Unauthenticated remote code execution".

Details of the patch C100 are provided in the link above.

EDIT : This patch was NOT installed by ZeroShell's own 'AutoUpdate' feature, although I have had the ZS running for a time now. I suggest you consider doing it manually.

** Details on how to install mlppp alpha8 (and patch C100) are in this post : »Re: fixppp.org


kpurd

@teksavvy.com
reply to Guspaz
fixppp.org seems to be down i can get as far as step 22 but becuase i can't download the file i guess i'm stuck. Is there another host for this file??


l0thar

join:2005-12-29
Far Far Away
kudos:1
miro was in the same situation as you, fixppp is still dOWN due to the host provider moving locations.

If someone has a local copy of the mlppp alpha3 or alpha5 modules, it would help a lot of people if they attached the file to this thread.

Time unknown until fixppp is back up, and without the mlppp module, you can't finish your installation completely.


kpurd

@teksavvy.com
reply to Guspaz
dang... well atleast i'm just that much closer i guess. great guide so far though. I have zero experince setting any of this up but i was able to set it up with ease just following the steps.


Shikomu

join:2007-11-16
Ontario
Reviews:
·Start Communicat..
Spikestabber offered to Host Fixppp.org we are hoping Guspaz takes him up on that offer . I'm in the same boat waiting to get alpha3. After 2 years on a horrible 2.5 Meg profile as I'm way over the DSL limit I finally get put on a brand new Remote. Now I'm flying. But I was never throttled for 2 years ( I guess they felt sorry for me.) now first day on a remote and Throttled at 30 Kb. My virtual Box is ready to role just need the alpha3 MLPPP for virtual box.


l0thar

join:2005-12-29
Far Far Away
kudos:1
Adding myself to those waiting and needing a copy of the alpha3 or 5 mlppp.

Installed Zeroshell to the hard disk in a spare machine today, considering using it as our home router (much more powerful than any off the shelf consumer grade router).

All went well, except I can't install the alpha8 mlppp module on it, as we found out yesterday it does not work on a 'virgin' zeroshell install (works well for upgrading older mlppp versions, just not as the very first mlppp install).

miro, really nice news that you got into a remote, congrats!


Shikomu

join:2007-11-16
Ontario
Reviews:
·Start Communicat..
Its funny everyone in my Area are on Cable as DSL was way too far away. I stuck it out. Modem tweaks you name it. I actually e-mailed Kevin Krull and bitched and bitched. I saw trucks digging for months. Saw remote boxes put up and everytime I asked they said no remotes. Now that their live they probably looked and there was I the lonely DSL teksavvy guy, I guess they had to put someone on the remote


l0thar

join:2005-12-29
Far Far Away
kudos:1
reply to kpurd
said by kpurd :

fixppp.org seems to be down i can get as far as step 22 but becuase i can't download the file i guess i'm stuck. Is there another host for this file??
A fellow forum member posted a copy of the mlppp alpha5 version on another thread - »**Needed : Zeroshell mlppp alpha module - please attach here .

That could get you up and going, check it out. Second post in the thread has the file attached.


ninja

@dsl.bell.ca
reply to Guspaz
Hi,

what are the prerequisite for this?

I have the High Speed DSL Premium. Do i need to get any extra service?

Thanks,


ninja

@dsl.bell.ca
^^ And i would use the 2wire.


l0thar

join:2005-12-29
Far Far Away
kudos:1
reply to ninja
said by ninja :

what are the prerequisite for this?

I have the High Speed DSL Premium. Do i need to get any extra service?
For now, all you need is to follow the instructions on the first post, install and configure VirtualBox/Zeroshell and all should work.

There's talk in the forums of a charge being added ($4 a month possibly) for mlppp access, if that comes in you would have to contact Teksavvy and opt in for that service.

Right now, it works without needing anything other than what Guspaz described in the first post.


l0thar

join:2005-12-29
Far Far Away
kudos:1
reply to l0thar
And another gentleman attached a copy of Zeroshell alpha3 version on the request thread.

Thanks Pack Rat and daboom for these, now people can have a choice of alpha 3 or 5 to complete their Zeroshell mlppp installs.

Get the archives from posts #2 (alpha5) or #6 (alpha3) on this thread : »**Needed : Zeroshell mlppp alpha module - please attach here


Shikomu

join:2007-11-16
Ontario
Thanks to all that helped get the files etc....

I'm running Zero-Shell Alpha 5 . I was getting BSOD but saw a few go to Virtual Box 2.1.2 in this thread and so far so good.
Throttle is GONE !!! No BSOD so far.


l0thar

join:2005-12-29
Far Far Away
kudos:1

1 edit
Jion, Cheers to that!

Well done, I am opening a beer to commemorate your completion, plus the beautiful weather we have today.

Best time of the year, this is.


Shikomu

join:2007-11-16
Ontario
I 2nd the Beer and weather salute !!!!

frozenclaw

join:2009-06-04
Canada

1 edit
Hi guys, I have a wrt54g w/ micro DD-WRT router and only 1 Lan chip on my PC, I managed to download everything but I'm stuck on step 22 and I wonder if it's because I need more than 1 LAN chips. My setup currently is:
Speedtouch Modem
wrt54g micro DD-WRT
2 wired computers and 2 wireless.
Edit: I only have 1 line.

I'm very confused as to what to actually do at this point and would appreciate any help.

Thanks!


jp_zer0

@bell.ca
reply to Guspaz
^ above poster: What do you mean stuck? Do you get an error after entering the code?

---

But I also have a problem of my own: My processor does not support virtualization. I have a 3ghz E2160 (core 2 duo), does anyone have a rough idea of the performance it'll cost me? Simply having zeroshell open in a virtual box doesn't tax my CPU, but I can't set it up to do anything as I'm on Sympatico at the moment.

Does anybody have any experience running virtual MLPPP without hardware virtualization support?