dslreports logo
site
    All Forums Hot Topics Gallery
spc
Search Topic:
uniqs
3721
share rss forum feed

Bigfootbuilt1

join:2002-10-20
Duncan, SC

[Other] FTP - Port Command failed..can't retrieve directory list

I have successfully been able to FTP to my websites with no problems for about 5 years, until now. This is the most baffling problem I have ever had, since I have already swapped out my router and modem as a last resort. I manage 5 websites and 4 of them can't retrieve the directory listing. When I connect without a router and connect straight to the DSL modem, it works fine. When I do use the router, I have the modem set to bridged ethernet as I am supposed to. The error I am getting is "port command failed...can't retrieve directory listing". Here is what I have tried so far...

1.) It is definitely not my DSL modem. When I connect directly with the modem, without a router, I can connect to FTP fine

2.) I have already done a /flushdns in IPconfig.

3.) I have already done the typical power off/power on/reboot procedure numerous times.

4.) I have already tried PASV mode, and tried turning PASV mode off as well.

5.) My login information is correct, and I have problems on multiple sites.

6.) This problem has been reported before by other users of WRT54G, but the other forums I see have no solution to the problem.

7.) I have already tried using other PC's and different FTP clients on my home network. No matter which PC or laptop I use behind the router firewall, I can't bring up a directory listing without a "port command failed" error.

8.) I have never had to open ports to be able to connect to FTP, since I am the one doing the request. But just in case anyone asks, yes, I did also try opening ports 20 and 21.

9.) XP firewall is disabled.

10.) I have tried both ethernet ports on my PC. But then again, that is irrelevant because none of my other PC's which connect wirelessly, can connect either.

11.) I have already tried manually changing the MTU value in the router settings as instructed by the FAQ's on Linksys.

12.) I have upgraded my firmware to 1.02.5

13.) Exchanged the WRT54G ver 5 router for a new WRT54G ver 8 router and upgraded to latest firmware again.

14.) Exchanged my old Westell AT&T DSL modem for a new Motorola modem.

15.) Narrowed the port range in my FTP clients to 55536-55546

Here is the full text of my session as an example. My IP address is different from the one listed in the next line. Is that supposed to be the remote server's IP address?...

Resolving ritracin.startlogic.com...
Connect socket #736 to 66.96.134.32, port 21...

USER ritracin
331 Password required for ritracin
PASS **********
230 User ******* logged in
SYST
215 UNIX Type: L8
Keep alive off...
PWD
257 "/" is the current directory
PASV

PORT command failed
Error loading directory...

Any help would be appreciated.