dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
5051
share rss forum feed


vukodlak75
Nisam Ti Dude
Premium,MVM
join:2001-10-27
Willoughby, OH

1 edit

opensuse 11.1 mounting external ntfs

I cannot get my external (WD 500 GB) ntfs USB drive to mount. Keep getting an error about "Cannot get volume.fstype.alternative".
I did a research and found some bugs reported about ntfs-3g.
But I don't have a clue on how to fix this. My internal ntfs drives get mounted and I have read/write privileges.
--
We've never considered divorce... murder sometimes, but never divorce.


No_Strings
Premium,MVM,Ex-Mod 2008-13
join:2001-11-22
The OC
kudos:6
Can you post the last part of dmesg after you plug in the device?


vukodlak75
Nisam Ti Dude
Premium,MVM
join:2001-10-27
Willoughby, OH
 
The 2 attachments are the errors I get after plugging in the drive.


No_Strings
Premium,MVM,Ex-Mod 2008-13
join:2001-11-22
The OC
kudos:6
I don't know what that stuff is. Too GUI-fied.

dmesg, please.

What kernel, by the way? I fought with an external enclosure for hours and finally fixed it by moving to a newer kernel - 2.6.27.7 in my case.


vukodlak75
Nisam Ti Dude
Premium,MVM
join:2001-10-27
Willoughby, OH
downloaddmesg.txt.zip 5,283 bytes
Kernel 2.6.27.19-3.2-pae

OK, I just ran dmesg in terminal and saved it as a txt file. Hope that was what I was supposed to do. I had to google dmesg and get some info on it.
--
We've never considered divorce... murder sometimes, but never divorce.


nwrickert
sand groper
Premium,MVM
join:2004-09-04
Geneva, IL
kudos:7
Reviews:
·AT&T U-Verse
reply to vukodlak75
I'm thinking it's some sort of communication problem.

I have an external 160G drive that mounts just fine on my desktop (opensuse 11.0), and on my wife's desktop (with Vista). But it gives me problems on my laptop, whether using WinXP or opensuse 11.0).
--
AT&T dsl; Westell 327w modem/router; openSuSE 11.0; firefox 3.0.6


No_Strings
Premium,MVM,Ex-Mod 2008-13
join:2001-11-22
The OC
kudos:6
reply to vukodlak75
From what I see in the dmesg output, the drive is being recognized and a device assigned. I believe the error is from a configuration or permissions problem. I manually mount via fstab. You're trying to do it with the HAL daemon, and I'm out of my element.

Hopefully, someone who knows more about using HAL can jump in.


adsldude
Premium,Ex-Mod 2003-9
join:2000-11-10
Colorado
kudos:1
reply to vukodlak75
said by vukodlak75:

The 2 attachments are the errors I get after plugging in the drive.
Cannot get volume.fstype.alternative
 
Have you tried to manually mount the USB drive?

mount -t ntfs /dev/sdg /mnt/tmp
 


vukodlak75
Nisam Ti Dude
Premium,MVM
join:2001-10-27
Willoughby, OH
I get the following when trying to manually mount:
wrong fs type, bad option, bad superblock on /dev/sdg,
missing codepage or helper program, or other error
--
We've never considered divorce... murder sometimes, but never divorce.


adsldude
Premium,Ex-Mod 2003-9
join:2000-11-10
Colorado
kudos:1
Time for silly questions! Is this a new drive? Has it been partitioned and formated? If yes, does it work with other machines?


vukodlak75
Nisam Ti Dude
Premium,MVM
join:2001-10-27
Willoughby, OH

1 edit
said by adsldude:

Time for silly questions! Is this a new drive? Has it been partitioned and formated? If yes, does it work with other machines?
It is about a year old WD My Book 500GB formatted in WinXP as NTFS.It mounts in Windows and Mac OS X

I can manually mount it like this:
sudo mount -t ntfs-3g /dev/sdg1 /mnt/tmp
--
We've never considered divorce... murder sometimes, but never divorce.


vukodlak75
Nisam Ti Dude
Premium,MVM
join:2001-10-27
Willoughby, OH
I guess I will be manually mounting/unmounting like so:

sudo mount -t ntfs-3g /dev/sdg1 /windows/WD500GB

sudo umount /dev/sdg1

Kind of annoying but I don't use this drive too often on Linux.
--
We've never considered divorce... murder sometimes, but never divorce.

salahx

join:2001-12-03
Saint Louis, MO
reply to vukodlak75
I think I know what might be going on here. Recently, ntfs-3g went all UTF-8, and it no longer recognized the locale option. With gconf-editor, go to /system/storage/default_options/ntfs_3g. If "locate=" is there, remove that value.


vukodlak75
Nisam Ti Dude
Premium,MVM
join:2001-10-27
Willoughby, OH
Will try that when I get to work tomorrow.
Thanks


vukodlak75
Nisam Ti Dude
Premium,MVM
join:2001-10-27
Willoughby, OH

2 edits
reply to salahx
said by salahx:

I think I know what might be going on here. Recently, ntfs-3g went all UTF-8, and it no longer recognized the locale option. With gconf-editor, go to /system/storage/default_options/ntfs_3g. If "locate=" is there, remove that value.
That didn't work

--
We've never considered divorce... murder sometimes, but never divorce.