dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
6696
share rss forum feed


Matt3
All noise, no signal.
Premium
join:2003-07-20
Jamestown, NC
kudos:12

1 edit

[Vista] Disable Infrared Device in Device Manager?

Hello Folks,

I have a problem that is driving me nuts and I'm hoping someone here has an answer. I have a Dell Studio XPS 13 laptop that has a Microsoft eHome Infrared receiver that allows a standard media center remote to control the laptop. My problem is that I have an HTPC downstairs where I use my laptop so whenever someone uses the remote (It's apparently not strictly line of sight) it controls my computer -- no matter what application I'm in. Scrolling up and down, pressing enter, or opening Vista Media Center ... the remote does it all, only, I don't want it to.

The BIOS has no setting for disabling infrared and when I go into the device manager, I have two devices listed; ITECIR Infrared Device and Microsoft eHome Infrared Receiver. However, when I right click, go to properties, choose the driver tab, disable is greyed out.

I am prompted by UAC when I open computer management, so it should be running as admin and I can disable other devices.

Any ideas? This is driving me nuts and I'd rather not call Dell Support.



Cudni
La Merma - Vigilado
Premium,MVM
join:2003-12-20
Someshire
kudos:13

not a tech answer and while you wait for one but place something over it (assuming it is visible)?

Cudni


OZO
Premium
join:2003-01-17
kudos:2
reply to Matt3

I know it's Vista, but can you try devcon: The DevCon command-line utility functions as an alternative to Device Manager and run: devcon listclass Infrared
--
Keep it simple, it'll become complex by itself...



45071419

join:2006-07-30
reply to Matt3

Probably not, but is there a Fn key to disable like the wireless radio and bluetooth?



45071419

join:2006-07-30

And instead of R-click -> Properties on the device, what happes when you try open the + next to the Device -> R-Click on the defvice -> Disable.



Matt3
All noise, no signal.
Premium
join:2003-07-20
Jamestown, NC
kudos:12
reply to Matt3

Thanks everyone but I figured it out. Under the Human Interfaces Devices category, there were several generically named HID-compliant devices listed. When I looked at the properties of each of them, they were attached to the Microsoft eHome Infrared Receiver. When I disabled them all, I still couldn't disable the two I named earlier, but the infrared receiver is no longer responding.

Thanks for the great suggestions!