dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
8941
share rss forum feed


yaplej
Premium
join:2001-02-10
White City, OR

Getting Putty terminal to work with HPUX.

Hey all,

I am trying to get Putty to work with out HPUX box. It seems to work fine for just text, but our users login, and get an application prompt that is more "graphical" in the sense it has menus, prompts, and such. These are not working well with Putty, and I have not been able to figure out what gives.

In Putty I have tried about every "keyboard" Function keys and keypad setting available, and still cannot navigate the menu. The menu does display, but it cannot be navigated using the arrow keys like normal. If it helps NetTerm works out of the box so perhaps its something Putty just does not support.

Just wondering if anyone here might have a clue, or where I could start looking.

Thanks.
--
Open Source WAN Accelerator
»trafficsqueezer.sourceforge.net/

pablo
MVM
join:2003-06-23
kudos:1
Howdy,

Putty emulates an xterm. Are you sure you have your Unix login's TERM variable set accordingly?

Cheers!
--
pablo
openSUSE 11.0;KDE
ISP: TekSavvy DSL; backhauled via a 6KM wireless link


greEd

join:2001-05-28
Odenton, MD
reply to yaplej
Under Terminal -> Features

Have you tried "Disable application keypad mode"?
--
»www.computerglitch.net


yaplej
Premium
join:2001-02-10
White City, OR
Just tried that without any change.


yaplej
Premium
join:2001-02-10
White City, OR
reply to pablo
I am not sure they are set correctly. Just that NetTerm works correctly, and putty does not. I have also tried TeraTerm Pro, and have not been able to get it to work correctly either.
--
Open Source WAN Accelerator
»trafficsqueezer.sourceforge.net/


nixen
Rockin' the Boxen
Premium
join:2002-10-04
Alexandria, VA
reply to yaplej
Render issues are generally related to what termcap entry your host tries to use to talk to your terminal software. You might try to see if there's a "custom" termcap you can install. I've only rarely used PuTTY with HP/UX. I don't require any specific issues that didn't work out with the use of the XTERM termcap and some "stty" defines.
--
The trouble with the world is that the stupid are cocksure and the intelligent are full of doubt. -- Bertrand Russell


nwrickert
sand groper
Premium,MVM
join:2004-09-04
Geneva, IL
kudos:7
reply to yaplej
You could experiment with setting TERM=vt100
in your environment. If that helps, then you can put something in your shell profile to automate that.
--
AT&T dsl; Speedstream 5100b modem; openSuSE 11.0; firefox 3.0.11

pablo
MVM
join:2003-06-23
kudos:1
reply to yaplej
If you're not sure whether it's set correctly, that may be the source of your problem. Try nwrickert's experiment and also try with TERM=xterm


koitsu
Premium,MVM
join:2002-07-16
Mountain View, CA
kudos:23

2 edits
reply to yaplej
Does HPUX have termcap or terminfo definitions for xterm? Are they accurate?

One workaround I've heard of is to try export TERM=dtterm. I've seen this done on Solaris, and it "works mostly", but I've also seen line wrapping problems and other oddities (again, because it's not xterm).

DO NOT use vt100 like someone else recommended. xterm != vt100. Some escape sequences are the same, but many (I repeat: MANY) are not. You'll end up with gobbledegook for output. PuTTY emulates xterm, not vt100. If you want a vt100 emulator, try SecureCRT.

Otherwise, I'd recommend getting the official xterm termcap from the xterm site; you don't need to build the xterm binary, just pull the termcap entry out of the documentation (it's in there somewhere). You can also try the putty terminfo/termcap definition, but I've tried it and it doesn't work that well (funny that, eh?)

If HPUX uses terminfo, you'll need to build a terminfo db based off of a terminfo description for xterm. That's probably also in the official tarball somewhere. Or you can try Eric Raymond's page. You'll probably need to use tic(1) to compile such. I make no guarantees if HPUX's tic understands all of the terminfo definitions.

You can do all of this per-account (well, at least on Solaris/BSD/Linux; I assume HPUX offers similar capability) by doing something like export TERMINFO=$HOME/.terminfo, then placing the terminfo directory structure generated into there (you'll have a file/path like .terminfo/x/xterm, for example). I had to do this for some of our Solaris machines at work, since the stock Solaris xterm definition didn't have 256-colour capability (only 16; the 256 capability is an extension).

Hope this helps.
--
Making life hard for others since 1977.
I speak for myself and not my employer/affiliates of my employer.