dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
3504
share rss forum feed


danybp

@verizon.net

Port Forwarding Stopped Working.

wireless function of my router wasnt working properly(due to signal interference) so i called in verizon help service.

she asked me to reset the router and i did. after setting wireless channel to 11 every thing works fine.

however, PORT FORWARDING STOPPED WORKING ANYMORE.(it was port forwarded for past 7 month)
i did everything i did when i first got the router.
Set Static IP, Port forward, and set DMZ when that didnt work.

however no LUCK. i asked someone who had same router to give it a try and he cant get my router to port forward. (his router is port forwarded fine)

does resetting removes firmware or something?
i currently have 4.0.16.1.56.0.10.11.6
Hardware Version D

(for some reason when i go to advanced-firmware update and click on "Current Version 4.0.16.1.56.0.10.11.6" it shows hardware version as 9A)
and ofc the router is MI424WR

PS. do not link me portforwards.com. thats the first thing i tried.)

it will be greatly appreciated if someone can help me out.

i struggled for past 2 weeks


danybp

@verizon.net
just realized that when i set DMZ. all UDP is open. but all TCP is closed.

i resetted router 8 times and all 8 times only UDP was open


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9
reply to danybp
If you reset the router, that is, you press the little button with a paper clip or select the Advanced item to Restore Defaults, you have to set your Port Forwards (and everything else) again.

If, however, you turn the router off then turn it back on, you haven't changed your config at all. It will be the same as you had it before.

It never hurts to reset to defaults then build the config again. Some things get cleaned up from before. Sort of like fresh install of an OS. It's remarkable how old stuff can get cleaned up that way.

All it takes is time.


danybp

@verizon.net
reply to danybp
yes i rested by holding the button down for 30 sec with pen

and ofc i did the port forwarding again.

however, what i am trying to say is that it doesnt work anymore.

and i asked someone who portforwarded his router(same model)

and he cant figure out why mine wont portforward


More Fiber
Premium,MVM
join:2005-09-26
West Chester, PA
kudos:32
reply to danybp
I seem to recall another post in the last month or two where port forwarding stopped working. I did a quick search for the post, but did not find the one I was looking for.

IIRC, VZ sent a replacement router.


danybp

@verizon.net
reply to danybp
did that work?

i already had them send a diff router. they sent me a used one

and this one have exactly the same problem.

could it be coincidence that this one has same problem?

thx


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9
reply to danybp
Ok, getting ready to dig into this.

Describe your network, what's connected to LAN, what is in the DMZ, and what application needs the port forward.

Finally, please post a screenshot of your portforward status page.


danybp

@verizon.net
reply to danybp
my wireless laptop and wired desktop is connected currently.

and DMZ is set to 192.168.1.4(which is the static IP of my wireless laptop)

and i am trying to port forward uTorrent.

as i said before only UDP is open and TCP is closed.


danybp

@verizon.net
reply to danybp
and here is Tinypic Img of
my portforward status
»tinypic.com/view.php?pic=29m22o6&s=4


More Fiber
Premium,MVM
join:2005-09-26
West Chester, PA
kudos:32

1 edit
Why do you have a port forward from your public IP address to your laptop?
This is not needed and should NOT be used unless you have a VZ assigned static IP address. Your DHCP address can change unexpectedly.

When you specify the laptop's IP address on the DMZ screen, all packets not otherwise redirected will be sent to the laptop. No port forwarding is necessary to the DMZ machine.


danybp

@verizon.net
reply to danybp
just realized the public ip is still there. dam it.

i asked someone to help me and he put it there.

but that one was put AFTER proper port forwarding didnt work (which you see in the picture)

so ignore that public ip thing plz

and for DMZ. i put that up AFTER i found out portforwarding didnt work.


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9

2 edits
Click for full size
PF step 1
Click for full size
PF step 2
Click for full size
PF step 3
Click for full size
PF step 4
Click for full size
PF step 5
Click for full size
PF step 6
Click for full size
PF step 7
Click for full size
PF step 8
Couple of things. First: upload graphics to DSLR. Too many steps to view a usable image on tinypics. Click on Preview/Attach button, then just under the post preview is a button + upload attachments. Click on that, browse to your image, give it a caption, then click upload.

Next, it appears uTorrent only needs TCP forwarded to one port. You are using 62355. Delete the uTorrent (UDP) port forward, and delete the PF at the bottom, if you haven't already done that.

Also, because your TCP PF says Any for WAN Connection type and that doesn't correspond to a valid option in my Rev A Actiontec, I'd suggest you drop that PF as well, and build it fresh. Use these steps.

First, verify the port uTorrent is using. Also verify the IP address of your laptop.

1. Navigate to your Port Forward status page, at the bottom click Add.
2. Enter the IP address for your laptop. In my example I used 192.168.1.24. (PortForward.com says you need to use a static IP, but I don't think that's required since the Actiontec generally remembers a DHCP address handed out. If you have problems with that, you can make your laptop IP a DHCP reservation. Subject of another post, for now.) Under Protocol/Specify Protocol, click Add.
3. Name the protocol. I used uTorrent. Under Server Ports/Protocol, click Add Server Ports.
4. Select Protocol dropdown, choose TCP. Select Destination dropdown, choose Single, then enter port number 62355. Click Apply.
5. Click Apply to complete the Protocol rule.
6. Click Apply to complete the Port Forward.
7. Final result. Click Apply to make it stick.
8. You know it will work if you get back to the nag screen to click Yes for Firewall settings.

If that doesn't work for you, you may have other problems in your router config. Some other options would be to do a hard reset back to factory defaults, and try it again using these steps.

Another option would be to open up router for Remote admin, or PC for Remote Control and let someone work it from outside.

[edit to correct screenshot, also to add]Also, drop the DMZ assignment. You'll have better NAT security by setting the PF.


danybp

@verizon.net
reply to danybp
tried that and no luck.

let me just reset the thing and try again tomorrow. kinda busy today.

i will post how it goes with picture uploaded correctly

thx.


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9
Also, check to make sure your PC firewall isn't contributing to the problem.

Dark Knight

join:2009-10-04

2 edits
i has similar problems where my actiontec was messing up ip distribution and port forwarding rules...they sent a new one and seems to be working again


danybp

@verizon.net
reply to danybp
ok that did not work after resetting the router.

can i ask you what is so diff in what you did?

all that guide did differently was to open TCP only

which didnt do anything.

i hear bridging router can solve this?
i have one wireless router hanging around anyway.

thx for the help again


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9
Click for full size
TCP and UDP uTorrent Port Forward
Couple of questions:

1. Are you using application from »www.utorrent.com, also what OS and firewall software?

2. How do you know it is not working? Is the red circle with exclamation mark showing as network status icon?
quote:
red network light The red light means that µTorrent was unable to bind a listening socket. Most likely, this means a firewall is blocking it. It's also possible that another torrent client is using this port, which will require you to change ports, or not run both clients at the same time.
Try a different port number.

3. A single TCP port is needed. UDP is used if you've specified DHT (whatever that is) in uTorrent. You can edit your existing protocol in the router's port forward rule that you did in step 4. Click "Add Server Ports", choose UDP from Protocol dropdown, select Destination dropdown, choose Single, then enter port number 62355. Click Apply. Click Apply until you get back to the nag screen to click Yes for Firewall Settings.

However, from what I read, the single TCP port forward should be enough to get you a green Network Status light in uTorrent. Go back to your Windows Firewall Settings unless you're using something else. Remember, if you use a different port, your Windows Firewall rule will change as well.

I don't think there's a problem with your router port forward if you followed the instructions I posted above, and your screenshot looks like the one above. This one is updated to show the UDP protocol added.

4. In router's Advanced / Universal Plug 'n Play, what are the settings?


danybp

@verizon.net
reply to danybp
first of all let me say ty for helping

1. i have windows firewall(and i turned it off) so no firewall

2. i know its not port forwarded cause i clicked utorrent "port test"
which directs me to website for testing port

and i also use "port forward" port test program.
(however, it shows as green as open but i know thats not true because it takes so long to upload now)

and i tried numerous ports but none work.

3. ive tried that no luck

4. it had check in first box and no check in second box.

but i changed to check in first and second

as i said i asked other people to config ports forwarding for me.
they have same router and their routers are port forwarded.
still they cant find out wut is wrong with my router.

what is this pc remote access thing you told me about?

thx again


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9
What's the status of UPnP in the router? Disable it.

Go to Advanced / Universal Plug and Play, then uncheck "Allow Other Network Users to Control Wireless Broadband Router's Network Features".

Checking to make sure I read you correctly: uTorrent network status shows green but uTorrent's website-based port test fails, and PortForward's port test program also fails? You've changed ports but that doesn't work?

I'm not sure what your comment on checkmark boxes signify. Settings in uTorrent?

PC remote access basically lets someone else use their keyboard, mouse and screen to control your PC. It's the same as if they were sitting there at your desk. If you have Windows running, it may already be enabled. Other non-Microsoft programs like it require a port forward on your router. It may be possible for someone to look at your PC to try to find the source of the problem. Liability issues abound with unknown third-parties across the internet, so you really want to use local resources.

jimboe

join:2000-08-14
New York
said by birdfeedr:

What's the status of UPnP in the router? Disable it.

Go to Advanced / Universal Plug and Play, then uncheck "Allow Other Network Users to Control Wireless Broadband Router's Network Features".
...
Wow.

I was having the same exact trouble and found this thread.

I did what you said, and Wah La!

Now port fwd'inf works.

What the hell would unchecking that feature in UPnP have to do with successfully port forwarding???

Thanks BF.


Smith6612
Premium,MVM
join:2008-02-01
North Tonawanda, NY
kudos:24
UPnP tends to have a tendency to override or otherwise delete port forwards all together. Generally when port forwarding it's a good idea to switch it off or to deny changes using it.
--
"All your base are belong to me!"


khalid123

@verizon.net
reply to danybp
I'm in the same boat as the OP port forwarding does not work.

I tried:

-resetting the router (small red button)
-putting the LAN host in the DMZ
-disabling UPnP

I'm scanning from the internet and cannot see any open ports on my public IP.

please help.


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9
said by khalid123 :

please help.
Basic info needed:
quote:
Ok, getting ready to dig into this.

Describe your network, what's connected to LAN, what is in the DMZ, and what application needs the port forward.

Finally, please post a screenshot of your portforward status page.
Hmm. There seems to be an echo.


More Fiber
Premium,MVM
join:2005-09-26
West Chester, PA
kudos:32
reply to khalid123
said by khalid123 :

please help.
And what router?


khalid123

@verizon.net
router: MI424-WR

firmware: 4.0.16.1.56.0.10.11.6

internet---router---PC (wired)

I'm trying to forward ports 80, and 22000, I have tried the built-in port config (from the drop down list), but also added custom ones.

I disabled forwarding and put the host in the DMZ, still nothing.

ps: I'm a sys admin, feel free to be as technical as you needed.

TIA


More Fiber
Premium,MVM
join:2005-09-26
West Chester, PA
kudos:32
said by khalid123 :

I'm trying to forward ports 80, and 22000, I have tried the built-in port config (from the drop down list), but also added custom ones.
Keep in mind there are three pairs of IP address / port numbers involved with port forwarding:
  • The source IP address / port of the originating machine. You should always set this to ANY/ANY.
  • The external IP address / port on your router. The external IP address is determined by your WAN DHCP address. For external port, you can pick any port number you want.
  • The destination IP address / port on your LAN where your want to forward the traffic.

Very often when port forwarding is not working, it is because the source IP address / port has been specified as the external IP address / port.

Also, what's the status of UPnP in the router? If it is enabled, then disable it.
Go to Advanced / Universal Plug and Play, then uncheck "Allow Other Network Users to Control Wireless Broadband Router's Network Features".


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9
reply to khalid123
With "also added custom ones", I think it would be useful to see a screenshot of your portforward page. Should be similar to PF 7 screenshot above.


khalid123

@verizon.net
reply to danybp
Click for full size


UPnP is disabled.


birdfeedr
Premium,MVM
join:2001-08-11
Warwick, RI
kudos:9

1 edit
Port 80 looks ok if you have a listening server. Change the ssh to All Broadband Devices, since there can only be one active, there should be no security risk.

Make sure you Apply until you get to the nag screen to take you back in to Firewall Settings.

[edit to add]Your ssh rule says your internal server is listening in on port 22 to whatever comes in on outside port 22000. If I'm reading it right.
Also, you've cropped your screenshot right down. Make sure you don't have any conflicts that would interfere with what's visible to me.


khalid123

@verizon.net
reply to danybp
I came across people with similar issues on the office Verizon FiOS forums, and got my solution from there: resetting the router twice in a row fixes the issue, weird but it worked.

thank you everyone for your help.