dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
3761
share rss forum feed

dearsir8

join:2009-11-25
North York, ON

Primus DSL speed

I have recently switched from Rogers to Primus DSL (triple value bundle). The advised speed is up to 7Mbps, however I can only get 4.2Mbps after some work done by the technical support. They have also mentioned my distance is far away from CO but I don't understand why I can't get something close to 7Mbps. Is there anything I can ask Primus to improve the speed on my DSL line?


spepin77

join:2007-12-06

I work for Primus, send me a PM with your phone number, and I"ll see what I can do for you


dearsir8

join:2009-11-25
North York, ON

said by spepin77:

I work for Primus, send me a PM with your phone number, and I"ll see what I can do for you
I have just send you an instant message, not sure if this is the correct way as I can't find how to send a PM.


vbs

@unused.primus.ca
reply to dearsir8

i am also with primus and getting 2 meg down. 500k up. the service was better earlier in the year but hs become terrible. the modem tells me I am syncing at 7mbps down. any ides?


spepin77

join:2007-12-06

Can you also send me your phone number, so I can look into what the problem is?


jcvdxxx

join:2010-02-03
L5R 4O1
reply to dearsir8

Waited 3 weeks of Primus DSL (late modem delivery)

Not impressed by the Speed ...
Advertised 5Mbps D/L ----> Tested 3Mbps D/L -----> Actual D/L speed 1Mbps

Feel my frustrations ????


dearsir8

join:2009-11-25
North York, ON

I have got something close to 5Mbps after escalate to their second line support. I was told this is the best speed I can get and the speed is good enough (but I pay for 7Mbps!).


tedv

join:2005-04-30
Oshawa, ON
Reviews:
·Primus Telecommu..
reply to dearsir8

I too have switched from Rogers to Primus back last summer. I am running a Speedstream 4200 and it seems to be hit and miss. When it works, I'm getting about 4Mbps and 400Kbps up. Sometimes, like now, I am getting horrible speeds. I just ran a speed test using speedtest.primus.ca and I got 1200ms ping time,523kbps down, 233kbps up. I just ran it again and got 378ms ping, 820kbps download and 146kbps upload speeds. Just before posting this, I got 987ms ping, 1751kbps down and 269kbps up. These are all over the place.

I am only about 2km at most to the CO. In DMT, it is showing my Bitrate as 5056kbps, with 23.5db attenuation and 27db SNRM for the downward stream, from what I can tell, are good numbers. (Except I am paying for a 7Mbps connection.) The upstream side lists 800kbps with 11dBm tx power.

What am I missing here that is slowing my down so much? I have not heard great things about Primus, but I really wanted out of Rogers at the time and when it works, Primus has been better than Rogers.

When I called tech support last time when the speed dropped off like this, they basically wouldn't talk to me because I wasn't using their modem. The lady wouldn't even give me the specs that the modem was to be set up to. (Our call went something like this:
"so let me get this right. I can use my own equipment but you can't give me the spec's on what the settings have to be to work on your system?"
"That is correct."
"So even thou I am not asking how to set up my equipment, I am just asking for the spec's, you can't give them to me. That would be like the cellular company saying that you can use your own phone on our network, but we won't tell you any if the spec's that your phone needs to connect and operate on our network."
"All I can tell you is that for us to provide support, you would have to be using our rental modem.")