dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
5256
share rss forum feed

rm12577

join:2010-01-16
Elgin, TX
Reviews:
·Skybeam.net

New ISDN user need help setting up

hey guys, having issues getting my new 804 to connect to my line, the best i have gotten so far was to get it to show the transmit lights but never authenticated, now with my new config that i made through the fast step software then copied to the router through hyperterminal it doesnt even do that... need some help trying to figure out what i need to add or remove to get it to connect already...

heres my config, minus some unneeded info of course like my logins, and spids, replaced by 7 x's each

no service udp-small-servers
no service tcp-small-servers
service password-encryption
hostname ISDN
username ISDN password xxxxxxx
enable secret xxxxxxx
no ip source-route
isdn switch-type basic-5ess

ip routing
ip classless
ip subnet-zero
service dhcp
ip dhcp pool DHCPPoolLAN_0
network 192.168.0.0 255.255.255.0
dns-server 209.124.51.138 209.124.51.215
default-router 192.168.0.1
lease 1 0 0
ip name-server 209.124.51.138
ip name-server 209.124.51.215

interface ethernet 0
keepalive
no shutdown
ip address 192.168.0.1 255.255.255.0
ip route-cache
no ip proxy-arp
no ip directed-broadcast
ip nat inside
ip access-group 121 in

interface bri 0
no ip address
no ip directed-broadcast
no ip route-cache
encapsulation ppp
ppp authentication chap pap callin
ppp multilink
isdn switch-type basic-5ess
isdn spid1 xxxxxxx
isdn spid2 xxxxxxx
dialer pool-member 1
no shutdown

interface dialer 1
dialer remote-name Cisco1
dialer pool 1
no ip split-horizon
description ISP
encapsulation ppp
dialer idle-timeout 2147483
dialer fast-idle 2147483
dialer hold-queue 10
dialer-group 1
dialer string 2200082 class DialClass
ppp authentication chap pap callin
ppp chap hostname xxxxxxx@netonecom.net
ppp chap password xxxxxxx
ppp pap sent-username xxxxxxx@netonecom.net password xxxxxxx
ppp multilink
dialer load-threshold 10 either
ip address negotiated
ip route-cache
no ip proxy-arp
no ip directed-broadcast
ip nat outside
ip access-group 121 in

map-class dialer DialClass
dialer isdn speed 56
dialer-list 1 protocol ip permit

no router rip
ip route 0.0.0.0 0.0.0.0 dialer 1
ip nat inside source list 18 interface dialer 1 overload
access-list 18 permit 192.168.0.0 0.0.0.255
access-list 121 permit ip any any time-range TIME
time-range TIME
periodic daily 00:00 to 23:59

line console 0
exec-timeout 120
line vty 0 4
exec-timeout 0
login local

end

let me know what needs added please!!!! I really want some dependable internet instead of this trash wisp i have right now...



needaname

@alltel.net

I just got my CCNA but unfortunately haven't set up ISDN before. This link might help you out:
»www.cisco.com/en/US/tech/tk713/t···33.shtml

How much is the total cost of ISDN for you?
I'm interested in getting it for gaming purposes.


rm12577

join:2010-01-16
Elgin, TX
Reviews:
·Skybeam.net
reply to rm12577

the line is going to cost me 50 bucks plus the isp cost of 20 a month or 200 a year on top of that, i am still working on getting it configured though, i have been to that site many times, even got the fast setup software but it kept saying it couldnt find the router through the serial port even though i could connect find through the serial cable using hyperterminal, so i used it to make a config and copied it to the router but still no connection, i have two routers and both do the same thing, so i ordered a 3com router from ebay to see if it will be any better, if not I will try netgear and maybe get a pci card or something.... just need to get rid if my wisp already...



needaname

@alltel.net

Have you used the "debug ppp authentication" command on the router?
This will give you a clue as to what part of the authentication went wrong. Type it in and copy/paste the results.

By WISP are you referring to 3g/evdo from a cell provider? (verizon, sprint...) Or a company who has a tower and slaps an antenna on your roof to get service?

$70 a month isn't bad, I wonder what Windstream charges.


aeblank

join:2004-09-07
Cadillac, MI
reply to rm12577

Are you sure about:
isdn switch-type basic-5ess
isdn spid1 xxxxxxx
isdn spid2 xxxxxxx

Mine is:
isdn switch-type basic-ni
isdn spid1 23177977770101 7797777
isdn spid2 23177988880101 7798888

I obviously changed things around a bit so I'm not giving you my phone numbers, but................

My switch type is different. I'd guess you know your switch type, but it does have to be right. I have AT&T in Michigan. Also, doesn't look like you're using your line for voice, but I think your SPIDS are wrong. A spid has 0101 at the end. I (somehow) found that they had to be in the format I use above, otherwise the line won't ring through. (I use mine for voice)

As I work through some ISP issues I'm having, I'm trying to learn more about my configs.

A couple nice things to put in there are:

clock timezone EST -5
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
sntp server 129.127.40.3

Funny you use netonecom. They're about a dozen miles down the road from me right now.


rm12577

join:2010-01-16
Elgin, TX
Reviews:
·Skybeam.net

2 edits

well i got it to dial out once using that for the spids, i had read that most of the old swb areas were still 5ess but I am not sure if I am in an old swb area or not, I might not be, I dont think I ever switched it to basic-ni but I can try it just to be sure maybe that is all that is wrong. I had seen someone else put 0101 after the spid. so for voice to work you just repeat the seven digit spid after the first 14 digits entered? I will configure it that way and see what happens, thanks for the reply. If anybody else has any ideas to try let me know.

O and by wisp I have a 53 foot pole with wires for support and its about 200 feet from my house that connects to a tower 8 miles away, but it has to go through some nasty stuff to get there and that is probably the "interference" maybe the trees grew or something...

set the config again changed router types and changed the way i had the spid's set still not connecting out at all... doesnt even attempt to transmit out, any way you could copy your working config and post it here without the numbers and stuff? i have tried using other's but they never seem to work... I also have a 3com unit on the way to see if that works any better... or if it is easier to config and use...I hate paying for an ISP and line not being able to use it...


aeblank

join:2004-09-07
Cadillac, MI
reply to rm12577

This assumes IOS 12.2-24. It is the newest that will run on the 804 and I found it to be the most reliable.

This is what I"m running, and it works. You can take out my comments (that start with !------).

--------------------------------------------
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
!------tells what flash file to boot and passwords
!
boot system flash c800-y6-mw.122-24a.bin
boot system flash
enable secret 5 $$$$$$$$$$$$$$$$$$$$
enable password 7 %%%%%%%%%%%%%%%%%%
!
username Router password 7 &&&&&&&&&
!
!---------sets timezone and the new DST
!
clock timezone EST -5
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
!
!---------"line 1" config
!
dial-peer voice 1 pots
no forward-to-unused-port
caller-id
call-waiting
ring 0
registered-caller ring 1
port 1
destination-pattern 7791111
!
!---------"line 2" config
!
dial-peer voice 2 pots
no forward-to-unused-port
caller-id
call-waiting
ring 0
registered-caller ring 1
port 2
destination-pattern 7792222
!
pots country US
ip subnet-zero
no ip source-route
!
!---------dhcp, starts at .100 for general. You can specify specific
!---------ips by MAC, but I took that out
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool 192.168.1.0/24
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 4.2.2.2 4.2.2.3
!
!----swtich type, obviously. should say on the paper you got
!----when you got the line.
!
isdn switch-type basic-ni
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
ip nat inside
no cdp enable
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 23177911110101 7791111
isdn spid2 23177922220101 7792222
isdn incoming-voice modem
ppp authentication chap pap callin
!
interface Dialer1
description ISP
ip address negotiated
no ip directed-broadcast
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip split-horizon
dialer pool 1
dialer remote-name Cisco1
dialer idle-timeout 0
dialer string 4351111 class DialClass
dialer hold-queue 100
dialer load-threshold 1 either
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname username@netonecom.net
!
!-----I set this one up by hand, so this password isn't encrypted.
!-----so, you take out the "5" or "7" like above and plain text
!-----will work.
!
ppp chap password password
ppp pap sent-username username@netonecom.net password password
ppp multilink
!
!---------shows a port forward from 8080 to 8080 on 192.168.1.4
!
ip nat inside source list 18 interface Dialer1 overload
ip nat inside source static tcp 192.168.1.4 8080 interface Dialer1 8080

ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
map-class dialer DialClass
access-list 18 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
snmp-server community public RO
snmp-server enable traps tty
!
!-------this has to do with console (telnet) sessions.
!-------that's about as far as I got.
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 0 0
password 7 @@@@@@@@@@@@@@@
login local
!
sntp server 129.127.40.3
!
end


rm12577

join:2010-01-16
Elgin, TX

Thanks, I will wipe both routers and test this and let you know if it works, if not I really assume my routers have another issue but we will see...


aeblank

join:2004-09-07
Cadillac, MI

it is possible your line is bad as well.
It took me several weeks (couple months?) to get my line working 100% proper.

If you strike out, PM me and maybe we can try to work something out. I'm pretty quick at setting these things up lately. Been doing them a lot lately (trying to get spares for everyone in my family that has ISDN).


rm12577

join:2010-01-16
Elgin, TX

alright, got it running in 64k but its not able to bond the second channel, anybody know what to put in the config to make them both stay connected constantly, like to force them not to disconnect?


aeblank

join:2004-09-07
Cadillac, MI

said by rm12577:

alright, got it running in 64k but its not able to bond the second channel, anybody know what to put in the config to make them both stay connected constantly, like to force them not to disconnect?
What config are you using?
These are the two applicable lines, I believe.
dialer load-threshold 1 either
ppp multilink

Look at this:
»forums.whirlpool.net.au/forum-re···792.html

rm12577

join:2010-01-16
Elgin, TX
Reviews:
·Skybeam.net

3 edits

I finally got fast step to load a config for me, and AT&T came out yesterday to work on my line because they said it needed tested and confirmed to be working and they said it tested alright after they reset a few things, so I got in the troubleshooting mood again. I will try to find the dialer load and multilink in it and see if I can get it to stay on. If not I can post the config on here.

this is what i get when the second channel tries to negotiate

1:48:141733920768: %DIALER-6-BIND: Interface BR0:2 bound to profile Di1
21:48:53: %DIALER-6-UNBIND: Interface BR0:2 unbound from profile Di1
21:48:53: %ISDN-6-DISCONNECT: Interface BRI0:2 disconnected from 2200082 , cals
21:48:231928233983: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down
21:49:12886379376: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
21:49:12884901888: %DIALER-6-BIND: Interface BR0:2 bound to profile Di1

I have no idea what the bind and unbind are doing

and this just repeats every few seconds until it fills up the router log...


aeblank

join:2004-09-07
Cadillac, MI

Sorry, I'm no help with that.

I'll add to my "it could be the line" comment above. I had a line just randomly dump out. I was confident of my config, since it was working great at my parents house.

I happened to get home from work while the tech was still there. I think he hated me for it, but I insisted that it wasn't right. He put his gear on it and watched it for 15 minutes, and it did it. If I wasn't there, it wouldn't have been found.

Tracked it down to mis-matched ISDN cards in one of their switches. Sweet....

Granted, it's a different issue than yours, but it proves the point.

What does it look like when you do a show dialer?


rm12577

join:2010-01-16
Elgin, TX
Reviews:
·Skybeam.net

BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

BRI0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Di1 - dialer type = DIALER PROFILE
Load threshold for dialing additional calls is 1
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
Number of active calls = 0

Dial String Successes Failures Last DNIS Last status
2200082 968 0 16:07:19 successful Default


aeblank

join:2004-09-07
Cadillac, MI

Why do you say one channel is connected? Looks like neither is.

Just curious, did you try my config (changed to your ISP username/password and your phone numbers)?

Also, what happens when you do a "show ver".
I'm curious of what IOS you're running.


rm12577

join:2010-01-16
Elgin, TX
Reviews:
·Skybeam.net

version 12.1, i didnt try that config because i was able to get the fast step running, i changed it so it didnt auto disconnect i thought but it still seems to disconnect after a little while of no pc being on it. I will wipe a router again and try your config and see what it does then, found out from the tech that came out that they dont use 5ess they use ni, at least thats what he thought it was...


rm12577

join:2010-01-16
Elgin, TX
Reviews:
·Skybeam.net

finally got ATT to acknowledge that there is a problem and you were right its a bad card on their end, it just keeps trying to dial, and they said someone should be out fixing it in about two hours, love the business side response... if it was residential would be a day or two, hopefully this gets everything working correctly. I will let you know if it corrects my problems, then I can finally stop paying for two half internet connections and just drop the half that goes out at night and keep the isdn running strong.


aeblank

join:2004-09-07
Cadillac, MI
reply to rm12577

Haha, we're covering 2 threads now. Didn't even pay attention that it was you.

Told ya AT&T might be the problem. Ticks me off, cause you go crazy assuming its you, and then it isn't.


rm12577

join:2010-01-16
Elgin, TX
Reviews:
·Skybeam.net

Yea, I totally thought it was me that whole time going through my config backward and forward just to find out it was them and it took three calls to them for them to figure that out... crazy but o well now i can sit and watch videos load forever or download stuff slowly lol, better than not at all or super duper slow... when i dialed in to get some dns numbers on my landline i was getting 26.8k dialup speed, makes me remember my connection years ago... and glad i dont have it anymore