dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
5676
share rss forum feed


DataRiker
Premium
join:2002-05-19
00000

WinRar slow and low CPU%

Does anybody else have a problem with WinRar running slow. I get at max 5-6% cpu usage. I extract large files ~700 MB.

When I use 7-zip it takes about 1/8 the time and my CPU is pegged at 100%.

I have tried, what I think is every appropriate option, like dual core ect...

Anybody else have this problem and maybe a solution?



Cudni
La Merma - Vigilado
Premium,MVM
join:2003-12-20
Someshire
kudos:13

did you check if your AV is accessing/checking the file?

Cudni



DataRiker
Premium
join:2002-05-19
00000

1 edit

Thanks for the reply.

No I don't have AV software on my computer.

I have windows XP sp3 if that helps. Also, I finally found some other forums with the same topic, and the conclusion seems to be you can't do anything about it. I hope that is not the case.



DeeC
Premium
join:2000-09-01
the world
kudos:1

My WinRar is pretty fast, and not on a dual core.......and I unrar 700mb files all the time. It should not be using full cpu either......(I don't believe).

I am using an older (different) version though....



ironwalker
World Renowned
Premium,MVM
join:2001-08-31
Keansburg, NJ

1 edit
reply to DataRiker

Check the settings/options, see if it is being used in low priority mode.
Also check where the temp folder being used for temp files is....is this a slow drive? If so move the temp folder to a faster drive.



Inflex

join:2002-09-05
reply to DataRiker

Are you disk bound? IE, is your hard drive ligh lit solid?



DataRiker
Premium
join:2002-05-19
00000

2 edits

said by Inflex:

Are you disk bound? IE, is your hard drive ligh lit solid?
Maybe so, I recently switched to a WD green edition HD, 5400rpm vs 7200 on my old one.

But that does not seem to make sense, because I can copy a 700MB file much faster.

Also, I was incorrect about 7-zip, it too only uses a fraction of my cpu % when opening rar files ( I was thinking about compression - sorry I've been not sleeping well...) but still seems to be much faster.


DataRiker
Premium
join:2002-05-19
00000
reply to ironwalker

said by ironwalker:

Check the settings/options, see if it is being used in low priority mode.
Also check where the temp folder being used for temp files is....is this a slow drive? If so move the temp folder to a faster drive.
Yes, as it happens I have a 5400 and 7200 drive on my computer.

But If i just change the location of the temp folder, would it not have to copy from my desktop to the destination drive first?


Doctor Olds
I Need A Remedy For What's Ailing Me.
Premium,VIP
join:2001-04-19
1970 442 W30
kudos:18
reply to DataRiker

Do you have indexing running on your Drives? It should be off for faster performance and use a better search utility like Agent Ransack.




Do you have the drives setup with write cashing properly?




Do the drives show the correct DMA Modes?



--
What’s the point of owning a supercar if you can’t scare yourself stupid from time to time?


DataRiker
Premium
join:2002-05-19
00000

Ok, I checked that and indeed indexing was on. I turned it off, seemed to have a very slight speed up. Also I am on Sata so all the DMA modes are grayed out.