dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
122249
share rss forum feed


underubb

@teksavvy.com
reply to mdirouhi

Re: Everything MLPPP

"for single line MLPPP" you can just use any old modem/router and an app on your computer..... Is bell still throttling un-MLPPP connections?


mdirouhi

join:2011-01-07
Scarborough, ON
reply to Dunlop

Yes, you still need a router installed with Tomato MLPPP.

I would recommend that you buy Linksys WRT54GL router straight from Teksavvy. That way you can get support with setting up the router.


Dunlop

join:2011-07-13
kudos:2
reply to TSI Martin

Sorry for the noob question but I am having DSL installed next week after having cable for the last decade.

I understand that MLPPP can be installed on a single line, do I still need a tomato based router?


pmarcovi

join:2009-06-29
Woodbridge, ON
reply to clarknova

said by clarknova:

TomatoUSB is based on Tomato. Tomato/mlppp is based on Tomato. Neither of these is Tomato, but two distinct forks thereof.

Tomato is a K24 build. In other words it runs on the Linux 2.4 series kernel. Likewise, Tomato/mlppp exists only in the K24 flavour.

The version of TomatoUSB that runs on your router is a K26 build, running on the Linux 2.6 series kernel. Until somebody ports Tomato/mlppp to K26 you are out of luck with that hardware.

I ended up installing the following: DD-WRT v24-sp2 (07/18/10) big
(SVN revision 14826M NEWD-2 K2.6 Eko)

It looks like everything works well. From what I understand DD-WRT supports only SLPPP, but that is what I need.

It would be nice if the Tomato MLPPP is upgraded to use the 2.6 kernel ...


clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
Reviews:
·TekSavvy DSL
reply to pmarcovi

TomatoUSB is based on Tomato. Tomato/mlppp is based on Tomato. Neither of these is Tomato, but two distinct forks thereof.

Tomato is a K24 build. In other words it runs on the Linux 2.4 series kernel. Likewise, Tomato/mlppp exists only in the K24 flavour.

The version of TomatoUSB that runs on your router is a K26 build, running on the Linux 2.6 series kernel. Until somebody ports Tomato/mlppp to K26 you are out of luck with that hardware.
--
db


pmarcovi

join:2009-06-29
Woodbridge, ON
reply to clarknova

said by clarknova:

said by pmarcovi:

Newer version of "regular" Tomato can ...

Nope. »polarcloud.com/tomato

If it's not on that page then it's not going to work.

These links says otherwise:
»tomatousb.org/forum/t-265034/ple···mato-usb

What is the chance that the MLPPP version does not work if the newer version works?


clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
Reviews:
·TekSavvy DSL
reply to pmarcovi

said by pmarcovi:

Newer version of "regular" Tomato can ...

Nope. »polarcloud.com/tomato

If it's not on that page then it's not going to work.
--
db

pmarcovi

join:2009-06-29
Woodbridge, ON
reply to TSI Outages

Can the Tomato MLPPP version be applied on the WRT320N? Newer version of "regular" Tomato can ...



TSI Outages
TSI Support
Premium
join:2009-09-28
Chatham, ON
reply to dsoegiarto

Hey dsoegiarto,

You can indeed benefit from using DD WRT with that router. Keep in mind, DD WRT will ONLY support SLPPP. You cannot run more than one connection or bond lines with this firmware.

Also, our tomato firmware doesn't need to be modified in any way and is ready to use once the firmware is in place, whereas DD WRT may need fixes via telnet to get it to work, depending on the hardware and firmware version. We will not support DD WRT because of this, officially.

Cheers,

TSR Paulo



dsoegiarto

join:2010-04-16
Ottawa, ON
Reviews:
·TekSavvy Cable
·TekSavvy DSL
reply to TSI Outages

said by TSI Outages:

Hey dsoegiarto,

It depends on what firmware version your dir-615 comes with, but most versions do update with DD WRT.
Regards,

TSR Paulo

and if it does updates with DD-WRT, i can benefit with MLPPP?

i thought DD still supports it unofficially only? and my DIR-615 doesn't work with tomato


TSI Outages
TSI Support
Premium
join:2009-09-28
Chatham, ON
reply to dsoegiarto

Hey dsoegiarto,

It depends on what firmware version your dir-615 comes with, but most versions do update with DD WRT.
Regards,

TSR Paulo



dsoegiarto

join:2010-04-16
Ottawa, ON
reply to TSI Martin

anybody has a D-Link DIR-615 that works with MLPPP? it can support DD-WRT and i only have 1 dry DSL line...


bradbarian

join:2011-06-07
Oshawa, ON

1 edit
reply to TSI Martin

answered



vitesse

join:2002-12-17
Saint-Jean-Sur-Richelieu, QC
reply to clarknova

my wrt54gl run out of ram at around 400 connections. This is why I changed for something else at first.



clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
Reviews:
·TekSavvy DSL
reply to vitesse

Have a look at Advanced>Conntrack/Netfilter (/advanced-ctnf.asp). Tomato default is 4096 maximum connections, but you can increase that until you run out of RAM.

How easy is it to use up 4096 connection? I had approximately 300 users behind mine and didn't have to adjust that setting. You could do it if you were torrenting and connected to thousands of peers, but on a 30 mbps connection there is no benefit to more than about 300 concurrent peer connections anyway.
--
db



vitesse

join:2002-12-17
Saint-Jean-Sur-Richelieu, QC
reply to clarknova

maximum number of concurrent connection.... limited at around 350-400



clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
Reviews:
·TekSavvy DSL
reply to vitesse

said by vitesse:

I had an WRT54gl with tomato/mlppp, but the hardware was not fast enough.

For two lines? I think you're doing it wrong. I've done three lines on a WL-520GU, which has only marginally more CPU power, and CPU usage was around 50% with the throttle fully open, including torrents, voip, and other traffic, all being properly managed by Tomato's QoS. What symptoms were you seeing that made you believe your hardware was inadequate?
--
db


vitesse

join:2002-12-17
Saint-Jean-Sur-Richelieu, QC
Reviews:
·voip.ms
·ELECTRONICBOX
·Bell Sympatico
·Videotron
reply to TSI Martin

What is the best router option available for doing 2 line mlppp?

I want to get ride of my POTS and only use VOIP phone, but my current "ZeroShell" router is really bad at QOS or I'M doing something wrong. When Utorrent is in use I always have difficulties with my voip signal. I had an WRT54gl with tomato/mlppp, but the hardware was not fast enough.

If anyone have a suggestion,. I'm open to it.
--
Connection: Teksavvy 10000/1600 in mlppp
Globaltuners.com Remotely controled Radio scanner


mkam
Premium
join:2010-02-22
Beeton, ON
reply to TSI Martin

On your MLPPP FAQ page (»mlppp.teksavvy.com/tomato_en.html) you list the latest version as TOMATO/MLPPP ver 1.21 . The download page states the stable build as 1.19 while the unstable build is 1.27. Where's 1.21??

Thanks



TSI Martin
Premium
join:2006-02-23
Chatham, ON
kudos:33
reply to tyciol

MLPPP if for DSL only.


tyciol

join:2007-01-29
Richmond Hill, ON
reply to TSI Martin

Question: what if we buy a 15 unlimited plan and a 15 limited (now 300 I believe) plan?

We'd get a speed of 30 by combining them with MLPPP, but how would the bandwidth limitations work?

Would it be something like, the work is split evenly between them? So once we get 600 worth of data, could we disconnect the limited one and half our speed and continue surfing without worrying about overcharges on the unlimited one?

Or would the unlimitedness of the more expensive 15 extend to the lesser?



andrej

@acanac.net
reply to TSI Martin

will mlppp work with cable internet?
also whats the max number of cable connections at one residence


mlord

join:2006-11-05
Nepean, ON
kudos:13
Reviews:
·Start Communicat..
reply to mlord

Re: Ethernet broadcasts leaking out over DSL with MLPPP ?

Disturbingly, I starting to think that this leaking of packets is actually happening.

Related to that, I found this story about a remote ARP attack using ethernet broadcasts from the other end of a DSL connection:

»www.increa.com/computers/verizon···dex.html

So.. MLPPP with more than one line appears to be an unsafe configuration with the default setup of Tomato/MLPPP on the WRT54G router. I believe this can be fixed with a rearrangement of the vlan configuration.. might try that later on.

Cheers


mlord

join:2006-11-05
Nepean, ON
kudos:13
Reviews:
·Start Communicat..

4 edits
reply to TSI Martin

Here is a question I originally asked in a more roundabout way in a different thread:

With a two-line MLPPP setup, using a WRT54GL with Tomato/MLPPP, the second modem connects to the WRT54GL via the LAN side of the router. As such, this modem "sees" all ethernet broadcast frames from the LAN --> anything with a MAC of FF:FF:FF:FF:FF:FF will be seen by the modem.

Q: Does the modem forward all ethernet broadcasts over the DSL connection to the RAS ?

I suppose it must, since PADI packets are sent that way, and are essential to PPPoE.

But this would also then mean that DHCP discovery, ARP, and other local LAN broadcasts would then also be travelling across the DSL connection. Which could be a rather large security hole, as well as a small amount of wasted bandwidth.

Does anyone know the answer? I would expect somebody from TSI might know.

Thanks.


Esc
Premium
join:2011-01-26
canada
reply to rtoole

Re: Everything MLPPP

Will a Linksys RV042 dual wan router work for MLPPP?

Appreciate feedback from anyone using this router. Will it function as two separate routers would for MLPPP or just SLPPP.


rtoole

join:2011-01-03
Calgary, AB
reply to TSI Martin

Multilink PPP on a Cisco 2691 works well for me in Telus Land (Calgary) I've posted my config and some details here: »www.tooleweb.ca/blog/?e=7

Very happy with it. TSI, Why no official support for it out west?


gt1996

join:2010-11-25
Etobicoke, ON
reply to TSI Martin

Hi Martin,
In your Cisco example the router has an internal ADSL WIC card. In my case I currently use a Cisco 3620 with Ethernet interfaces only and I use an external Alcatel speedtouch DSL modem in bridge mode. This config is working for me for 5 year now.
Following is the relevant working configuration :
vpdn enable
vpdn session-limit 1
!
vpdn-group 1
request-dialin
protocol pppoe

interface Ethernet0/0
description TO ADSL MODEM (BRIDGE MODE)
no ip address
half-duplex
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface Ethernet0/1
description INTERNAL LAN
ip address x.y.z.t a.b.c.d
ip nat inside

interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown

interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
no peer default ip address
keepalive 3
ppp authentication pap callin
ppp pap sent-username xxxxxxxx password 7 000000000

My question is what would be the template so I can use SLPPP with the same Cisco router and the same external modem (and one phone line)? I did quite a bit of research but this solution doesn't seem to be that popular. I have already the MLPPP login from teksavvy now I need to get this working.
Thanks in advance!


valunthar

join:2008-12-30
reply to TSI Martin

Single Link MLPPP now works in the PFsense 2.0 beta.

Assuming you have an interface that you're not using the steps to follow are (this is for an Alix 2D13 board, but it should be similar for other systems):

Your hardware has 3 NICs, vr0, vr1 and vr2. Let's say for example you want to connect your modem to vr0. vr1 will be your LAN. vr2 will not be plugged, but will act as the dummy link in the bundle, like this:

vr0--modem
vr1--LAN switch
vr2--unplugged

1. Go to interfaces_ppps.php and delete every entry.
2. Click the + sign to make a new entry.
3. Choose type: pppoe. Link interfaces: select vr0 and vr2 (using the ctrl key).
4. Save and go to interfaces_assign.php.
5. You need exactly 2 entries here. WAN: PPPOE0(vr0,vr2) and LAN: vr1 (00:00:00:00:00:00). Save and apply as needed.

That's it. These instructions only work if you have a physical port that's not in use. If you're using all your physical ports then you'll have to go about it a little differently with vlans. Let me know if you want instructions for that.

--------------------------------------------

However if you don't have a spare port that you can use there's always the VLAN route covered here:

If you want slmlppp and you don't have a spare physical interface, then you need to create and use a vlan interface as the dummy. The gotcha here is that a vlan interface won't show up in the interface list when you're selecting your pppoe bundle members unless you have first enabled that vlan as a static or dhcp interface.

Creating vlans in pfsense is effectively free, so just make a vlan on your WAN or some other port, so for example vr0 is your WAN, and you also create vlan 999 on vr0 and assign it as OPT2 (because vr2 is now OPT1). Enable OPT2 as a static IP address that does not fall on one of your existing subnets, and then go to ppps and make a pppoe bundle from vr0 and OPT2.

Steps were copied from Clarknova's posts on the Pfsense forum.


spinbot

join:2010-08-22
Belleville, ON
reply to smokerings

It took an evening to realize my hardware version was too new. It would be nice if DD-WRT's Multi-Link worked as it would save me $60 , however I have no option but to grab a new one to install Tomato/MLPPP ( getting a WRT54GL , making sure its one of the older firmware versions ).



smokerings

join:2001-02-25
Kitchener, ON

2 edits
reply to spinbot

Yes, you can run MLPPP with just a single line and your line will not be throttled.

I don't think that router is able to run tomato/mlppp as it only has 2mb of flash and I believe you need at least 4mb to install that firmware.( Just ran into your post on RFD asking the same stuff while I was searching hehe )