dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
158809
share rss forum feed
« Service in Richmond Hill[Outages] out in London »
prev page · 1 · 2 · 3 ... 14 · 15 · 16 · 17 · 18 · 19 ... 21 · 22 · 23 · next

34764170

join:2007-09-06
Etobicoke, ON
reply to kg77

Re: IPv6 beta

said by kg77:

Unless TekSavvy has changed their setup, I am pretty sure you need to manually assign your IPv6 address on your router. When I signed up for the IPv6 beta TekSavvy also gave me an IPv6 subnet address along with the login.

Haven't heard anything to the contrary but TSI still doesn't have DHCPv6-PD setup on their end so the setup is still manual.

didcrywolf

join:2002-12-03
Mont-Royal, QC

1 recommendation

said by 34764170:

said by kg77:

Unless TekSavvy has changed their setup, I am pretty sure you need to manually assign your IPv6 address on your router. When I signed up for the IPv6 beta TekSavvy also gave me an IPv6 subnet address along with the login.

Haven't heard anything to the contrary but TSI still doesn't have DHCPv6-PD setup on their end so the setup is still manual.

Well that is why I am upset. Giving someone incomplete info is worse than nothing at all, I am now in limbo waiting for a charitable soul to point me in the right direction...
I called tech support at TSI and I was told ... you are on your own...
How complicated is it to send an email to all beta testers with a set of basic instructions...
Instead I have to BEG...

34764170

join:2007-09-06
Etobicoke, ON

1 recommendation

said by didcrywolf:

Well that is why I am upset. Giving someone incomplete info is worse than nothing at all, I am now in limbo waiting for a charitable soul to point me in the right direction...
I called tech support at TSI and I was told ... you are on your own...
How complicated is it to send an email to all beta testers with a set of basic instructions...
Instead I have to BEG...

They could make this all automatic by using DHCPv6-PD and with it integrated with their RADIUS database very easily have both static allocations or dynamic from a pool.

isocat

join:2012-06-03
Toronto, ON
reply to mattvmotas

Hello, I am having a bit of trouble getting my network working with IPv6, and I was wondering if someone can point me in the right direction.

I am running OpenWRT (Backfire 10.03) on a WRT54GL router.

I am able to ping6 ipv6.google.com from the router, but not from the host:

$ ping6 ipv6.google.com
PING6(56=40+8+8 bytes) 2607:f2c0:a000:xxxx:xxxx:f2ff:fe02:xxxx --> 2001:4860:4008:802::1011
Request timeout for icmp_seq=0
Request timeout for icmp_seq=1
Request timeout for icmp_seq=2


My host gets an IPv6 address, and can ping6 the LL address of the LAN interface on the router.

I am unable to access any IPv6 pages from the host.

This does not seem to be firewall related as opening up the firewall (ip6tables -F) has no effect.

It seems that the router is not passing IPv6 traffic from the LAN to the WAN...?

Config (abridged):

root@DeltaNet:/etc/config# cat /proc/sys/net/ipv6/conf/all/forwarding
1

Network:
config 'interface' 'lan'
option 'type' 'bridge'
option 'ifname' 'eth0.0'
option 'proto' 'static'
option 'ipaddr' '192.168.242.241'
option 'netmask' '255.255.255.240'
option 'ip6addr' '2607:f2c0:a000:xxxx::/64'
option 'mtu' 1452

config 'interface' 'wan'
option 'ifname' 'eth0.1'
option 'proto' 'pppoe'
option 'password' 'xxx'
option 'username' 'xxx@hsiservice.net'
option 'mtu' 1452
option 'ipv6' '1'
option 'ip6addr' '2607:f2c0:f00f:xxxx::/56'

Radvd:
config interface
option interface 'lan'
option AdvSendAdvert 1
option AdvManagedFlag 0
option AdvOtherConfigFlag 0
list client ''
option ignore 0
option AdvLinkMTU 1452

config prefix
option interface 'lan'
option prefix '2607:f2c0:a000:xxxx::/64'
option AdvOnLink 1
option AdvAutonomous 1
option AdvRouterAddr 0
option ignore 0


Running a traceroute to ipv6.google.com from the host returns this:

$ traceroute6 ipv6.google.com
traceroute6 to ipv6.l.google.com (2001:4860:4008:802::1011) from 2607:f2c0:a000:xxxx:xxxx:f2ff:fe02:xxxx, 64 hops max, 12 byte packets
1 2607:f2c0:a000:xxxx:: 0.711 ms !N 0.695 ms !N 0.448 ms !N


And running a traceroute to ipv6.google.com from the router returns this (is this because it isn't traceroute6? And if so, does anyone know how to perform an IPv6 traceroute from OpenWRT?:

traceroute to ipv6.google.com (2001:4860:4008:802::1011), 30 hops max, 38 byte packets
1traceroute: sendto: Invalid argument


And finally, the routing table on the router looks like this:

root@DeltaNet:/etc/config# ip -6 route
2607:f2c0:a000:xxxx::/64 dev br-lan metric 256 mtu 1452 advmss 1392
2607:f2c0:f00f:xxxx::/56 dev pppoe-wan metric 256 mtu 1452 advmss 1392
fe80::/64 dev eth0 metric 256 mtu 1500 advmss 1392
fe80::/64 dev eth0.0 metric 256 mtu 1500 advmss 1392
fe80::/64 dev eth0.1 metric 256 mtu 1452 advmss 1392
fe80::/64 dev br-lan metric 256 mtu 1452 advmss 1392
fe80::/64 dev wl0 metric 256 mtu 1500 advmss 1440
fe80::/64 dev pppoe-wan metric 256 mtu 1452 advmss 1392
fe80::/10 dev pppoe-wan metric 1 mtu 1452 advmss 1392
fe80::/10 dev pppoe-wan metric 256 mtu 1452 advmss 1392
ff00::/8 dev eth0 metric 256 mtu 1500 advmss 1392
ff00::/8 dev eth0.0 metric 256 mtu 1500 advmss 1392
ff00::/8 dev eth0.1 metric 256 mtu 1452 advmss 1392
ff00::/8 dev br-lan metric 256 mtu 1452 advmss 1392
ff00::/8 dev wl0 metric 256 mtu 1500 advmss 1440
ff00::/8 dev pppoe-wan metric 256 mtu 1452 advmss 1392
default via fe80::90:1a00:4243:14a8 dev pppoe-wan metric 1 mtu 1452 advmss 1392
unreachable default dev lo proto none metric -1 error -128 advmss 1392


I'm not exactly a guru when it comes to networking, especially in regards to IPv6, but feel like my problems have something to do with the default route...?

Anyway, sorry for the long post. Just wanted to be thorough. Anyone have any suggestions?


mactalla

join:2008-02-19
kudos:1

What's the default policy on your firewall? (ip6tables -L)


isocat

join:2012-06-03
Toronto, ON

Output of ip6tables -L follows:


root@DeltaNet:/etc/config# ip6tables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all anywhere anywhere
syn_flood tcp anywhere anywhere tcp flags:FIN,SYN,RST,ACK/SYN
input_rule all anywhere anywhere
input all anywhere anywhere

Chain FORWARD (policy DROP)
target prot opt source destination
forwarding_rule all anywhere anywhere
forward all anywhere anywhere
reject all anywhere anywhere
ACCEPT icmp anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all anywhere anywhere
output_rule all anywhere anywhere
output all anywhere anywhere

Chain forward (1 references)
target prot opt source destination
zone_lan_forward all anywhere anywhere
zone_wan_forward all anywhere anywhere

Chain forwarding_lan (1 references)
target prot opt source destination

Chain forwarding_rule (1 references)
target prot opt source destination

Chain forwarding_wan (1 references)
target prot opt source destination

Chain input (1 references)
target prot opt source destination
zone_lan all anywhere anywhere
zone_wan all anywhere anywhere

Chain input_lan (1 references)
target prot opt source destination

Chain input_rule (1 references)
target prot opt source destination

Chain input_wan (1 references)
target prot opt source destination

Chain output (1 references)
target prot opt source destination
zone_lan_ACCEPT all anywhere anywhere
zone_wan_ACCEPT all anywhere anywhere

Chain output_rule (1 references)
target prot opt source destination

Chain reject (5 references)
target prot opt source destination
REJECT tcp anywhere anywhere reject-with tcp-reset
REJECT all anywhere anywhere reject-with icmp6-port-unreachable

Chain syn_flood (1 references)
target prot opt source destination
RETURN tcp anywhere anywhere tcp flags:FIN,SYN,RST,ACK/SYN limit: avg 25/sec burst 50
DROP all anywhere anywhere

Chain zone_lan (1 references)
target prot opt source destination
ACCEPT all anywhere anywhere
input_lan all anywhere anywhere
zone_lan_ACCEPT all anywhere anywhere

Chain zone_lan_ACCEPT (2 references)
target prot opt source destination
ACCEPT all anywhere anywhere
ACCEPT all anywhere anywhere

Chain zone_lan_DROP (0 references)
target prot opt source destination
DROP all anywhere anywhere
DROP all anywhere anywhere

Chain zone_lan_REJECT (1 references)
target prot opt source destination
reject all anywhere anywhere
reject all anywhere anywhere

Chain zone_lan_forward (1 references)
target prot opt source destination
zone_wan_ACCEPT all anywhere anywhere
forwarding_lan all anywhere anywhere
zone_lan_REJECT all anywhere anywhere

Chain zone_wan (1 references)
target prot opt source destination
ACCEPT udp fe80::/10 fe80::/10 udp spt:dhcpv6-server dpt:dhcpv6-client
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp echo-request limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp destination-unreachable limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp packet-too-big limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp time-exceeded limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp bad-header limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp unknown-header-type limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp router-solicitation limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp neighbour-solicitation limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere
input_wan all anywhere anywhere
zone_wan_REJECT all anywhere anywhere

Chain zone_wan_ACCEPT (2 references)
target prot opt source destination
ACCEPT all anywhere anywhere
ACCEPT all anywhere anywhere

Chain zone_wan_DROP (0 references)
target prot opt source destination
DROP all anywhere anywhere
DROP all anywhere anywhere

Chain zone_wan_REJECT (2 references)
target prot opt source destination
reject all anywhere anywhere
reject all anywhere anywhere

Chain zone_wan_forward (1 references)
target prot opt source destination
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp echo-request limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp destination-unreachable limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp packet-too-big limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp time-exceeded limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp bad-header limit: avg 1000/sec burst 5
ACCEPT ipv6-icmp anywhere anywhere ipv6-icmp unknown-header-type limit: avg 1000/sec burst 5
forwarding_wan all anywhere anywhere
zone_wan_REJECT all anywhere anywhere
root@DeltaNet:/etc/config#


mactalla

join:2008-02-19
kudos:1

said by isocat:

Chain FORWARD (policy DROP)

Your firewall is dropping by default anything that would need to be forwarded from one interface to another.

Try this: ip6tables -P FORWARD ACCEPT

isocat

join:2012-06-03
Toronto, ON

Thanks for your reply! I have tried your suggestion, but unfortunately there was no change.

Something I forgot to include in the original post was that when I restart my firewall, I get some errors:

root@DeltaNet:/etc/config# /etc/init.d/firewall restart
Loading defaults
ip6tables: No chain/target/match by that name.
ip6tables: No chain/target/match by that name.
ip6tables: No chain/target/match by that name.
ip6tables: No chain/target/match by that name.
ip6tables: No chain/target/match by that name.
ip6tables: No chain/target/match by that name.
Loading synflood protection
Adding custom chains
Loading zones
Loading forwardings
Loading redirects
Loading rules
Loading includes
Loading interfaces
ip6tables: No chain/target/match by that name.
root@DeltaNet:/etc/config#


rpnc

join:2011-06-08
Markham, ON
reply to isocat

isocat,

I am using OpenWRT successfully. However, I'm running version 10.03.1. Version 10.03.1 uses a new integrated IPv4/IPv6 firewall. I was able to add the iputils-traceroute6 package in 10.03.1 to get traceroute6.

I have kept a record of how I configured OpenWRT. I did a lot with the GUI but some had to be done with config files.

In GUI (better with Firefox):
- System > Administration > Router Password
Password: xxxxxxxx
Confirmation: xxxxxxxx
- System > Administration > SSH Access
Interface: lan
Save & Apply.

- Network > Interfaces > WAN > General Setup
Protocol: PPPoE
PAP/CHAP username: xxxxx@hsiservice.net
PAP/CHAP password: xxxxxxxx
Save & Apply.

From PuTTY:
opkg update
opkg install kmod-ipv6 radvd ip kmod-ip6tables ip6tables wide-dhcpv6-server ntpclient iputils-traceroute6
reboot

- Network > DHCP and DNS > Static Leases > Add
Hostname: CanonPrinter
MAC-Address: xx:xx:xx:xx:xx:xx
IPv4-Address: 192.168.1.xx
Save & Apply.

- Network > Wifi > radio0 > Device Configuration > General Setup
Enable
- Network > Wifi > radio0 > Interface Configuration > General Setup
ESSID: xxxxxx
- Network > Wifi > Interface Configuration > Wireless Security
Encryption: WPA2-PSK
Key: xxxxxxxx
Save & Apply.

- Network > Firewall > Zones
wan/Input: drop
wan/Forward: drop
Save & Apply.

- Network > Interfaces > WAN > Advanced Settings
Enable IPv6 negotiation on the PPP link: yes
Save & Apply.

- Network > Interfaces > LAN > General Setup
IPv6 address: 2607:f2c0:f0xx:xxxx::1/56
- Network > Interfaces > LAN > Advanced Setup
Override MTU: 1492
Save & Apply.

From PuTTY:
vi /etc/config/network
- under config 'interface' 'wan', add
option 'ip6addr' '2607:f2c0:a0xx:xxxx::1/64'

vi /etc/sysctl.conf
- remove comment # from net.ipv6.conf.all.forwarding=1
reboot

- System > Startup > Initscripts
enable radvd

Note: get MTU by pinging an IPv6 computer on the internet with -l size and finding the max size (1444) and add
- 40 bytes for the IPv6 header
- 4 bytes for the ICMPv6 header
- 4 bytes for the ICMPv6 echo request header
From PuTTY:
vi /etc/config/radvd
- under config interface
option AdvLinkMTU 1492
option AdvOtherConfigFlag 1
option ignore 0
- under config prefix (note that prefix is /64 not /56)
list prefix '2607:f2c0:f0xx:xxxx::/64'
option AdvValidLifetime 14400
option AdvPreferredLifetime 14400
option ignore 0

vi /etc/config/dhcp6s
- change to
option 'enabled' '1'

vi /etc/dhcp6s.conf (new file)
option domain-name-servers 2607:f2c0:f0xx:xxxx::1;

vi /etc/hosts
fe80::xxxx:xxxx:xxxx:xxxx xxxxxxx
fe80::xxxx:xxxx:xxxx:xxxx xxxxxxx
fe80::xxxx:xxxx:xxxx:xxxx xxxxxxx
fe80::xxxx:xxxx:xxxx:xxxx xxxxxxx
fe80::xxxx:xxxx:xxxx:xxxx xxxxxxx
fe80::xxxx:xxxx:xxxx:xxxx xxxxxxx

reboot

- System > Backup / Flash Firmware
Download backup: Generate archive
Done.

Here are some of the resulting configuration files:
root@OpenWrt:/etc/config# cat /etc/config/network

config 'interface' 'loopback'
option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'

config 'interface' 'lan'
option 'ifname' 'eth0'
option 'type' 'bridge'
option 'proto' 'static'
option 'ipaddr' '192.168.1.1'
option 'netmask' '255.255.255.0'
option 'ip6addr' '2607:f2c0:f0xx:xxxx::1/56'
option 'mtu' '1492'

config 'interface' 'wan'
option 'ifname' 'eth1'
option '_orig_ifname' 'eth1'
option '_orig_bridge' 'false'
option 'proto' 'pppoe'
option 'password' 'xxxxx'
option 'ipv6' '1'
option 'ip6addr' '2607:f2c0:a0xx:xxxx::1/64'
option 'username' 'xxxxx@hsiservice.net'

config 'switch'
option 'name' 'rtl8366s'
option 'reset' '1'
option 'enable_vlan' '1'

config 'switch_vlan'
option 'device' 'rtl8366s'
option 'vlan' '1'
option 'ports' '0 1 2 3 5'

root@OpenWrt:/etc/config# cat /etc/config/radvd
config interface
option interface 'lan'
option AdvSendAdvert 1
option AdvManagedFlag 0
option AdvLinkMTU 1492
option AdvOtherConfigFlag 1
list client ''
option ignore 0

config prefix
option interface 'lan'
# If not specified, a non-link-local prefix of the interface is used
list prefix '2607:f2c0:f0xx:xxxx::/64'
option AdvOnLink 1
option AdvAutonomous 1
option AdvRouterAddr 0
option AdvValidLifetime 14400
option AdvPreferredLifetime 14400
option ignore 0

config route
option interface 'lan'
list prefix ''
option ignore 1

config rdnss
option interface 'lan'
# If not specified, the link-local address of the interface is used
list addr ''
option ignore 1

config dnssl
option interface 'lan'
list suffix ''
option ignore 1

root@OpenWrt:/etc# cat /etc/dhcp6s.conf
option domain-name-servers 2607:f2c0:f0xx:xxxx::1;


isocat

join:2012-06-03
Toronto, ON

Thanks very much, rpnc! :)

I also have 10.03.1 (r29592). Are you using bcrm-2.4 or brcm47xx? For some reason I am unable to add traceroute6:

root@DeltaNet:/etc# opkg update
Downloading »downloads.openwrt.org/backfire/1···kages.gz.
Inflating »downloads.openwrt.org/backfire/1···kages.gz.
Updated list of available packages in /var/opkg-lists/packages.
root@DeltaNet:/etc# opkg install iputils-traceroute6
Unknown package 'iputils-traceroute6'.
Collected errors:
* opkg_install_cmd: Cannot install package iputils-traceroute6.


Thanks very kindly for your detailed post, I will go through it and see if I can figure out where I went wrong.


rpnc

join:2011-06-08
Markham, ON

I have openwrt-ar71xx-dir-825-b1-squashfs-*.bin running on a D-Link DIR-825.

My list of packages are at:
»downloads.openwrt.org/backfire/1···ackages/

Yours are at:
»downloads.openwrt.org/backfire/1···ackages/

In my packages, I see iputils-traceroute6_20101006-1_ar71xx.ipk but I don't see it in yours. Yours has tcptraceroute6_1.0.1-1_brcm-2.4.ipk but I can't get tcptraceroute6 to work - apparently due to bug #8153.


mactalla

join:2008-02-19
kudos:1
reply to TSI Gabe

Looking for suggestions on how to configure a router (OpenWrt 10.03.1) to use TSI's Western version of IPv6.

Basically, we don't get a /56 but only a /64. And as far as I know the /64 itself is dynamic so I shouldn't hardcode this prefix. TSI Gabe, could you chime in on this?

Enabling IPv6 on the PPPoE interface gets itself an IPv6 address easy enough and it's all working great on the router. What I've had configured with a HE tunnel and what looks like the TSI East approach is to have a static /64 subnet for the lan interface. For the moment I've arbitrarily chosen an address within the /64 I got assigned and hardcoded it. But this is a Bad Thing unless I have some promise that we indeed get a static subnet (I already know my address is dynamic, but thus far the subnet has remained constant). How should I be assigning an address to br-lan if I'm getting a dynamic subnet from TSI?

To get addresses to the machines on the lan I figured I should probably take a subset of the prefix to avoid the (small) chance that my wan IP would collide with a machine on the lan. But radvd complains if the prefix is larger than /64. I must be missing something because I can't imagine why we should not be able to divide the address space into chunks smaller than a /64. So for now I'm using the exact same prefix for the machines downstream as is given to the wan port.

Am I correct in assuming that the /64 as given to my pppoe interface is exclusively mine and not shared with other customers?

Finally, with this all setup openwrt is adding the same /64 route to both br-lan and pppoe-wan which of course breaks things. After manually removing the /64 route out the wan port I can access the IPv6 world from my machines behind the router.

Obviously it's not done correctly but I don't know where to look as everyone talks about the wan and lan having different prefixes. Help?

For reference, here's rdisc6:

# rdisc6 pppoe-wan
Soliciting ff02::2 (ff02::2) on pppoe-wan...

Hop limit : undefined ( 0x00)
Stateful address conf. : Yes
Stateful other conf. : Yes
Router preference : medium
Router lifetime : 1800 (0x00000708) seconds
Reachable time : unspecified (0x00000000)
Retransmit time : unspecified (0x00000000)
MTU : 1452 bytes (valid)
Prefix : 2607:c000:blah:blah::/64
Valid time : 3600 (0x00000e10) seconds
Pref. time : 3000 (0x00000bb8) seconds
from fe80::90:1a00:343:14ab


rpnc

join:2011-06-08
Markham, ON

I'm not in the west, but I imagine that you should have a static /64. Ideally, you would want at least a /128 for the WAN side and a /64 for the LAN side. The stateless addressing (SLAAC) enabled with radvd requires a /64 on the LAN. You may be able to split the /64 into two /65s but then you should use stateful addressing (DHCPv6).

So don't set config prefix / list prefix in radvd. Instead, edit /etc/dhcp6s.conf to use DHCPv6 to assign addresses in a smaller range.

In /etc/config/radvd, enable DHCPv6 router advertisement:
- under config interface
option AdvOtherConfigFlag 1
option ignore 0

In /etc/config/dhcp6s, enable DHCPv6:
- change to
option 'enabled' '1'

Let's say your /64 was 2607:f2c0:xxxx:xxxx::/64. This could be split into 2607:f2c0:xxxx:xxxx:8000::/65 and 2607:f2c0:xxxx:xxxx::/65.

You could make your router's WAN IP 2607:f2c0:xxxx:xxxx:8000::1/65 and your router's LAN IP 2607:f2c0:xxxx:xxxx::1/65. Configure DHCPv6 to give out addresses in a range 2607:f2c0:xxxx:xxxx::1000 to 2607:f2c0:xxxx:xxxx::ffff.

I haven't tried this and don't know if it will work.


34764170

join:2007-09-06
Etobicoke, ON

1 recommendation

said by rpnc:

I haven't tried this and don't know if it will work.

This won't work if you have devices on the network with no DHCPv6 support.
RA is a requirement for IPv6 anyway. Just get TSI to properly allocate /56's as they should be.

mactalla

join:2008-02-19
kudos:1

1 edit
reply to TSI Gabe

Thanks rpnc. Unfortunately it didn't work for me.

If anyone can get IPv6-west working on a router I would really like to hear how it's done. Or if anyone knows of instructions anywhere to get OpenWrt to function with a single /64 allocation. The IPv6 allocation seems to work easily for a single host with no router (who has that these days?) but I can't get a router to work. I have no objections to changing firmware, but Tomato doesn't support my router so that's not an option. Generally if it's possible OpenWrt should be able to do it.

It's screwy to the point that I have a Global IP on a host and some sites report my IPv6 address and say congrats and others say I don't even have a v6 IP.

For now I've gone back to my HE.net tunnel and will try again when time permits.


isocat

join:2012-06-03
Toronto, ON

I asked for some help a little earlier this week, but unfortunately none of the suggestions seemed to work. I gave up for a day, and when I come back, everything was suddenly working.

It continued to work until I had to reboot my router. Now I am back to where I started.

The only clue I have, is that when it wasn't working, I got this:

root@DeltaNet:~# ip -6 route
2607:f2c0:a000:xxxx::/64 dev br-lan metric 256 mtu 1280 advmss 1220
2607:f2c0:f00f:xxxx::/56 dev pppoe-wan metric 256 mtu 1280 advmss 1220
fe80::/64 dev eth0 metric 256 mtu 1500 advmss 1220
fe80::/64 dev eth0.1 metric 256 mtu 1280 advmss 1220
fe80::/64 dev eth0.0 metric 256 mtu 1500 advmss 1220
fe80::/64 dev br-lan metric 256 mtu 1280 advmss 1220
fe80::/64 dev wl0 metric 256 mtu 1500 advmss 1440
fe80::/64 dev pppoe-wan metric 256 mtu 1280 advmss 1220
fe80::/10 dev pppoe-wan metric 1 mtu 1280 advmss 1220
fe80::/10 dev pppoe-wan metric 256 mtu 1280 advmss 1220
ff00::/8 dev eth0 metric 256 mtu 1500 advmss 1220
ff00::/8 dev eth0.1 metric 256 mtu 1280 advmss 1220
ff00::/8 dev eth0.0 metric 256 mtu 1500 advmss 1220
ff00::/8 dev br-lan metric 256 mtu 1280 advmss 1220
ff00::/8 dev wl0 metric 256 mtu 1500 advmss 1440
ff00::/8 dev pppoe-wan metric 256 mtu 1280 advmss 1220
unreachable default dev lo proto none metric -1 error -128 advmss 1220


And after it started working, I noticed that the "unreachable default dev lo proto none metric -1 error -128 advmss 1220" was no longer there. Now that it has stopped working again, that line has returned. It seems pretty likely that this is related.

Does this make sense? Does anyone have an idea of what may have happened?


isocat

join:2012-06-03
Toronto, ON

Solved. Seems like a bug in openwrt. This is how I fixed it:

root@DeltaNet:/etc/init.d# ip -6 route del default
root@DeltaNet:/etc/init.d# ip -6 route add default dev pppoe-wan


Looks like this problem occurs everytime the router is rebooted.


mactalla

join:2008-02-19
kudos:1

Yes, it looks like you were missing the default route. This should normally be configured for you. If it fails on you again I would look at your firewall and make sure none of the negotiations are being blocked. You can enable logging (option log 1) on your wan zone to identify what's not getting through.



rodjames
Premium
join:2010-06-19
Gloucester, ON
reply to TSI Gabe

maybe set that as an openwrt startup command. that'll do it for you every boot.


xero9

join:2001-11-29
Ajax, ON
reply to TSI Gabe

I can't seem to find anyone else who has asked this yet, so..

I've had a 6to4 tunnel set up using HE's service, but the performance is pretty bad. I figure TekSavvy's IPv6 offering would eliminate most of the overhead I'm seeing, but I'm having issues setting it up on my D-Link DIR-615.

Under the IPv6 menu, I changed 'My IPv6 Connection is' to PPPoE, and have basically left the settings as is. My laptop is obtaining an IPv6 address, but it's COMPLETELY different than what TekSavvy has provisioned me..

My computer is getting 2002:cef8:xx:xx
TekSavvy has given me 2607:f2c0:xx:xx

This is a bit confusing to me and I suspect I haven't set something up properly.

The other thing too is they gave me a /64 and a /56, and I'm not really sure which is which. I thought the /64 was for the router, and the /56 is the block for any systems on my network. Am I mistaken?

And finally, why is my /56 the same size as the /48 from HE? They're both 1111:2222:3333:4444:: in size. I thought /56 would have been something like 1111:2222:3333:4444:5555::

I have a long way to go to understand this..


rpnc

join:2011-06-08
Markham, ON

xero9,

The /64 is for the WAN and the /56 is for the LAN. The LAN only needs a /64 so you could have 256 /64 subnets on the LAN. The number after the slash refers to the number of bits that have been given to you out of 128 bits total. So the /56 is 1111:2222:3333:4400::. You can use any values betwen 4400 and 44FF in this example (256 values). You just need the 4400 value. If you were given 2607:f2c0:a0xx:xxxx::/64 and 2607:f2c0:f0xx:xxxx::/56, use 2607:f2c0:a0xx:xxxx::/64 for the WAN and 2607:f2c0:f0xx:xx00::/64 for the LAN. I'm not sure which hardware revision you have but I tried the rev E emulator at D-Link and found that you could go to Advanced > IPv6 and select My IPv6 Connection is PPPoE. You can try PPPoE address mode Dynamic IP, in which case you should get an address from your /64. You can also choose Static IP and select an address from your /64, such as 2607:f2c0:a0xx:xxxx::1. Under LAN IPv6 Address, enter an address from your /56, such as 2607:f2c0:f0xx:xx00::1.


xero9

join:2001-11-29
Ajax, ON

Thanks so much for your help!

The strange thing is, I had TekSavvy's IPv6 set up originally, but now I can't get it to work since using HE.

I did what you said and picked PPPoE (which makes perfect sense to me). If you look at the DIR-615 Rev E simulator, you'll see in LAN IPv6 address setting, there is a 2002::: v6 IP. I tried setting that to the /64 that TekSavvy provided but it won't take. Every time it updates, it resets back to the original value.

I'm not seeing there to put the /56 address either.

Any help would be appreciated!


jrbit

join:2012-06-21
Etobicoke, ON
reply to TSI Gabe

Has anyone had any luck with IPv6 on a Mikrotik router and an MLPPP account? If so, was there anything special that needed to be done besides enabling IPv6?

I was told to continue to use the same @wiredhighspeed.com account name and password, and given my new IPv6 address assignments, but as far as I can tell the PPPoE interface isn't even getting assigned a link-local address.

I captured the packets on the modem interfaces and analyzed it with Wireshark. From what I can tell the router requests link-local address fe80::8 over IPV6CP, which the PPPoE server approves, then instead of declaring its own local identifier the server terminates the IPV6CP session. IPCP and thus IPv4 continue to work normally.

I think maybe my account isn't properly activated for IPv6, but I'm not sure.


rpnc

join:2011-06-08
Markham, ON
reply to xero9

The LAN IPv6 address setting is where you should put in your /56 even though it says /64. You only need a subset of your /56. Put in a value like "2607:f2c0:f0xx:xx00::1". The ::1 on the end chooses a specific IP address within your /56.


xero9

join:2001-11-29
Ajax, ON

Last question, I swear!

This is starting to make sense..

The only thing I'm confused about is when I set my router to do IPv6 over PPPoE I've discovered TekSavvy is pushing this 6to4 address to me (the 2001:: address). So I've concluded I need to use Static IP as the method. What I don't know is, how do I know what the default gateway address is? Short of guessing..


rpnc

join:2011-06-08
Markham, ON

said by xero9:

Last question, I swear!

This is starting to make sense..

The only thing I'm confused about is when I set my router to do IPv6 over PPPoE I've discovered TekSavvy is pushing this 6to4 address to me (the 2001:: address). So I've concluded I need to use Static IP as the method. What I don't know is, how do I know what the default gateway address is? Short of guessing..

The rev E simulator doesn't have an input field for default gateway. It has an IP address field under PPPoE when you choose PPPoE and static IP. You can put an address from your /64 in there, such as "2607:f2c0:a0xx:xxxx::1". For user name, be sure to use your IPv6 username, such as xxxxx@hsiservice.net.

xero9

join:2001-11-29
Ajax, ON
reply to TSI Gabe

Okay so an update.. I've concluded that the DIR-615 is crap, and will not work for native IPv6.

I ended up getting a DIR-655, which some other users have had. I've configured it exactly as they have, and the router is able to get an IPv6 connection going, as I can ping 2001:4860:4860::8888 for example (from the router), and my computer is assigned an IPv6 address, but the 'router' address on my computer is blank, and it's not able to access anything. Almost like the router isn't pushing a route.

Here is the setup I did:




rodjames
Premium
join:2010-06-19
Gloucester, ON

1 recommendation

reply to TSI Gabe

Maybe try running Stateful?


34764170

join:2007-09-06
Etobicoke, ON

said by rodjames:

Maybe try running Stateful?

That won't change anything. The default route is determined via RA and not via DHCPv6.


DragonSpyre
Premium
join:2009-05-20
Aurora, ON

1 recommendation

reply to TSI Gabe

Found that on the Asus RT-N16 that stock firmware didn't seem to be working 100% of the time. Most times it would require a reboot of the router every time a new client connected, also with a reboot of a computer the rebooted machine would not acquire an IPV6 address either.

On switching to a variant of Tomato 1.28 USB developed by Toastman I believe, everything seems to be working smoothly and properly. At test-ipv6.com I get 10/10 for both IPV4 & IPV6. I only had to use the /64 I was assigned though not the /56, being somewhat new to this IP concept is this proper or will it hinder anything?