dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
28049
share rss forum feed


NICK ADSL UK
Premium,MVM
join:2004-02-22
kudos:16
Reviews:
·Zen Internet

3 recommendations

Java Runtime Environment (JRE) 6 Update 21 - July 8, 2010


garofede624

join:2009-12-04
Thanks for this! I wouldn't have known about this otherwise as my Java updater did not alert me to this updated build. I suppose that it is due to the fact that "Java SE 6 Update 21 does not contain any additional fixes for security vulnerabilities to its previous release, Java SE 6 Update 20. Users who have Java SE 6 Update 20 have the latest security fixes and do not need to upgrade to this release to be current on security fixes."


siljaline
I'm lovin' that double wide
Premium
join:2002-10-12
Montreal, QC
kudos:17

2 recommendations

reply to NICK ADSL UK
Thanks, Nick

Those that don't want Sun Java phoning home may turn off automatic updating via your Control Panel (user choice)

Watch your MSCONFIG for new Sun items.


jmorlan
Hmm... That's funny.
Premium,MVM
join:2001-02-05
Pacifica, CA
kudos:4

1 recommendation

reply to NICK ADSL UK
Thanks NICK ADSL UK See Profile. Internal updater didn't find it saying I already had the latest version.

It appears I now have two versions of the Java Deployment Toolkit plugin for Firefox:

[*] Java Deployment Toolkit 6.0.200.2
[*] Java Deployment Toolkit 6.0.210.6

Do I need both?


siljaline
I'm lovin' that double wide
Premium
join:2002-10-12
Montreal, QC
kudos:17

1 recommendation

The infernal update mechanism is unpredicatable, at best, jmorlan See Profile, I am now current.


NICK ADSL UK
Premium,MVM
join:2004-02-22
kudos:16
reply to jmorlan
You should uninstall the older build my friend

Marsman

join:2004-11-10

1 recommendation

reply to NICK ADSL UK
Thx once again Nick!


jmorlan
Hmm... That's funny.
Premium,MVM
join:2001-02-05
Pacifica, CA
kudos:4

1 recommendation

reply to NICK ADSL UK
said by NICK ADSL UK:

You should uninstall the older build my friend
After restarting the browser the older build seems to have disappeared.


jaykaykay
4 Ever Young
Premium,MVM
join:2000-04-13
USA
kudos:24
reply to NICK ADSL UK
Correct. I use JavaRa and it works well.

ctggzg
Premium
join:2005-02-11
USA
kudos:2

1 recommendation

reply to NICK ADSL UK
Not security-related:

"Java SE 6 Update 21 does not contain any additional fixes for security vulnerabilities to its previous release, Java SE 6 Update 20. Users who have Java SE 6 Update 20 have the latest security fixes and do not need to upgrade to this release to be current on security fixes."


siljaline
I'm lovin' that double wide
Premium
join:2002-10-12
Montreal, QC
kudos:17
Reviews:
·Bell Sympatico

1 edit

1 recommendation

reply to jmorlan
The current JRE packages uninstall prior versions at great insistance to Sun from the MVP Community.

Install over-top works just fine assuming you re-adjust the usual annoyances like automatic update via Control Panel and javascheduler via MSCONFIG.

As indicated in the system look-up database:
not required
»www.systemlookup.com/Startup/504···exe.html


antdude
A Ninja Ant
Premium,VIP
join:2001-03-25
United State
kudos:4
Reviews:
·Time Warner Cable
reply to ctggzg
said by ctggzg:

Not security-related:

"Java SE 6 Update 21 does not contain any additional fixes for security vulnerabilities to its previous release, Java SE 6 Update 20. Users who have Java SE 6 Update 20 have the latest security fixes and do not need to upgrade to this release to be current on security fixes."
Nice, but what is this then in its release notes? "Security Exception Upon Drag-and-Drop

Drag-and-drop would, under certain circumstances, result in a null value being passed instead of the expected data.

Java SE 6u21 provides a fix that lets drag-and-drop operations succeed for signed applications or applications with the accessClipboard permission granted."
--
Ant @ »antfarm.ma.cx and »aqfl.net. Please do not IM/e-mail me for technical support. Use the forum! Disclaimer: The views expressed in this posting are mine, and do not necessarily reflect the views of my employer


lordpuffer
RIP lil
Premium
join:2004-09-19
Rio Rancho, NM
kudos:2
Reviews:
·CableOne

1 edit
reply to NICK ADSL UK
Hi Nick.....Before I went to your link, I went to Java's site and looked around, and when I tried to download Java directly from the site, it gave me this message:
--
If you need a re-format, just ask and I'll do it. If you don't need one, just give me 5 minutes with your computer, and you will.


mark5019
Premium
join:2002-03-30
Atlanta, GA
reply to NICK ADSL UK
i dont have auto update options?
win 7 64 bit

garofede624

join:2009-12-04

1 recommendation

reply to antdude
said by antdude :
Nice, but what is this then in its release notes? "Security Exception Upon Drag-and-Drop
This isn't a security vulnerability in the sense that it cannot be used as a malicious exploit. Rather, it refers to a bug that resulted from an ostensible conflict between the application action and security policy.


antdude
A Ninja Ant
Premium,VIP
join:2001-03-25
United State
kudos:4
Reviews:
·Time Warner Cable

1 edit
said by garofede624:

said by antdude :
Nice, but what is this then in its release notes? "Security Exception Upon Drag-and-Drop
This isn't a security vulnerability in the sense that it cannot be used as a malicious exploit. Rather, it refers to a bug that resulted from an ostensible conflict between the application action and security policy.
Ah, OK and thanks. I guess I won't upgrade my Java b20 then!
--
Ant @ »antfarm.ma.cx and »aqfl.net. Please do not IM/e-mail me for technical support. Use the forum! Disclaimer: The views expressed in this posting are mine, and do not necessarily reflect the views of my employer
Expand your moderator at work


Wasim34301

@119.152.5.x
reply to NICK ADSL UK

Re: Java Runtime Environment (JRE) 6 Update 21 - July 8, 2010

Nick, I do not know how to uninstall java 6 update 21 for previous version. Please guide me for uninstall.

Libra
Premium
join:2003-08-06
USA
kudos:1
Reviews:
·Verizon FiOS

1 edit

2 recommendations

You can use add/remove to remove the old java. Reboot. Then you can use javara to clean up any leftovers.

Link to info: »raproducts.org/javara.html

Link to javara: »sourceforge.net/projects/javara/···download

Sincerely, Libra

Edit: the latest versions of java are suppose to remove previous versions.


siljaline
I'm lovin' that double wide
Premium
join:2002-10-12
Montreal, QC
kudos:17
reply to Wasim34301
Add/Remove Programs - uninstall older versions (or) use third-party software recommended in this thread.

The current JRE installers should remove previous builds as also noted in this thread.


ironwalker
World Renowned
Premium,MVM
join:2001-08-31
Keansburg, NJ
reply to NICK ADSL UK
quote:
NOTE: The Firefox 3.6 browser requires Java SE 6 Update 10 or later. Otherwise, Java-based web applications will not work.
Can anyone confirm this with Firefox 3.6.6?
javaRa states that I have java 6.0.200.2
JavaCP says 6 update 20 (build 1.6.0_20-b02)
Java stuff works so I guess I can install to 6.21 with no problem.
Am I reading the quote wrong/ Does firefox 3.6 not work with any java 6 above update 10 or it doesn't work with anything below update 10? (tis really late for me, need sleep
--
Live Free or Die!
»sidux.com/
»www.chronixradio.com



rcdailey
Dragoonfly
Premium
join:2005-03-29
Rialto, CA
I'm pretty sure "later" means the same thing as "higher" or "greater" would mean. That is, in this context, it has the same meaning. Anyway, update 21 works for me and I have Firefox 3.6.6.
--
In reality, there is no such thing as a clean human being.


ironwalker
World Renowned
Premium,MVM
join:2001-08-31
Keansburg, NJ

1 recommendation

reply to NICK ADSL UK
Just updated, all good...night.

lynney62

join:2010-08-07
reply to NICK ADSL UK
I just downloaded Java update 21.....I run windows 7 on a Vaio laptop......do I now need to uninstall my other Java updates 17-20? Thanx.


NervousWreck
Go Fast,Turn Left.
Premium
join:2000-11-05
Inside,Row 1
OK, I ended up with two Java Consoles in Add-ons / Extensions. Java Console 6.0.20 and 6.20.21. Uninstall was grayed out only option was to disable. Is this OK?
--
N.W.


jmorlan
Hmm... That's funny.
Premium,MVM
join:2001-02-05
Pacifica, CA
kudos:4
said by NervousWreck:

OK, I ended up with two Java Consoles in Add-ons / Extensions. Java Console 6.0.20 and 6.20.21. Uninstall was grayed out only option was to disable. Is this OK?
Right click on Firefox and select "Run as Administrator." Then the uninstall options will be active.


NervousWreck
Go Fast,Turn Left.
Premium
join:2000-11-05
Inside,Row 1
Thank you jmorlan.
--
N.W.

hybucket

join:2001-10-10
Boston, MA
reply to jmorlan
I just checked my add-ons (which I hardly ever do), and I have

Java Console 6.0.4, 6.0.5, 6.0.17 and 6.0.20
Do I need to get rid of the older ones? Do I need to D/L 6.0.21?
And shouldn't the older ones have been uninstalled when the newer ones were installed?


jmorlan
Hmm... That's funny.
Premium,MVM
join:2001-02-05
Pacifica, CA
kudos:4
said by hybucket:

I just checked my add-ons (which I hardly ever do), and I have

Java Console 6.0.4, 6.0.5, 6.0.17 and 6.0.20
Do I need to get rid of the older ones? Do I need to D/L 6.0.21?
And shouldn't the older ones have been uninstalled when the newer ones were installed?
I would recommend cleaning all that up.

Only recent versions of Java RTE remove older versions. The older versions should all be removed manually; not just the console, but the whole RTE. Some of them have security liabilities.

Most users have no need for the Java Console extension. If you don't know what it is for, you don't need any of them.

Libra
Premium
join:2003-08-06
USA
kudos:1
Reviews:
·Verizon FiOS
I never updated to version 6_21. I just checked my add-ons in IE and I have the Java Console 6_20, Java Plug-in 2-SSV Helper, Java Plug-in 6_11 and Java Plug-in 6_20.

I just looked in the registry and it only shows 6_20 as a plugin. When I removed 6_11 I used JavaRa and never got a list or confirmation (in Vista). I disabled 6_11 in IE since I can't seem to remove it any other way.

I think I'll disable the console on your advice, since I don't know what it's for . Should the SSV-Helper be disabled? Somehow I think it should, but can't remember why.

Thank you.

Sincerely, Libra