dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
391
share rss forum feed

amigo_boy

join:2005-07-22

4 edits
reply to Msradell

Display power-off stopped working (Win 7, Solved)

said by Msradell:

said by bitstopjoe:

What works for me is to go into the power settings, click never, apply then ok. Back into power set it to 5 min ( or whatever you want) apply then ok. It works fine until you reboot. At least for me XP SP3.
I've seen this solution but it doesn't work for Windows 7.
I found the solution. This only works for Win 7 (not Vista). If someone finds a solution for Vista, please post it.

The problem: MJ has always disabled energy-savings features to prevent the computer from hibernating (unable to answer calls). With the recent upgrade, MJ now disables the screen's dim/off feature. Manually changing settings in Windows' Power Management screen doesn't cause the energy-savings features to regain control (as it apparently does in XP).

This gives the appearance MJ has taken total control of a computer's power management.

The reason: This has to do with something called power requests. Starting with Vista, an application can request the OS not apply power savings for the system (hibernate), display (dim) or something called awaymode (another power-saving state).

These requests can be seen and disabled with the powercfg command. This command was introduced with Vista, and the two features (/requests and /requestsoverride) described below were added in Win 7.

The following command shows all the requests to prevent energy savings.

dosbatch code:
C:\>powercfg /requests
DISPLAY:
[PROCESS] \Device\HarddiskVolume1\Users\????\AppData\Roaming\mjusbsp\magicJack.exe

SYSTEM:
[PROCESS] \Device\HarddiskVolume1\Users\????\AppData\Roaming\mjusbsp\magicJack.exe

AWAYMODE:
None.

C:\>

As you see, MJ has a request to prevent the system from entering hibernation/standby. Another to prevent screen dimming and power off.

Info: Because MJ is a process, it is prefixed in the results with the "PROCESS" keyword. Services and drivers can also make requests. If you have any, you'll see them prefixed with those keywords.

The solution: Microsoft allows administrators to override application requests. The following two commands will override (disable) MJ's power request for the display only:

dosbatch code:
powercfg /requestsoverride PROCESS magicJack.exe DISPLAY
powercfg /requestsoverride PROCESS ^
\Device\HarddiskVolume1\Users\????\AppData\Roamin\mjusbsp\magicJack.exe ^
DISPLAY

Note: Don't copy the above. One command has the full path obtained from the requests output. Be sure to use the path from your requests output.

Note: The "^" is the "continuation character" used by Windows' command/batch language to break a long command onto multiple lines. You can execute the command exactly as you see it (although the path should be your path). Or, remove the "^" symbols and put it all on one line. (I broke it onto shorter lines just so the line wouldn't exceed your browser's width, causing a scroll bar).

All overrides can be seen with the following command, showing the overrides created above:

dosbatch code:
C:\>powercfg /requestsoverride
[SERVICE]

[PROCESS]
magicJack.exe DISPLAY
\Device\HarddiskVolume1\Users\????\AppData\Roaming\mjusbsp\magicJack.exe DISPLAY

[DRIVER]

C:\>

After creating those two overrides, my monitor now dims and turns off as expected.

Info: To remove an override, execute the command like you did to add one. But, omit the DISPLAY parameter at the end of the command. (If you make mistakes, trying these instructions a few times, you could end up with more overrides than the two above. You can remove them all and start over.).




Notes:

- Overrides are persistent. Execute the commands once. The overrides will be present when you restart your computer.

- You must have administrator rights to execute the requestsoverride command. If you're using a computer managed by a support group, ask them to do it for you. If it's your own computer and you don't have admin rights, read some articles on the topic.

- The commands can be entered into a Command Prompt window. (Start->Accessories->Command Prompt). Right click in the window and choose "Paste."

- I don't know why it requires two overrides. I would think MJ's power request would match one override. But, I tried both forms of override individually (with or without path). Neither worked. It doesn't make sense. But, it's the only way it works.

- I believe you can add "SYSTEM" to the end of the override command provided above. That will override both the DISPLAY and SYSTEM requests. That should let your computer go into hibernate/sleep states (whatever your power-savings plan specifies). This is probably not desirable. If MJ's running, you probably want your computer to stay on. But, there could be cases where you want your computer to poweroff after a period of activity. Adding "SYSTEM" to the override command should do it.


Macy
South Of Insanity
Premium,MVM,ExMod 2004-7
join:2001-12-02
Pink Beanbag
kudos:2
Have any suggestions on getting this to work with Vista? So far I've had no luck but it does work fine in Windows 7.
--

~ Feel Your Heart Race ~

amigo_boy

join:2005-07-22
said by Macy:

Have any suggestions on getting this to work with Vista? So far I've had no luck but it does work fine in Windows 7.
I don't have any experience with Vista. (I lived with XP and upgraded to Win 7 last November.).

I thought I read somewhere that this requests/requestsoverride was introduced with Vista. But, the powercfg command indicates those parameters are available for Win 7 only.

You might try changing your power management settings and see if that causes them to be respected. If it does, you could use the powercfg command to automate that. (I think you can make the same setting changes with the command as you can through the GUI.).

If you, or anyone figures something out for Vista, let me know and I can update the instructions to be clearer.

(You should consider upgrading to Win 7. Vista was like Windows Me. A not-so-perfect step between Win 98 and XP. Vista was that same step between XP and 7.).


Macy
South Of Insanity
Premium,MVM,ExMod 2004-7
join:2001-12-02
Pink Beanbag
kudos:2
Thanks for the quick reply. I've changed power management settings and the screen saver works fine but the display settings haven't worked. I can change them with the powercfg command, the settings persist but they still won't work.

I've thought about upgrading this computer to Windows 7 but I have a couple of graphics and video editing programs that isn't compatible with 7 so I've held off upgrading.

I'll try a few more things this weekend and will post back if I make any progress.

Thanks again for the reply.
--

~ Feel Your Heart Race ~


Vista_blues

@verizon.net
I'm running Vista as well and it looks like it has powercfg but not the "/requests" option. Looks like I'll need to upgrade to Windows 7 - darn!


Telbont

@comcast.net
reply to amigo_boy
Thanks Amigo boy for the working solution to this rather vexing issue. Finally nailed the problem down after checking and re-checking many other options.

CheeseKing

join:2010-08-29
Columbus, IN
reply to amigo_boy
I registered an account just to say this.. Thank you amigo_boy!


mistervane

@rogers.com
reply to amigo_boy
Hmmmm....I just don't know why this is not working for me!? I have executed the cmd exactly as described, using my correct path, etc. and when I check it with C:\>powercfg /requestsoverride
it shows magicjack as being overrode, but my screensaver still does not come on. Tried rebooting, tried changing my screensaver start times, nuthin'!! Any ideas?
I am running Windows 7 64bit Ultimate.

Thanks!


mistervane

@rogers.com
reply to amigo_boy
Follow up: When I first discovered it was the Magicjack stopping my screensaver from working, simply by unplugging it, the screensaver started working again. Then I tried these cmd functions to see if I could get both working, but it didn't work, so I undid any and all cmd entry overrides, and checked that they weren't there anymore, and tried unplugging my magicjack, but now my screensaver won't work at all!! Magicjack or no magicjack! It's like magicjack permanently destroyed my screensaver from working. Any ideas?? I have no clue why it's not working even without magicjack plugged in.

Thanks!!!

amigo_boy

join:2005-07-22
reply to mistervane
said by mistervane :

I am running Windows 7 64bit Ultimate.
I'm using Win 7, 64-bit. I didn't have a screen saver enabled. Therefore, the powercfg commands were just for Power Management (screen dim and off).

I just right-clicked on the desktop and chose "Personalize." Then clicked "Screen Saver" in the lower right corner. I enabled "Bubbles" with 1-minute timeout.

It came on after 1-2 minutes. I shutdown magicJack. And the screensaver came on after 1-2 minutes. Started magicJack again, and the screensaver came on after 1-2 minutes.

So, as far as I can tell, magicJack doesn't interfere with the screen saver.

You might try going into Personalize and disable the screensaver. Go back in and enable it.

Are you using one of the standard Windows screensavers? Or, something you downloaded somewhere?

amigo_boy

join:2005-07-22
reply to mistervane
Continuing my previous reply to you.

I removed my two requestsoverride display rules (the creation of which was described here). The screensaver (I created in my first reply to you) stopped working. I created the requestsoverride display rules and the screensaver began working (without me having to do anything else).

So, my guess is that you didn't get the rules right. Or, you're using a third-party screen saver.

I suggest that you disable you screen saver and focus only on getting the rules to work with the Power Management features to dim and power off the display after (for example) 1 and 3 minutes, respectively.

Get that working, so you know you have the requestsoverride display rules working correctly. Then experiment with the screen saver. This would help isolate what the problem is, eliminating the possibility your screen saver is unusual.

The Power Management settings can be reached through the bottom of the Personalize->Screen Saver page.


mistervane

@rogers.com
reply to amigo_boy
said by amigo_boy:

said by mistervane :

I am running Windows 7 64bit Ultimate.
I'm using Win 7, 64-bit. I didn't have a screen saver enabled. Therefore, the powercfg commands were just for Power Management (screen dim and off).

I just right-clicked on the desktop and chose "Personalize." Then clicked "Screen Saver" in the lower right corner. I enabled "Bubbles" with 1-minute timeout.

It came on after 1-2 minutes. I shutdown magicJack. And the screensaver came on after 1-2 minutes. Started magicJack again, and the screensaver came on after 1-2 minutes.

So, as far as I can tell, magicJack doesn't interfere with the screen saver.

You might try going into Personalize and disable the screensaver. Go back in and enable it.

Are you using one of the standard Windows screensavers? Or, something you downloaded somewhere?
Thanks for the replies!!
I have tried everything imaginable, but nothing works. No screensaver, no "turn off monitor", nothing about power management works. I am even currently on a different hard drive (I have multiple drives with Windows 7) on which I never even tried the cmd functions. Right now, my Magicjack is unplugged, it booted up without it plugged in, but nothing in the power management works. I'm stumped. It all worked before the dreaded magicjack update, then it stopped working, but now it won't even work without magicjack plugged in. I tried disabling and re-enabling, etc. nuthin'!!
I thought at least I'd get my screensaver/power management back if I unplugged my magicjack, so now I'm totally lost. I don't know what's stopping it. I have tried unplugging my mouse, but that doesn't work (and it worked before anyway). The thing is, when I first troubleshooted this and found out it was magicjack, I unplugged it and my screensaver worked, without even rebooting, so I was like "yeah, problem located", but now...no clue!
Any other possibilities??
Thanks a bunch!!

Rant

p.s. standard Windows screensavers.


mistervane

@rogers.com
reply to amigo_boy
said by amigo_boy:

Continuing my previous reply to you.

I removed my two requestsoverride display rules (the creation of which was described here). The screensaver (I created in my first reply to you) stopped working. I created the requestsoverride display rules and the screensaver began working (without me having to do anything else).

So, my guess is that you didn't get the rules right. Or, you're using a third-party screen saver.

I suggest that you disable you screen saver and focus only on getting the rules to work with the Power Management features to dim and power off the display after (for example) 1 and 3 minutes, respectively.

Get that working, so you know you have the requestsoverride display rules working correctly. Then experiment with the screen saver. This would help isolate what the problem is, eliminating the possibility your screen saver is unusual.

The Power Management settings can be reached through the bottom of the Personalize->Screen Saver page.
Follow up: This is what I get when I check powercfg:

C:\>powercfg /requests
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

Magicjack is not plugged in, but nothing works in power management.

Thanks!!
Rant

amigo_boy

join:2005-07-22
said by mistervane :

Magicjack is not plugged in, but nothing works in power management.
I would manually change the Power Management settings. Maybe they're not in effect and changing their values would fix that. I would disable your screen saver, and work on getting screen dim/off (and hibernation) working.

I don't think the problem is MJ. It sounds like you may have other things running that make it appear your computer is active and can't power down.

I don't know why it seemed to occur with the MJ upgrade.

I don't have more suggestions. Reinstall Windows, maybe.


mistervane

@rogers.com
said by amigo_boy:

said by mistervane :

Magicjack is not plugged in, but nothing works in power management.
I would manually change the Power Management settings. Maybe they're not in effect and changing their values would fix that. I would disable your screen saver, and work on getting screen dim/off (and hibernation) working.

I don't think the problem is MJ. It sounds like you may have other things running that make it appear your computer is active and can't power down.

I don't know why it seemed to occur with the MJ upgrade.

I don't have more suggestions. Reinstall Windows, maybe.
Thank you so much for your suggestions and your speedy replies! I will take everything into consideration and do my best so resolve the sitch.
Best regards,
Rant


mistervane

@rogers.com
said by mistervane :

said by amigo_boy:

said by mistervane :

Magicjack is not plugged in, but nothing works in power management.
I would manually change the Power Management settings. Maybe they're not in effect and changing their values would fix that. I would disable your screen saver, and work on getting screen dim/off (and hibernation) working.

I don't think the problem is MJ. It sounds like you may have other things running that make it appear your computer is active and can't power down.

I don't know why it seemed to occur with the MJ upgrade.

I don't have more suggestions. Reinstall Windows, maybe.
Thank you so much for your suggestions and your speedy replies! I will take everything into consideration and do my best so resolve the sitch.
Best regards,
Rant
Update:
I found the culprit! It's my X-box 360 controller for PC. The "unplug your usb devices" helped alot. Without magicjack plugged in, there had to be another culprit. I noticed that when I went into NFS Underground my menu selection would jump around, and it was my left thumbstick that was constantly triggering. It's a new controller, and when I wiggle it and work it in, it stops acting up, so it might just need some time. But that was definitely stopping my screensaver/power management from enabling. So now, I'll be able to go back and add the cmd tweaks so I can replug my magicjack and all should be great! Thanks for replies and thanks for your magicjack tweak!! Much appreciated!!
Rant


Astoman72

@telecable.com.do
reply to amigo_boy
Amigo_boy,
Thank you for the work around to this issue.

It's not surprising how these corporations team up to control our lives and the things we do. In the case at hand, we have MJ controling how our computers behave by MS giving them (Corporations) the tools to apply controls via their O/S without our knowledge or permission. The worse part of all this is that we ACTUALLY pay MS for the O/S License! And, it's not only with this, it's with many other activities that they are controling us and what we do...and it will get worse... Believe me.

the Matrix movie is just one concept of how it will be in the near future for mankind. Luckily, we have knowledgeable and curious individuals like yourself that can identify there doings and find ways to "override" their control over us.

Thank you again for your contribution...Good Job!!


Damo

@rr.com
reply to amigo_boy
Thanks so much for the workaround command line code. Worked perfectly. I chatted with MJ today for about an hour. They admitted the problem immediately and told me they have been instructed to tell everyone to either pull the magicJack out or configure the sleep mode. Of course, both of these suggestions are totally unacceptable.


poweroffagn

@comcast.net
reply to amigo_boy
Thanks amigo_boy this worked great. I experimented and found I only needed the one override entered for some reason (without the full path) and it still works. I also found out that case matters too. ie magicjack.exe will not work magicJack.exe does.

C:\Windows\system32>powercfg /requestsoverride
[SERVICE]

[PROCESS]
magicJack.exe DISPLAY

[DRIVER]

Thanks again!


ecomagicjack

@tds.net
reply to amigo_boy
I have already looked into this when this first came about.

It appears that it does not work.

The only way it works for me windows 7 ultimate 32bit is if I unplug my magicjack.

The requestsoverride does not work for magic jack trust me I have spent 1 whole day on this!

And this is a bit inaccurate the way that you describe it is not how it looks.

when you type powercfg /requestsoverride

it only shows the line like so up to the users name then it follows with display service or just display depending on what you disabled.

amigo_boy

join:2005-07-22
said by ecomagicjack :

It appears that it does not work.

The only way it works for me windows 7 ultimate 32bit is if I unplug my magicjack.

The requestsoverride does not work for magic jack trust me I have spent 1 whole day on this!
It seems to work for a lot of people. I'm sorry it doesn't work for you.

said by ecomagicjack :

And this is a bit inaccurate the way that you describe it is not how it looks.

when you type powercfg /requestsoverride

it only shows the line like so up to the users name then it follows with display service or just display depending on what you disabled.
I couldn't understand what you said. If you're seeing something different than I described, maybe a screenshot would help communicate what you're seeing?


RollerburnNe

@sbcglobal.net
reply to amigo_boy
Need help correcting this with XP. I consider myself fairly computer savy but cannot get the commands to work in XP. ANy thoughs? I hate this recent upgrade...

amigo_boy

join:2005-07-22
The commands only work with Win 7. For XP, you have to manually go in and re-enable your power settings. Read through the thread, especially a couple posts before yours. They talk about XP.


bitstopjoe

join:2009-08-02
Pen Argyl, PA
reply to RollerburnNe
Right click on your desktop, click properties, then screen saver, then power. Click never, apply then ok. Then click power again I click 5 min then apply then ok.

Cant make it any clearer than that..

Again this ONLY works on XP, Win 7 is more involved, just read all the posts here to find out what you have to do.

Joe Sica

stevegriz
Premium
join:2007-04-15
Round Rock, TX
reply to mistervane
How do I remove the request overide rules???

jwichman

join:2008-04-28
Emden, MO
reply to bitstopjoe
said by bitstopjoe:

Right click on your desktop, click properties, then screen saver, then power. Click never, apply then ok. Then click power again I click 5 min then apply then ok.

Cant make it any clearer than that..

Again this ONLY works on XP, Win 7 is more involved, just read all the posts here to find out what you have to do.

Joe Sica
I tried it real quickly on my XP system and it didn't work.

However earlier I was testing some microphones over magicJack with a friend and hadn't yet unhooked the 3 USB audio devices I had connected - in addition to the built-in audio!

I think that might'a been holding it up a tad LOL

P.S. Best was a mVox USB speakerphone closely followed by a Sun microphone (part# 370-1414) copped off of a circa 1997 Sun Sparc workstation.


prfek

@rr.com
reply to amigo_boy
What am I doing wrong? I went to command prompt. I copied everything and pasted it there. I got a reply that I may not be allowed to make this change or something like that. I am logged on as the administrator on my computer. Anyway I continued with the steps and restarted the computer. No change. The monitor still will not shut down with the MJ plugged in. Could you please explain the process more clearly for those of us who are not as computer savvy. I know how to get to command prompt. I know how to copy and paste. What got me confused here is which of the blocks of code was supposed to be used. I tried the one in the middle, but that one was the one that told me I had a problem. HELP PLEASE!!!


bitstopjoe

join:2009-08-02
Pen Argyl, PA

1 edit
Don't bother. Go to the MJ home page and d/l the update. They went to version 2.03 which fixed the screen saver not working problem.

Works for me in XP and from what I read for others in 7 and Vista.

Joe Sica


David1958

@bellsouth.net
reply to amigo_boy
amigo_boy, I would also like to thank you for this information. Works great for me. I think the people at MagicJack should thank you also.

jeffnyc

join:2004-06-09
Atlanta, GA
reply to amigo_boy
I am Anyone use MCE Standby Tool? It must affect powercfg and MJ.