dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
4403
share rss forum feed

linked2you

join:2010-11-02
San Clemente, CA

Unable to browse to certain websites. Any suggestions?

I setup a doctor's office with Internet access using Covad's DSL network using a Netopia DSL modem acting as a dedicated bridge and a Cisco 871 router acting as the PPPoe client.

I was able to get the router to authenticate and allow Internet access to sites such as AOL, MSN, craigslist, but some of the websites such WebMD would just stall and sit there. You would see the banner page at the top of the browser window but the content would not download and display. Does anyone know from this scenario whether this could be the DSL modem or the router?


LBDSL
Lightning Bolt

join:2002-01-07
Auburn Hills, MI
your issue would be the router, since your modem is a dumb bridge. One thing to look at is MTU
--
Lightning Bolt Technologies


RealoRc
Premium
join:2003-01-25
Brooklyn, NY
reply to linked2you
Could it be dns servers also?

linked2you

join:2010-11-02
San Clemente, CA
reply to LBDSL
Thanks for the reply,

Here is stripped down version of my running config ...Notice that I have the dialer interface mtu set at 1492. Is that the correct parameter?

vpdn enable
vpdn-group 1
request-dialin
protocol pppoe
exit

Now we configure one FastEthernet interface for use as our WAN interface.

interface FastEthernet 4
description ADSL WAN Interface
shutdown
pppoe enable
pppoe-client dial-pool-number 1
ip nat outside
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
no cdp enable
no shutdown
exit

Now to add your Dialer interface:

interface dialer 0
description ADSL WAN Dialer
shutdown
ip address negotiated
ip mtu 1492
encapsulation ppp
ip nat outside
encapsulation ppp
ppp authentication chap callin
ppp chap hostname
ppp chap password
dialer pool 1
dialer-group 1
no ip mroute-cache
no ip unreachables
no cdp enable
no shutdown
exit

dialer-list 1 protocol ip permit

interface vlan 1
description ADSL LAN Interface
shutdown
ip nat inside
ip address a.b.c.3 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
no cdp enable
no shutdown
exit

access-list 10 permit a.b.c.0 0.0.0.255

no cdp run

Create poool of globabl IP addresses for NAT
ip nat pool Pool1 a.b.c.11 a.b.c.250 netmask 255.255.255.0

Enable dynamic translation of addresss on the inside interface
ip nat inside source list 10 interface dialer 0 overload

Make router a DHCP server
ip dhcp pool LANPOOL
network a.b.c.0 255.255.255.0
default-router a.b.c.3
dns-server 64.105.132.250 64.105.132.252

exit

ip dhcp excluded-address a.b.c.1 a.b.c.10
ip dhcp excluded-address a.b.c.252

ip route x.y.z.0 255.255.255.0 a.b.c.252
ip route j.k.l.0 255.255.255.0 a.b.c.252
ip route 0.0.0.0 0.0.0.0 dialer 0

ppp ipcp dns request accept
ppp ipcp address accept

line con 0
password
stopbits 1
exit

line vty 0 4
exec-timeout 120 0
password
login
length 0
exit

linked2you

join:2010-11-02
San Clemente, CA
reply to RealoRc
My apologies ...my post didn't really describe the issue properly. The DNS works fine. The problem is the web page partially loads and then just hangs/stalls.