dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1621
share rss forum feed

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online

Frame relay setup woes

Alright, me again. Have two Cisco 1721s with a WIC-1T on each and a DB60 to DB60 DCE to DTE cable. After much toying around I got the interfaces to come up. Now the next hurdle is layer 3 connectivity. The DTE can ping the DCE but the DCE cannot ping the DTE.

Config file outputs below...


This is router configured as DCE

QUEENS_1721#sh run
Building configuration...
 
Current configuration : 940 bytes
!
! Last configuration change at 02:29:57 UTC Wed Nov 15 2006
! NVRAM config last updated at 02:30:10 UTC Wed Nov 15 2006
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname QUEENS_1721
!
logging queue-limit 100
enable secret 5 xxx
enable password xxx
!
ip subnet-zero
no ip routing
!
!
!
frame-relay switching
!
!
!
!
interface Ethernet0
 ip address 20.17.13.2 255.255.255.0
 no ip route-cache
 half-duplex
!
interface FastEthernet0
 ip address 10.17.12.23 255.255.255.0
 no ip route-cache
 speed auto
 full-duplex
!
interface Serial0
 ip address 30.1.1.2 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 clockrate 8000000
 frame-relay map ip 30.1.1.1 30
 frame-relay interface-dlci 20
 frame-relay intf-type dce
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 password xxx
 login
!
end
 

This router is configured as DTE
BRONX_1721#sh run
Building configuration...
 
Current configuration : 682 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BRONX_1721
!
enable secret 5 xxx
enable password xxx
!
ip subnet-zero
no ip routing
!
!
!
!
interface Ethernet0
 ip address 20.17.13.1 255.255.255.0
 no ip route-cache
 half-duplex
!
interface FastEthernet0
 no ip address
 no ip route-cache
 speed auto
 full-duplex
!
interface Serial0
 ip address 30.1.1.1 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 frame-relay map ip 30.1.1.2 20
 frame-relay interface-dlci 30
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 password xxx
 login
!
end
 

Ping succeeds from DTE to DCE as shown below
BRONX_1721#ping 30.1.1.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

This is current PVC stats. Apparently both DLCIs are up and can "see" each other...
QUEENS_1721#sh frame-relay
Nov 15 02:45:45.379: %SYS-5-CONFIG_I: Configured from console by console pvc
 
PVC Statistics for interface Serial0 (Frame Relay DCE)
 
              Active     Inactive      Deleted       Static
  Local          2            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
 
DLCI = 20, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0
 
  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:30:50, last time pvc status changed 00:24:09
 
DLCI = 30, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0
 
  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:16:43, last time pvc status changed 00:16:43
 
 

Both router frame relay mappings show active as well with corresponding IPs. I configured them static after having a hard time getting the DCE to issue dynamic mapping.
QUEENS_1721#sh frame-relay map
Serial0 (up): ip 30.1.1.1 dlci 30(0x1E,0x4E0), static,
              CISCO, status defined, active
 
BRONX_1721#sh frame-relay map
Serial0 (up): ip 30.1.1.2 dlci 20(0x14,0x440), static,
              CISCO, status defined, active
 

Welp.. :(

TIA

nosx

join:2004-12-27
00000
kudos:5
Rip all that config out of the parent interface and use a subinterface instead:
interface Serial0
  encapsulation frame-relay ietf
 exit
interface Serial0.16 point-to-point
  frame-relay interface-dlci 16
  ip address 1.1.1.1 255.255.255.252
  no shut
 
You shouldnt need any static frame-relay map commands to map IP addresses to DLCIs.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
Alright, still having issues.

The point of having a router acting as a frame relay switch is to deliver DLCI information automatically, no? Despite doing the frame-relay switching command on one of the 1721s, the second 1721 will not see it's neighbor unless I do a static mapping.

Unless I'm missing something in the config, how will the directly attached neighbor frame relay router get its mapping?

The available DLCIs show up when I do show frame pvc command, but they'll stay unused unless I manually map both interfaces.

nosx

join:2004-12-27
00000
kudos:5
If you are going to connect two routers together with PVCs, you need to define those PVCs and build them from one point to another. SVCs are still very much the same way, you need to map all endpoints on a switched virtual circuit with that DLCI information. My suspicion is that you are wanting frame-relay to behave like ethernet and automagically ARP for L2 reachability information for an IP address and discover where to send packets to. I think the fundamental issue here is that frame-relay is not a broadcast multiaccess technology.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
Yeah, that's really what I'm trying to practice. The course instructor said technically that's what should happen if inverse arp is enabled. He simulated the dynamic assignment to the serial interface by using one of the routers as a frame relay switch.

Not possible? Or is there a secret frame mapping command that I'm forgetting?

nosx

join:2004-12-27
00000
kudos:5
Did your instructor do it with 2 routers back to back or did he have a 3rd frame-relay switch device in the middle?
There is no magic with frame-relay, the router must put a frame on the wire with a DLCI. If it doesnt know what DLCI to use, its not going to work well. Frame-relay inverse-arp can work if you have the same DLCI on either side i believe? Its been a long time, not many people deploy frame switching anymore.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
Instructor has three routers, second one in the middle acting as frame relay switch.

And now that I think of it, yes; both sides need to have same locally significant DLCI but it wasn't using a frame map command, I think it was frame routing DLCI to interface or something to that effect.

So what do most corporate WAN links use now? Straight Ethernet with an ASA? Not that I feel like I'm wasting my time learning this 'cause I like it, but I suppose I can spend more time learning ACLs than this.

nosx

join:2004-12-27
00000
kudos:5
Um no... They terminate circuits that goto a service providers cloud (Layer3 MPLS VPN service). They can be anything from subrate T1 to DS3 to OC# to ethernet varying site by site based on bandwidth needs etc.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Alright.. Something to look forward to when I get started on my CCNP.

Thanks though. I'm gonna play with it some more tonight and see how far I get.

JamesVPN123

join:2010-11-17
For what you are after the best thing is with three routers with one acting as the frame relay switch.

R1----serial----R2----serial----R3
s0/0----s0/0-s0/1----s0/0

The frame relay in the middle (R2) is purely DCE ended serial.

Example configs are something like:

R2:

 frame-relay switching
 interface Serial0/0
   no ip address
   encapsulation frame-relay
   clockrate 8000000
   frame-relay intf-type dce
   frame-relay route 600 interface Serial0/1 100

 interface Serial0/1
   no ip address
   encapsulation frame-relay
   clockrate 8000000
   frame-relay intf-type dce
   frame-relay route 100 interface Serial0/0 600


R1:

 interface Serial0/0
   bandwidth 8000
   no ip address
   encapsulation frame-relay
 interface Serial0/0.600 point-to-point
   ip address 192.168.101.1 255.255.255.252
   frame-relay interface-dlci 600


R3:

 interface Serial0/0
   bandwidth 8000
   no ip address
   encapsulation frame-relay
 interface Serial0/0.100 point-to-point
   ip address 192.168.101.5 255.255.255.252
   frame-relay interface-dlci 100


Note: The frame-relay switching command only goes on the frame relay swtich (router), and R2 is transparent to the operation of the R1/R3. If you want a connection to R2 you will need a separate serial line, and suggest you use PPP encapsulation to master the art of passwords, etc.

In the real world the ISP / Telco would provide the services of R2, and this is only used as a lab device. In reality you may well use PPP / a.n.other encapsulation on a point to point physical link, as the benifits frame relay brings may well be negated in a back to back situation. One of the many benifits is that you only need one physical link at any one site, but can have multiple PVCs / SVCs to other sites, in what ever topology you want / can afford.

Also, with a multipoint setup, you can never sucessfully ping the local (node you are pinging from) router's frame relay interface ip...

There are some real cheap 2500s and 2600 routers on ebay at the moment, and can recomend the 2612 with a WIC-2T card in for R2...

Feel free to IM me to chat further, but I am not always on line.

James.

HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to Network Guy
said by nosx:

They can be anything from subrate T1 to DS3 to OC# to ethernet varying site by site based on bandwidth needs etc.
Frame Relay Tx/Ex/OCx I can understand... frame-relay ethernet?! Or am I crossing a few wires here nosx?

Regards

nosx

join:2004-12-27
00000
kudos:5
Read my post again, im not talking about frame relay.
"Layer3 MPLS VPN service"

HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to Network Guy
Crossed wires... it's been a long week *sighs*

Regards

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
reply to Network Guy
Alright, so I finally figured out what was wrong.

I setup the serial interfaces back-to-back as planned. While setting them up, I also had the E0 interfaces on both routers enabled back-to-back with L2 and L3 connectivity as well. I setup and left the E0 interfaces online so I can setup the serial connections without having to keep swapping the console cable between the routers.

The second I disabled the E0 interfaces, both serial connections had L3 connectivity between them.

Big case of doh! Shoulda known better.

Now onto the next hurdle.. NAT'ing on router 1 so router 2 and resources behind router 2 can access the web.