dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
4737
share rss forum feed

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online

Using GNS3 simulator

So I finally got around to using this simulator. (Very super cool stuff so far by the way!!). I wanted to use the IOS from a Cisco 1721 router since I use the actual router at home with my lab but for some reason it won't let me bind a WIC-1T interface to another WIC-1T off a second 1721 in the same topology.

I managed to find an IOS for a 2691 and that seems to bind a WIC-1T on each router so far (haven't configured anything yet).

Anyone use GNS3 and came across this?

I'm pretty excited to get this thing going. We'll see


Da Geek Kid

join:2003-10-11
::1
kudos:1

1 edit
that's easy... reboot the pc. the sessions are being used and it can't bind sometimes...

edit: just tested 2 1721 with WIC-1T no issues..

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Grr.. Been playing with it with little success. I got two WIC-1Ts (one on each 2691) to bind once. For some reason it won't bind again.

I'll try removing all settings, reboot, retry.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
reply to Da Geek Kid
Alright, I think I figured it out.

I gotta make the links before starting the routers. I was able to link the WIC-1Ts back to back again.

Thanks

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
reply to Da Geek Kid
Alright, another silly question, perhaps.

I'm trying to simulate frame relay between two 2691s and a frame relay switch. From the studying I've done and the toying around with the two 1721s I have with a WIC-1T on each, the interface type is determined by the serial cable installed. You can set the "frame intf-type" to dce or dte all you want, but the interface will only provide clocking if the cable says it's a DCE and it won't if the cable says it's a DTE.

Unless I'm missing something, the serial interfaces on both 2691s in the simulator are coming up as DCEs and naturally, I can't get them to "talk."

You know where to change this?


Da Geek Kid

join:2003-10-11
::1
kudos:1

1 edit
huh????

you set up couple of routers and connect them to the virtual FR... I have never had any issues doing this... Have you read the GNS3 docs???

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
This is what I've configured thus far. Maybe I need to read the GNS docs.

I know a frame relay switch provides the clocking "in real life" but I can't seem to change the serial interfaces to DTEs.

Diagram of network in GNS



Config of router 1
R1#sh run
Building configuration...
 
Current configuration : 797 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
frame-relay switching
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 30.1.1.1 255.255.255.252
 encapsulation frame-relay
 clock rate 8000000
 frame-relay map ip 30.1.1.2 200 IETF
 frame-relay interface-dlci 100
 frame-relay intf-type dce
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
 

Config of router 2
R2#sh run
Building configuration...
 
Current configuration : 796 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
frame-relay switching
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 30.1.1.2 255.255.255.252
 encapsulation frame-relay
 clock rate 800000
 frame-relay map ip 30.1.1.1 100 IETF
 frame-relay interface-dlci 200
 frame-relay intf-type dce
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
 
 

Frame mappings
PVC Statistics for interface Serial0/0 (Frame Relay DCE)
 
              Active     Inactive      Deleted       Static
  Local          0            2            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
 
DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0/0
 
  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:09:14, last time pvc status changed 00:05:25
 
DLCI = 200, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0/0
 
  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:06:32, last time pvc status changed 00:05:26
 

Serial WICs on both routers come up as DCEs so they both come up with this:
Interface Serial0/0
Hardware is GT96K
DCE 530, clock rate 8000000
idb at 0x627E4CE8, driver data structure at 0x627EC404
wic_info 0x627ECA00
 


Da Geek Kid

join:2003-10-11
::1
kudos:1
Reviews:
·Callcentric
reply to Network Guy
well... Here's your answer in the GNS3 docs:

* Why my serial connection works though the interfaces are both DCE?

GNS3/Dynamips doesn't emulate the physical layer which is why the serial connections work even though they are both DCE.

aryoba
Premium,MVM
join:2002-08-22
kudos:4
said by Da Geek Kid:

well... Here's your answer in the GNS3 docs:

* Why my serial connection works though the interfaces are both DCE?

GNS3/Dynamips doesn't emulate the physical layer which is why the serial connections work even though they are both DCE.

This is one of the reason why no simulators beat the real thing

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
reply to Da Geek Kid
said by Da Geek Kid:

well... Here's your answer in the GNS3 docs:

* Why my serial connection works though the interfaces are both DCE?

GNS3/Dynamips doesn't emulate the physical layer which is why the serial connections work even though they are both DCE.

Except it's not working for me

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online

1 edit
reply to aryoba
said by aryoba:

This is one of the reason why no simulators beat the real thing

*sigh* I was hoping this would somewhat supplement. It's more difficult for me to schedule lab time at home than it is for me to keep reading the CCNA book on my commute to work/home.


Da Geek Kid

join:2003-10-11
::1
kudos:1
Reviews:
·Callcentric
reply to Network Guy
ok So you need to study up on your frame and here's a link below to help you out..

»www.cisco.com/en/US/tech/tk713/t···a7.shtml

obviously, neither of the R1 and R2 are frame switches so I am not sure why you have frame switching anyways... there's nothing wrong with configuring FRs on GNS3... I'll let you RTFM more...

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
I used "frame-relay switching" to enable that. I knew it would be the wrong config to do "frame-relay switching" on both routers, but with nothing else to configure on the simulated frame switch in the simulator, and not being able to change the serial interfaces to DTEs on both routers so I can use the simulated frame switch, I knew it wouldn't work anyway.

I've read up on frame switching, I know what it's supposed to do. I've made it work with the 1721s I have sitting at home back to back.

Soooo you said that you tested 1721s via WIC-1Ts in the simulator and it worked. Any insights as to how? I'm curious because I have the IOS for 1721s. The IOS that I use on the actual, physical 1721s via WIC-1Ts at home is the same IOS I'm using in the simulator.


Da Geek Kid

join:2003-10-11
::1
kudos:1
Reviews:
·Callcentric
reply to Network Guy
R1
 
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 point-to-point
 ip address 30.1.1.1 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 102
 

R2
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 point-to-point
 ip address 30.1.1.2 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 201
 

and:
R2#p 30.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/46/156 ms

R2#sh int s0.1
Serial0.1 is up, line protocol is up
Hardware is PowerQUICC Serial
Internet address is 30.1.1.2/30
MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY
Last clearing of "show interface" counters never
R2#sh int s0
Serial0 is up, line protocol is up
Hardware is PowerQUICC Serial
MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
LMI enq sent 30, LMI stat recvd 31, LMI upd recvd 0, DTE LMI up
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE segmentation inactive
Broadcast queue 0/64, broadcasts sent/dropped 7/0, interface broadcasts 0
Last input 00:00:01, output 00:00:01, output hang never
Last clearing of "show interface" counters 00:05:46
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
51 packets input, 3614 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
55 packets output, 3942 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Got it to work using subinterfaces.

Thanks for your help


Da Geek Kid

join:2003-10-11
::1
kudos:1
Reviews:
·Callcentric
you can use it without sub interfaces as well... use your intuitive techniques (i.e. debug command) to find out the line item missing in your config...

The purpose here is to learn not to tell ya how it's done... GNS3 just works. it has bugs and so does the IOS...

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Yeah, I seriously need to get into the habit of using the debug functions instead of googling possible working configs that might work. I still don't know what went wrong, but I'm gonna break it again like before and peruse through the messages.


NOCMan
MadMacHatter
Premium
join:2004-09-30
Colorado Springs, CO
reply to Network Guy
In defense of GNS3 it can save a lot of money on a CCIE level lab just by interfacing some hardware with some soft routers via a NIO and a actual switch.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
I'm starting to hate this simulator. It's as stable as the stock market. Grr

I'm gonna look up the recommended machine specs to use this, but I'm using an Intel Duo 2 GHz with 2 GB of RAM. It should be sufficient.


Da Geek Kid

join:2003-10-11
::1
kudos:1
Your machine does need to be beefy... I have a quad core with 8GB of RAM and can run 13-17 routers without a single issue for more than 5 days straight on a win7 64 bit... I do not see any problem with stability.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online
Ahh.. I suppose that's the problem then. I'm able to tame CPU utilization if I keep playing around with the Idle PC value. But the more stuff goes on; ie.. RIP, frame relay, the higher it goes. Sometimes the sessions just stop. I'll have to reboot and recreate the topology from scratch.

Time to invest in a new rig


Da Geek Kid

join:2003-10-11
::1
kudos:1
You can tweak it to just the way you like for the number of routers you have... Obviously, that's what I do to make sure the stability of system. I spent roughly 500USD for a board, CPU and RAM everything else was reused.

aryoba
Premium,MVM
join:2002-08-22
kudos:4
said by Da Geek Kid:

I spent roughly 500USD for a board, CPU and RAM everything else was reused.

As alternative, you can spend the same money amount to get real routers and switches to lab with


Da Geek Kid

join:2003-10-11
::1
kudos:1
Reviews:
·Callcentric
I'd like you to point me to those 7206vxr routers I am running on my PC. I run 13 7206vxr without any issue @ 1/13th of the power.

edit: well, I need to be fair. So yeah for 500USD I have 13 routers connected to a separate virtual Frame Switch. Now purchasing 13 routers with cables and a frame switch fro 500USD is a STEAL if you can find one, but the electricity and noise it makes is well, ...

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
reply to aryoba
Yeah. But they aren't as portable. And they're pretty much useless for anything else.

(If you happen to work for an ISP/Integrator/etc., you should have stacks of equipment at hand. I always did. I might still have a PA-2CT1 (15pin T1 interface) somewhere around here.)