dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2181
share rss forum feed

hamselv_78

join:2011-02-27
4880

1 edit

SMCGS8P-Smart


Main menu of switch
  
Click for full size
VLANs
Click for full size
RSTP
Hi there

I don't know if the following is achievable:

I have a fiber-to-home-gateway from packetfront.
Port1 = IP telephony
Port2-5 = IPTV
Port 6-8 = Internet

From where the packetfront is located, I have just one patch cable running up to attic where router, switches, and so on are located, and distributes it to the rest of the house. Running some more patch cables inside the wall is no option, as there is no room.

What I am trying to do is this:

Switch1 = SMCGS8P-Smart (located next to fiberbox)
Switch2 = SMCGS8P-Smart (located on the attic)

Fiberbox port1 -> switch1 port1 = VLAN5 (telephony)
Fiberbox port2 -> switch1 port2 = VLAN3 (IPTV)
Fiberbox port8 -> switch1 port3 = VLAN 4 (Internet)

switch1 port4 -> switch2 port1 = VLAN3+4+5 (using patch cable in the attic)

port1-3 accepts all packets, but tags incoming with the relevant VLAN ID.
port4 accepts tagged only

switch2 on the attic then uses different ports to seperate the VLANs again.

This setup works perfectly as long as I ONLY plug in either Internet, IPTV or telephony. Once I connect more than one cable to the fiberbox, the spanning tree option blocks them becuase it thinks I created a loop (the MAC address on the fiberbox is the same across all ports, but they all gives different IP's/subnets).

I have tried to disable RSTP protocol on the switch, but it does nothing.

Is there anything I can do?