dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2627
share rss forum feed

monsieurmac
Premium
join:2011-03-14
Canada

[Asterisk] Unable to connect to remote asterisk (does...)

downloadLog.txt 110,152 bytes
Log file for Asterisk
I'm unable to access the Asterisk GUI. I keep getting an error:

Unable to connect to remote asterisk (does /opt/var/run/asterisk/asterisk.ctl exist?)

This error appears on every menu item selected (other than the Settings page)

I have included a log file which shows the processes running, the result of using asterisk -r and the result of using asterisk -cvvv. I would be extremely grateful if someone could give me an idea of how to fix this. I also checked the asterisk.conf but did not see anything out of place although I suppose there's still a chance that it's not quite right?

Any other logs that might help troubleshoot this?


ekiM
Oh Well

join:2001-01-06
/usr/home
I saw your other post and then this so I see what you are trying to get to. I'd be interested in doing the same if you get this to work.

That said...

Does /opt/var/run/asterisk/asterisk.ctl exist?

If it does then check permissions on the file.
If not, does the file exist in a different directory?
- If that is the case I think you need to adjust the pathing in the asterisk.conf file.

--
"I can't sing, I ain't pretty and my legs are thin."

Jet101
Jet101
Premium
join:2009-10-01
Pflugerville, TX
reply to monsieurmac
Have you ever been able to access it? How did you install Asterisk. Did you use one of the popular distros, or compile and install it yourself. The error you are seeing is generally a sign that Asterisk is not starting automatically, however you should be able to access the GUI after running the asterisk -cvvv command.

If Asterisk is not running, entering Asterisk -r will give you the error you are seeing. Installing with a distro should set everything up to auto run Asterisk at startup. If you installed manually, it sounds like you might have missed the "make config" portion of the install. You should also check your etc/rc.local file and add something like "/etc/init.d/asterisk start" if it's not already in there. Just stabbing in the dark here.

monsieurmac
Premium
join:2011-03-14
Canada
reply to monsieurmac
Well, still trying different options and I have found one that worked.

1) Install Brainslayer's mega DD-WRT
»www.dd-wrt.com/site/support/other-downloads

-Select 'others' -> eko -> Brainslayer-V24-preSP2 -> 2011

I chose the latest build which was 03-17-11-r16454 but there are no guarantees that this is the most stable release. Choose your poison… latest build with potential bugs or most stable build with known issues.

2) Follow steps from Optware, the Right Way:
»www.dd-wrt.com/wiki/index.php/Op···ight_Way

As part of that process, they have you prepare a USB key with the instructions below: (the link is in Optware the Right Way so you don't really need this but I figured I'd add it separately)
»www.dd-wrt.com/wiki/index.php/Ho···e_Device

3) Start the xinetd service:
service xinetd on
service xinetd start

4) Start the Asterisk service:
service asterisk on
service asterisk start

From following the steps in Optware, the right way, I was able to get myself up and running.

Now, I just need to configure Asterisk with VOIP.MS and my PAP2T device.