dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2730
share rss forum feed

rascale
Premium
join:2010-01-20

How do you get Qwest to stop blocking port 25 repeatedly?

I provide email services for a few clients, one of whom uses qwest dsl. Recently, he was no longer able to send messages.
After spending several hours troubleshooting, I determined his access to port 25 had been blocked, without any reason or notice.

Qwest restored port 25 access only after I did the research, gave him the contact info and the "magic words" (port 25 blocked)
His first call to tech support denied there was any problems with his connection.

Now a few weeks later, his email stopped working again!

It took less time to determine that qwest had reinstated the port 25 block, without any notice.
Once again he had to endure telephone support to get his service restored. This is getting to be quite a hassle.

We have no confidence his access will continue, or be reliable.
This is costing me and my client time and money.

How can we get his access permanently enabled? Are there some secret "magic words" to tell qwest support to stop reactivating his port 25 block?

Qwest is doing a very poor job communicating and I cannot recommend using qwest dsl services to any of my clients.



adsldude
Premium,Ex-Mod 2003-9
join:2000-11-10
Colorado
kudos:1

Have you considered offering your client an alternate port? Most MTAs support multiple ports.


TheMayor

join:2002-05-09
reply to rascale

Have you looked at the setup instructions Q has on their website? I believe Q doesn't use port 25 for outgoing/incoming email.



chpalmer

join:2002-11-18
Belfair, WA

I ended up changing ISP's due to this.

You can always use a telnet :25 command to verify when it happens but it became to much of a time issue with me.



msj
Premium
join:2004-05-21
Fort Collins, CO
kudos:1

You might consider having the client get a single static IP address. Then you get access to a control panel that lets you set the option for port 25 filtering. I have a static IP and have not had any issues with port 25 being blocked either inbound or outbound (I run postfix for my personal domain).


colorbars

join:2003-03-20
USA
reply to rascale

ADSLDude is correct. Any reasonable SMTP server that is designed as a relay server from customers will allow alternate ports. That's because blocking of the standard port 25 port is the proper thing to do these days due to the threat of spam and malware. Yes, your customer might be able to get an exception but then if something gets into his machine it will be able to connect to any publicly facing SMTP server in the world. That opens up the potential for a world of hurt.

There's another concern as well. Publicly facing servers absolutely must be properly set up and maintained by someone who knows how. If they aren't, they become very dangerous. (Sometimes they're dangerous even when run by people who know what they're doing, but the risk is far greater when they don't.) Things like this are Security 101.


nonymous
Premium
join:2003-09-08
Glendale, AZ
reply to rascale

Change ports or go to a secure port.



helloworld

@midco.net
reply to rascale

Qwest, by default blocks port 25. There are also a couple other they block as well. If you really need any of those ports open, call tech support and they can simply open them for you. But, there is a reason they block those by default.


CappinHoff

join:2007-01-05
Des Moines, IA
Reviews:
·Mediacom

said by helloworld :

. But, there is a reason they block those by default.

That is because they don't want people to run an email server/service from there home service. Exactly what the OP is doing. Most ISP block this on residential accounts. Or of they don't and find out your are doing it will block it. Pretty understandable.


Boss302_1970

join:2009-12-11

said by CappinHoff:

said by helloworld :

. But, there is a reason they block those by default.

That is because they don't want people to run an email server/service from there home service. Exactly what the OP is doing. Most ISP block this on residential accounts. Or of they don't and find out your are doing it will block it. Pretty understandable.

Yes if they see you are , theyll usually block it in a small amount of time. Had a couple of friends have the same issue as the op.

CappinHoff

join:2007-01-05
Des Moines, IA
Reviews:
·Mediacom

said by Boss302_1970:

said by CappinHoff:

said by helloworld :

. But, there is a reason they block those by default.

That is because they don't want people to run an email server/service from there home service. Exactly what the OP is doing. Most ISP block this on residential accounts. Or of they don't and find out your are doing it will block it. Pretty understandable.

Yes if they see you are , theyll usually block it in a small amount of time. Had a couple of friends have the same issue as the op.

I did as well.

treasureman

join:2002-08-09
Port Orange, FL
reply to rascale

Why not offer SMTP service on an additional port as well as port 25 on your server? That's what I do. Many ISP's block port 25 due to spam, it's not just Qwest.


mylesw1

join:2009-06-11
reply to rascale

Yep, this is common (about 80% of all providers, particularly those with 'residential' plans for Internet block port 25). Since more block than those that do not, the best way is to:

a. Upgrade to a business level plan that doesn't block this port,
b. Find an alternative port that isn't blocked and use that.
c. Use the ISPs mail server for outgoing mail, but adjust your DNS settings for your domain to nominate that server as one of your MX records.

If you Google this subject, you'll find a wealth of resources on it. There are also websites that will test the blocking for you. Many ISPs use port 587 (I think that's it - going off memory here) as an alternative. The only assumption is that your mail client can send SMTP out through an alternative port.

Personally I think the whole thing is ISPs being scared of what was common back in 2001, and spammers have moved onto better techniques now anyways. But this 'cold war' legacy lives on and you just have to deal with it.

Myles