dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
13615
share rss forum feed

fronquillo

join:2011-06-15

DIR-655, Hw Version B1

Hi!

I have a router DIR-655 hardware version B1 with firmware version 2.01NA, can anyone knows how to change it to 2.01WW version??

I have a big problem with this router, i configured it to work in the 20/40 Mhz channel width in auto. It starts to work fine in the 40Mhz width (connection speed is 270 to 300Mbps) but after 4 or 5 minutes it switches to the 20 Mhz width (connection speed is maximum 130 Mbps).....the problem is that the router never switches back to the 40 Mhz channel width!!!

There is no other wireless networks in the area, so i´m sure there is no interference (i´m monitoring the spectrum with the inSSIDer software with another laptop).

The same scenario is tested with a DIR-655, hardware version A4, and that router switches excellent between the 20 and 40 Mhz channel width.

Does anyone have some patch? some beta firmware?

Thanks in advance.

Fidel


Airwolf
Premium
join:2001-10-30
Windsor, ON
Are you sure there's no other networks in the area. Their SSID could be hidden.

Also, there could be other devices causing interference.

fronquillo

join:2011-06-15
Thanks for your answer, but i´m sure there is no other wireless networks.

In fact i made the test with a DIR-655 Hardware version A4, and everything is OK, the router switches between 20 and 40 Mhz channel width.

When i change the router to a DIR-655 hardware version B1 and with an exactly the same configuration, the B1 starts workin in the 40 Mhz, but after 5 minutes switches to 20Mhz channel width and never comes back!!

I´m desperate because my client have about 150 units of this DIR-655 B1, imagine how is he!!!

thanks and hope somebody have any solution!!!

Fidel

bigpapae35

join:2002-10-25
united state
kudos:1
reply to fronquillo
you cant switch your device to a different region, but why don't you try the 2.00na shipping firmware instead.

What kind of chipset is in the rev b1?


shwatkin
Premium
join:2007-10-02
Bowmanville, ON
Reviews:
·Distributel Cable

1 recommendation

reply to fronquillo
I have the same issues with my B1 DIR-655. Starts on 40MHz and then some time later switches to 20MHz and stays there. A3 or A4 revisions never experienced this same behavior. Most people claim there is no issue and while that may be true the way the software on the B(x) revisions behaves is certainly different from the A(x) revisions. Best I can figure is that the good neighbour policy is very sensitive on this software release. All we can hope for is an updated firmware that dials down the good neighbour policy to levels in line with the A series routers. If it wasn't for the lack of IPv6 support on the A series I would have ditched this B1 router after the first week. Are you listening D-Link? Either give us IPv6 on the A series or fix the B series software.

fronquillo

join:2011-06-15
I agree with you. The good neighboor policy is very, very, veryyyyyy sensitive. I´m using the inssider software to monitor the wireless networks around my lab, the dir-655 wireless network is alone in the spectrum, but when i turn on another wireless router working in a channel near the one used by the dir-655............. immediately the dir-655 switches from 40 to 20 Mhz and never comes back.

I did a second test, with the same scenario, but with a DIR-655 Hw A4 instead of the DIR-655 B1. everything works excellent, with the switching between 40 and 20 Mhz Channel width constantly.

I did a third test, with the same scenario, but with a DIR-600 instead of the DIR-655 HwB1, and everything works excellent, with the switching between 40 and 20 Mhz Channel width working very good.

So the problem is the HwB1, D-Link!!!!!!!! please listen us and fix this.......................if i don´t find a solution to this problem, i´m going t lose a 500 pieces project........including the bad image of the brand "D-Link" with my client.............

Regards

bigpapae35

join:2002-10-25
united state
kudos:1
Reviews:
·Callcentric
d-link might issue a fix, but you have to call tech support get transferred ten times before you get a tier 1 or 2 tech that can issue a real support ticket, and from there it will take a month to write new code, test it and do quality assurance, and then another month of beta testing. So this is not goint to be a quick fix for you.

D-link does not have a great reputation in the IT industry for these type of consumer products, you should have stuck with their enterprise AP's for these type of projects.

Try detailing this issue in d-link own support forum which gets checked more routinely than this one.

Two be honest even the good neighbor policy in the latest firmware of rev Ax is still too sensitive for me, I prefer the bad neighbor policy of 1.11 firmware from pre-2009.

fronquillo

join:2011-06-15
Hi, i have a new customized firmware version for DIR-655 B1, i ocntact HQ in taiwan and they send me some instructions. It works excellent always in 40Mhz!!!!!! Do you want the firmware?? Please send me you email and i´ll send it to you!!

Regards!!


shwatkin
Premium
join:2007-10-02
Bowmanville, ON
Reviews:
·Distributel Cable

1 recommendation

So, I tried the 2.02AX firmware that fronquillo supplied and the 40MHz mode works like a charm but, and this is a big but, it breaks IPv6. IPv6 is was also broken in the 2.03NA firmware, see my post on it here...

forums.dlink.com

So I'm afraid its back to 2.01NA. IPv6 support is more important to me than 40MHz mode. Why oh why can't D-Link get the firmware for this router right. Here's looking forward to another release that has both of these features working and then we have a winner.


slpip3

join:2007-02-20
Springfield, VA

1 edit
reply to fronquillo
Have you tried the new firmware 2.03NA yet?
Use 2.01NA for IPv6 support.

gr678537

join:2011-08-11
Avon Lake, OH
reply to shwatkin
said by shwatkin:

So, I tried the 2.02AX firmware that fronquillo supplied and the 40MHz mode works like a charm but, and this is a big but, it breaks IPv6.

Does anyone have this firmware?? I have emailed fronquillo but have received no response. I cannot keep my router in 40 mhz mode for more than a couple minutes.


kkumul

@bell.ca
reply to fronquillo
I have same problem with A4 (firmware 1.35).

but A4 firmware has 3 options like...
20, 40, auto(20/40)
so when I choose "40" It's OK

If I choose "auto(20/40)" same problem like B1.

but.. if I use "Enable Auto Channel Scan" option.
It works fine. even with "auto(20/40)"

I don't know why.

I also e-mail to Dlink support about this..
but..looks like they don't understand about this problem.