dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
4155
share rss forum feed


bayrossnet

@rogers.com

1 edit

[Config] URGENT - Configuring SIP to FXS

I have a 2811 router with VIC2-FXS port, 2 - 48 CH DSP Modules. I am trying to configure the the router so when people dial my DID it will ring the analog phone connected to 0/3/0

Outgoing calls are fine through my SIP provider.

Everytime I dial the DID # I get a busy signal. I have the DIDWW service pointing to the external IP of the router.

Any help will be appreciated. I can even provide remote access to the router if needed. EMAIL: garrett@bayross.net

Thanks.

---- SH VER OUTPUT -----

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 15.1(4)M, RELE
ASE SOFTWARE (fc1)
Technical Support: »www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 24-Mar-11 14:26 by prod_rel_team

ROM: System Bootstrap, Version 12.4(1r) [hqluong 1r], RELEASE SOFTWARE (fc1)

BNET01C2811-TOR1807 uptime is 13 hours, 22 minutes
System returned to ROM by power-on
System restarted at 18:08:58 NewYork Thu Jun 16 2011
System image file is "flash:c2800nm-advipservicesk9-mz.151-4.M.bin"
Last reload type: Normal Reload

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
»www.cisco.com/wwl/export/crypto/···qrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2811 (revision 1.0) with 247808K/14336K bytes of memory.
Processor board ID FHK1041F27M
6 FastEthernet interfaces
1 Channelized (E1 or T1)/PRI port
1 Virtual Private Network (VPN) Module
4 Voice FXO interfaces
2 Voice FXS interfaces
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
125440K bytes of ATA CompactFlash (Read/Write)

---- SH RUN ----

Building configuration...

Current configuration : 3803 bytes
!
! Last configuration change at 07:24:03 NewYork Fri Jun 17 2011
! NVRAM config last updated at 07:24:05 NewYork Fri Jun 17 2011
! NVRAM config last updated at 07:24:05 NewYork Fri Jun 17 2011
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BNET01C2811-TOR1807
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
no logging buffered
enable secret 5 *************************************
!
no aaa new-model
!
clock timezone NewYork -5 0
clock summer-time NewYork date Apr 6 2003 2:00 Oct 26 2003 2:00
!
dot11 syslog
ip source-route
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.15.0.0 10.15.0.20
!
ip dhcp pool TOR-1807WEBB
network 10.15.0.0 255.255.255.0
default-router 10.15.0.15
dns-server 64.71.255.198
!
!
!
ip name-server 64.71.255.198
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
!
!
voice-card 0
dsp services dspfarm
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn ************
username user1 privilege 15 secret 5 ***************
username user2 privilege 15 secret 5 ***************
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.15.0.15 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex full
speed auto
no mop enabled
!
interface FastEthernet0/1
description $ETH-WAN$
ip address dhcp client-id FastEthernet0/1
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/2/0
no ip address
shutdown
!
interface FastEthernet0/2/1
no ip address
shutdown
!
interface FastEthernet0/2/2
no ip address
shutdown
!
interface FastEthernet0/2/3
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:
!
!
ip nat inside source list 1 interface FastEthernet0/1 overload
!
logging esm config
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.15.0.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
mgcp profile default
!
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 20
shutdown
!
dial-peer voice 1 pots
destination-pattern 16472584731
port 0/3/0
forward-digits 0
!
dial-peer voice 102 voip
session protocol sipv2
session transport udp
incoming called-number 16472584731
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2 voip
destination-pattern T
session protocol sipv2
session target dns:sip.voipdiscount.com
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 202 pots
destination-pattern 1000
port 0/3/0
!
!
gateway
timer receive-rtp 1200
!
sip-ua
authentication username username password 7 ****************** realm sip.
voipdiscount.com
retry invite 3
retry register 10
registrar dns:sip.voipdiscount.com expires 3600
sip-server dns:sip.voipdiscount.com
!
!
!
telephony-service
sdspfarm units 1
sdspfarm transcode sessions 5
max-ephones 20
max-dn 100
ip source-address 10.15.0.15 port 2000
max-conferences 8 gain -6
transfer-system full-consult
!
!
banner login ^CBayross Network^C
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password **********
login
transport input all
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 128.100.100.128 prefer source FastEthernet0/1
end


rolande
Certifiable
Premium,Mod
join:2002-05-24
Dallas, TX
kudos:6
Reviews:
·AT&T U-Verse
·ViaTalk
I am digging back a few years in my memory. I am pretty sure there is an order of operations issue when the SIP call comes in and the router is unable to tie the call to the local FXS port. I struggled with this same issue when trying to ring both FXS and VoIP extensions running Skinny. I ended up having to get an ATA adapter running SIP and hang my POTS devices off the FXS ports on the ATA so that I could ring both simultaneously.

If you are ONLY trying to tie the incoming SIP call to the FXS port, then my issue may be completely irrelevant. It is possible that you are not actually getting the DID string from the SIP provider and that is why you aren't getting a match on the dial-peer. I found I had to fake it out with my local FXS port because I was using FXO for my DID. I ended up using a translation rule to take the nulll DID field and set it to an arbitrary value that matched the port I wanted to ring. You also have to remember to flag the dial-peer as 'direct-inward-dial' to force the DID match to occur.

You can read my notes here:
»rolande.wordpress.com/2007/12/09···ess-4-0/

Scroll down to the section Incoming Calls - DID.
--
Scott, CCIE #14618 Routing & Switching
»rolande.wordpress.com/


bayrossnet

@rogers.com
I am just looking to get the SIP to FXS port. I've been trying to days with no success.
Do you want to get access to the router?
email me: garrett@bayross.net


rolande
Certifiable
Premium,Mod
join:2002-05-24
Dallas, TX
kudos:6
Reviews:
·AT&T U-Verse
·ViaTalk
The right way to do DNIS matching is to use 'incoming called-number' instead of 'destination-pattern' on the dial-peer. You also have to set 'direct-inward-dial' on the dial-peer. However, I did read a caveat that incoming calls on voice ports must match POTS dial peers and incoming calls from the network must match against VOIP dial peers. So, not sure how that plays into this.

You need to debug the incoming call on the router to see what, if any, DNIS information is being sent. The preceding "1" may not be included if they are even sending a DNIS string at all. You can use the 'debug ccsip' family of commands. Remember to enable 'term mon' so you can see the debug output on your router terminal session. 'debug ccsip messages' is probably a good starting point.
--
Scott, CCIE #14618 Routing & Switching
»rolande.wordpress.com/

ladino

join:2001-02-24
USA
kudos:1
reply to bayrossnet
The key thing is knowing what digits your SIP provider is sending to you, Rolande already pointed this out. Since we do not know at this stage, you could use a translation profile. I was able to do a test call & make my fax ring using the following configs.

!
voice translation-rule 8
 rule 1 // /16472584731/
!
!         
voice translation-profile FXO
 translate called 8
! 
!
dial-peer voice 1 pots
 destination-pattern 16472584731
 port 0/3/0
 forward-digits all
!
!
dial-peer voice 102 voip
 translation-profile incoming FXO
 session protocol sipv2
 session target sip-server
 incoming called-number .
 dtmf-relay rtp-nte
 codec g711ulaw
!
!
 


battleop

join:2005-09-28
00000
reply to bayrossnet
Do you have the option of registering a SIP account for the DID you are trying to setup? If you can here is a config from an IAD2431-16FXS.

dial-peer voice 1 voip
destination-pattern .T
voice-class codec 1
session protocol sipv2
session target sip-server
session transport udp
dtmf-relay rtp-nte
fax protocol pass-through g711ulaw
!
dial-peer voice 5551234 pots
destination-pattern 4045551234
port 2/0
authentication username 4045551234 password 101E5d3scDDw7
!
gateway
timer receive-rtp 1200
!
sip-ua
retry invite 4
retry response 3
retry bye 2
retry cancel 2
registrar dns:pbx.city.domain.com expires 300
sip-server dns:pbx.city.domain.com