dslreports logo
    All Forums Hot Topics Gallery


Search Topic:
share rss forum feed

John Mc
Monkton, VT

1 edit

[trouble] Fairpoint DSL: no outgoing email

My fairpoint DSL was hooked up a few weeks ago. It's only partially working. I can't send outgoing email via Thunderbird, or any other email client. (Fairpoint's web mail does work, but I can't stand the interface).

If I click send on an email, after a long wait I get:
An error occurred while sending mail. The mail server responded: 4.4.1 collect: read timeout on connection from d-burl-bng1-64-222-152-238.ngn.east.myfairpoint.net, from=(myusername@myfairpoint.net). Please check the message and try again.

Occasionally, I can get a very short email to go through. Incoming mail via Fairpoint's POP server works fine.

I'm usually hooked up to a bridged router, which is connected to FP's Westell 6100 modem, but I get the same problem when plugged directly into the DSL modem.

Now for the strange part: I still have my account with Wildblue, my old satellite internet provider. When connected to Fairpoint DSL, I can send outgoing mail through Wildblue's SMTP server, using my old Wildblue email address, but not Fairpoint's SMTP server with my new Fairpoint address. If I hook back up to Wildblue's satellite modem (I still have the satellite service, until this problem gets resolved), I can send through either Fairpoint's or Wildblue's internet server.

If I hook up to a neighbor's Fairpoint DSL service, my outgoing mail works fine, with no changes made to my computer. Same thing when hooked up to a local cafe's wifi. This would seem to indicate that the problem is not in my computer or settings. Running a Mac Powerbook, OS 10.5.8. Latest versions of Thunderbird (and get same results with latest version of Apple's Mail program).

If i try via my son's PC (Windows 7) everything works fine, which would seem to indicate the problem is in my PC -- contrary to the tests mentioned above

Possible related problem: A lot of sites I can browse to with no problem, and downloads usually work fine. Some sites just lock up, or go to a blank page and hang there (my online banking and credit card, paypal, or trying to register and post to some forums). In fact, I could not register for this forum for quite some time. Turning Firefox's preferences setting "Block known attack sites" to OFF seems to have helped me get on here and post on another forum... unless that's just a coincidence. It did not help my logging in to banking and CC sites.

Sorry for the lengthy post... and thanks for any help you can provide. MANY hours with Fairpoint tech support have not helped (I've probably double checked the server settings and reset the modem a dozen times).

John Mc

John Mc
Monkton, VT

It looks as though unchecking "block known attack sites" in Firefox's preferences didn't really help anything. I was able to get to a few (but not all) of the sites that we're not working for a while, but then it stopped working again. I'm borrowing my son's PC to post this, since my Mac can look at posts here, but not post a reply.

Still have the same problems with outgoing mail. Still works fine when I plug my Mac into a neighbor's Fairpoint system a couple miles down the road. Will not work on my next door neighbor's Fairpoint hookup.

A second Mac computer in my home has the same problems.

Does anyone know if Fairpoints systems have problems with Macs?

Can anyone think of settings other than the basics that I should poke around with? (My Mac OS X built-in firewall is set to allow all incoming traffic. There does not seem to be any settings for outgoing, and "parental controls" are turned off.)

Help! this is getting frustrating, and my 30 day "no penalty for early cancellation" runs out in a little over a week (not that cancelling is a good option... I need better speed than I had with the satellite connection).

John Mc
Monkton, VT
reply to John Mc
duplicate post

Nashua, NH
reply to John Mc
It would be interesting to know what IP address your Mac (more likely, your DSL modem/router) is being assigned, and compare that with the IP addresses of the two neighbors. Perhaps you're getting an address in a block that was previously unused by FairPoint and their internal servers aren't aware of the new block.

One thing that might help is to turn on authentication for your outgoing mail to FairPoint's server. I have absolutely no idea how to set that up on a Mac or Thunderbird, but it's mostly a matter of finding where in your e-mail settings you can specify a user ID and password for the SMTP server. (I've found that if I don't turn on outgoing authentication FairPoint's mail server is unhappy when I explicitly set my "reply to" e-mail address to something other than @myfairpoint.net.)


Milford, NH
·FirstLight Fiber
·Hollis Hosting
·G4 Communications
reply to John Mc
Though I had already responded. Can't seem to find the post.

Since short messages seem to work and you are having trouble connecting to SSL/TLS sites my guest is the root cause is packet size.

Normal packets have a maximum length of 1500 bytes. Verizon and most DSL providers use PPPoE. PPPoE is an encapsulation protocol. It needs 8 of the 1500 bytes thus limiting maximum packet length (MTU) to 1492 bytes.

Normally all this happens automatically. I'm not that familiar with Apple products the devices at each end discover the optimum setting. If an overly large packet is sent it gets fragmented into two parts. Routers are supposed to deal with this situation but often do not. The end result is you cannot send.


John Mc
Monkton, VT
Two visits from a tech who came by when I was not here resulted in them saying everything was fine, the problem was in my computer. (Hard to imagine when my computer works fine when plugged into one of their systems down the road a couple miles.)

I met the tech out here today. He found one problem in their hardware (had to switch ports at the box where the fiber optic ends and the DSL starts), and another problem in one of their settings in the software. Np changes at all required in my computer.

I had wondered about MTU settings myself, not that I know much about it, but it turns out, my settings were OK.


Keene, NH
reply to John Mc
said by John Mc:

I'm usually hooked up to a bridged router, which is connected to FP's Westell 6100 modem

This is making me think MTU, try manually setting the MTU in your bridged router to 1492. If it doesn't fix it, you can always set it back. I've seen this issue with some Netgear, and some Linksys models where it doesn't figure out the MTU properly when connected via PPPoE DSL, this may also apply to other brands/models of router as well. Worst case is you can reverse it to set it back the way it was if it doesn't fix the issue.