dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
5756
share rss forum feed


HiVolt
Premium
join:2000-12-28
Toronto, ON
kudos:21
Reviews:
·TekSavvy DSL
·TekSavvy Cable

[VoIP] Freephoneline.ca port forwarding

I'm trying to remotely help a friend to set up their freephoneline.ca VoIP adapter on their Rogers cable service. Right now they can call out, but nobody can call in. The instruction sheet that comes with it says that the following ports must be fowarded.

UDP 5060-5061
UDP 10000-20000

So I have forwarded the first range of 5060-5061, but I cannot add the second range because the Rogers provided SMC-8014WG modem/router can only port forward a total of 5000 ports combined, so I cannot forward the silly 10000-20000 port range to the voip ATA's local LAN IP.

My question is, has anyone actually figured out if this insane 10000-20000 port range is necessary, or is it a smaller set of ports that can work?

The VoIP ATA is Grandstream HT-286.

Thanks
--
GO LEAFS GO!


zorxd

join:2010-02-05
Quebec, QC

Port forwarding shouldn't be required. However the ATA must know that it's running behind a NAT

On sipura/linksys/cisco ATAs there are settings such as NAT keep alive and NAT port mapping



HiVolt
Premium
join:2000-12-28
Toronto, ON
kudos:21

This is some pre-configured thing. There is a password when you try to access it's web interface.
--
GO LEAFS GO!



tatty

join:2002-02-23
North York, ON
reply to HiVolt

I think those port ranges are only for their software. You should check their forums »forum.freephoneline.ca/ for the password or the proper port range.



Ott_Cable

@teksavvy.com
reply to HiVolt

zorxd is correct! Whoever that tells you port forwarding is required has no understanding on how it works. »en.wikipedia.org/wiki/Session_In···Protocol

Your router is the one that initiates the registration to the VoIP server (freephoneline.ca) which already opened the return ports on the firewall, thus port forwarding is not required. Incoming calls are replies from the server in form of "INVITE".

You'll have to make sure that the registration is okay and NAT setting on both the server (freephoneline.ca) and the ATA box has to know it is sitting on NAT.



LazMan
Premium
join:2003-03-26
canada
reply to HiVolt

Can't help with that ATA, but I just setup a SPA-3102 on FPL and Rogers Cable about 2 weeks ago... I didn't have to do any manual port forwarding. Worked like a charm.

First off, have you confirmed it's with the ATA only, and that calls in and out work with the softphone app?

The FPL forums are actually pretty helpful - lots of config examples and other "tips and tricks"



Davesnothere
No-BHELL-ity DOES have its Advantages
Premium
join:2009-06-15
START Today!
kudos:7

3 edits
reply to HiVolt

.
I too have wondered about that very same point, though never have asked, as the VoIP providers which I have recently begun to use do not require me to FWD that range (or ANY range, for that matter), though some others apparently DO.

I have been testing Callcentric and CallWithUs on a Linksys PAP2T-NA ATA box, and they JUST WORK.

These VoIPPs seem to use alternate methods for the ATA to maintain communication (registration) with their servers.

But IMNSHO, you will get more experienced answers about VoIP in general, if you were to post here :

»VOIP Tech Chat

I certainly have learned a lot in a short time from the regulars over there.

(and of course by searching that forum, as many topics have already been covered in the past)

I do not have experience with other ATAs, but some other folks over there do.

Also the DSLR VoIPP reviews often contain worthwhile tips & config info.

Here : »/gbu



FPL232

@nexicom.net
reply to Ott_Cable

or 'ring before voice mail' problem like this guy having

quote:
HI,

Problem solved after calling to a freephoneline tech support, he is really good and knew what I was talking about, It turns out that in their system the 'ring before voice mail' was set to 1/0, while in my account on the web page, it displayed '3' by default, I have to click the update button to make it become a real 3 into their system. I think its a bug in freephoneline.

Thanks for the helps.

William
»forum.freephoneline.ca/viewtopic···8&t=3024


Michael9009

join:2006-07-28
Toronto, ON
reply to HiVolt

said by HiVolt:

I'm trying to remotely help a friend to set up their freephoneline.ca VoIP adapter on their Rogers cable service. Right now they can call out, but nobody can call in. The instruction sheet that comes with it says that the following ports must be fowarded.

UDP 5060-5061
UDP 10000-20000

So I have forwarded the first range of 5060-5061, but I cannot add the second range because the Rogers provided SMC-8014WG modem/router can only port forward a total of 5000 ports combined, so I cannot forward the silly 10000-20000 port range to the voip ATA's local LAN IP.

My question is, has anyone actually figured out if this insane 10000-20000 port range is necessary, or is it a smaller set of ports that can work?

The VoIP ATA is Grandstream HT-286.

Thanks

HiVolt, I have two accounts with FPL and I use a Linksys SPA2102 ATA on ADSL/VDSL. I never had to do any port forwarding and the system just works. Not sure what could happen in your case.


ekster
Hi there
Premium
join:2010-07-16
Lachine, QC
kudos:3
reply to HiVolt

Those ports only need forwarding for the softphone.

I use an ATA and it works fine as is.


zorxd

join:2010-02-05
Quebec, QC

Even on a softphone you shouldn't need port forwarding.

I used many SIP softphones behind a NAT without any problem.



HiVolt
Premium
join:2000-12-28
Toronto, ON
kudos:21
Reviews:
·TekSavvy DSL
·TekSavvy Cable

I was trying to help my friend over remote desktop, I had no physical access to the device. I've worked with Linksys ATA's, but not with this Grandstream branded ATA...

From what my friend was reading to me from an instruction sheet provider, it said specifically to forward those ports to the VoIP ATA's LAN IP.

I told my friend to call back if she needs more help.
--
GO LEAFS GO!


zorxd

join:2010-02-05
Quebec, QC
Reviews:
·Acanac

Well the one who wrote the instruction didn't know what he is talking about. Port forwarding should only be required if you want to receive direct IP calls not from your SIP server (freephoneline in that case). Most users don't need this. I would even say that most users don't want this since you can receive spam this way (although unlikely)

I checked the voip.ms configuration guide and there is nothing about port forwarding
»wiki.voip.ms/article/Devices



Ott_Cable

@teksavvy.com

When done correctly, really only servers needs to use port forwarding to allow in packets from clients. It is not like you are the VoIP provider or anything that requires someone's client to initiate services from your ATA.

This ass backward scheme with the port forwarding is there presumably that the person has no clue how to configure the NAT support correctly and relies on the forwarding itself to push the return packets from the server to the client.

Randomly exposing ports behind a firewall is asking for trouble from a security point of view.

Most softphones would at least be smart about NAT transversal or use a STUN server to figure out the WAN address.



Davesnothere
No-BHELL-ity DOES have its Advantages
Premium
join:2009-06-15
START Today!
kudos:7
reply to zorxd

said by zorxd:

Even on a softphone you shouldn't need port forwarding.

I used many SIP softphones behind a NAT without any problem.

.
Also, I still have Skype in one PC, and it never required any special router settings, IIRC.