dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
18099
share rss forum feed

john51

join:2010-02-27

[Config] Cisco 1921 and HWIC-1VDSL

Hi, I remember seeing some old posts about this, and I am hoping to configure the router to run my BT Infinity service.
I am brand new to Cisco, but have managed to configure the router to work with the supplied VDSL2 modem, using a forum members config..
I have sync/ Showtime on the VDSL2 card, (sh controller vdsl 0/0/0) so this is to let others know that the combination should work.
A "newbe" question, does the interface for router to office network still need to be configured as VLAN, as it has to be to work with the supplied modem.
I would like to try to solve this issue myself, but an answer to the above question would help.
Thanks.

HELLFIRE
Premium
join:2009-11-25
kudos:18
quote:
does the interface for router to office network still need to be configured as VLAN, as it has to be to work with the supplied modem.
I'm guessing you're trying to do a VPN tunnel between your 1921 and the office? If so,
then generally no, VLANs have NOTHING to do with VPN.

May help to explain what you're trying to do, and provide a copy of your current config
for review.

Regards

john51

join:2010-02-27
Thanks, Hellfire.
What i'm trying to do is replace the service provider's router and notoriously unreliable VDSL modem with a Cisco 1921 and HWIC-1VDSL card. The router will then connect to my Gig Switch and small office setup.
This is purely for non-professional use, and I have taken this route because I like to challenge myself, and like to learn new skills.
Here is the config, I know it is a mess, I have cut and added things from the original config which worked with the IP's modem.
!
no aaa new-model
!
!
!
!
no ipv6 cef
ip source-route
ip cef
!
!
ip multicast-routing
ip dhcp excluded-address 192.168.1.100
!
ip dhcp pool Admin
network 192.168.1.0 255.255.255.0
!
!
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
!
!
!
license udi pid CISCO1921/K9 sn FCZ1432C6XG
!
!
username Cisco1 privilege 15 secret 5 $1$Bmbx$30W2Yv50MDA.BWHTNboYG0
!
redundancy
!
!
controller VDSL 0/0/0
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
no mop enabled
!
!
interface GigabitEthernet0/0.1 *This interface used with the service provider's modem*

encapsulation dot1Q 1 native
ip address 192.168.1.100 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1350
!
interface GigabitEthernet0/1
description WAN-INTERFACE
ip address dhcp
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
no routing dynamic
!
interface Ethernet0/0/0 *Not sure about this*
ip address 192.168.2.200 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
pppoe enable group global
pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address negotiated
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname bthomehub@btbroadband.com
ppp chap password 0 1234
ppp pap sent-username bthomehub@btbroadband.com password 0 1234
ppp ipcp dns request
no cdp enable
!
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 217.32.142.104
!
access-list 1 permit any
!
!
!
!
!
!
control-plane
!
!
!

The output from the IP's supplied modem demanded a router configured for PPPOE, in my ignorance, I thought that was what VPDN was about. I now know it's about VPN dial-up.
Here's the controller log:

Cisco1#sh controller vdsl 0/0/0
Controller VDSL 0/0/0 is UP

Daemon Status: Up

XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0xA1B7
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0xA1B7
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: FOC151311CY 1921/K9 15.0(1)M
Serial Number Far:
Modem Version Near: 15.0(1)M
Modem Version Far: 0xa1b7

Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2)
TC Mode: PTM
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
Line Attenuation: 0.0 dB 0.0 dB
Signal Attenuation: 0.0 dB 0.0 dB
Noise Margin: 24.6 dB 23.4 dB
Attainable Rate: 113112 kbits/s 32643 kbits/s
Actual Power: 12.3 dBm -12.9 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 1.9 4.7 12.2 0.1 5.2 7.3 N/A
Signal Attenuation(dB): 1.9 4.7 12.2 0.0 N/A 6.3 N/A
Noise Margin(dB): 24.6 24.6 24.4 24.3 N/A 23.4 N/A
Total FECS: 0 0
Total ES: 0 0
Total SES: 0 0
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0

Full inits: 0
Failed full inits: 0
Short inits: 0
Failed short inits: 0

Firmware Source File Name (version)
-------- ------ -------------------
VDSL embedded VDSL_LINUX_DEV_01212008 (1)

Modem FW Version: 090929_1033-4.02L.01.AvC011b.d21j1
Modem PHY Version: AvC011b.d21j1

DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 39998 0 10000
Reed-Solomon EC: 0 0 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0 0 0 0
Actual INP: 0 0 0 0

Training Log : Stopped
Training Log Filename : flash:vdsllog.bin

Many thanks, John.

HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to john51
Can you also provide a "show inventory" from the router?

Which interface are you planning for your LAN interface, just out of curiousity?
From the looks of it, Gi0/0 was to form a trunk to your LAN interface, with
a subint on Gi0/0.1, Gi0/1 was to be the WAN interface, and I'm not sure where
eth0/0/0 came from, unless you have a ethernet WIC card present.

Right now I'm guessing Dialer1 is the interface you're going to use for your
BT service?

Regards

john51

join:2010-02-27

2 edits
reply to john51
Thanks.
Here is the sh inventory:
NAME: "CISCO1921/K9 chassis", DESCR: "CISCO1921/K9 chassis"
PID: CISCO1921/K9 , VID: V01 , SN: FCZ1432C6XG

NAME: "VDSL over POTS supporting VDSL2 on Slot 0 SubSlot 0", DESCR: "VDSL over POTS supporting VDSL2"
PID: HWIC-1VDSL , VID: V01 , SN: FOC151311CY

I'm not sure where ethernet0/0/0 came from, I think it appeared on installation of the HWIC-1VDSL module, which I configured with the basic configuration in the module's
manual, although I have since taken some out, pim, etc.
I had set up only the sub-interface 0/0.1 as the lan interface, and it worked correctly with the dialler as shown on the BT infinity service, which I would use for the module if possible.
This was the set-up using the supplied external vdsl modem, and WAN interface gi0/1.
I know it is running before I can walk, but what I hoped to do was use either the VDSL module or the WAN interface,
but it's not necessary, I would prefer to use the VDSL module now I have bought it!
Gi0/0 was indeed going to be the LAN interface, but the config I copied specified a sub interface, I thought that was necessary to get the PPPOE to work.
Here's the int brief as well:
isco1#sh ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES NVRAM down down
GigabitEthernet0/0.1 192.168.1.100 YES NVRAM down down
GigabitEthernet0/1 unassigned YES NVRAM down down
Ethernet0/0/0 192.168.2.200 YES NVRAM up down
Dialer1 unassigned YES NVRAM up up
NVI0 unassigned YES unset administratively down down
Virtual-Access1 unassigned YES unset up up
Cisco1#

Just to prove the point, I have removed the HWIC-1VDSL module, and eth0/0/0 has gone:
Cisco1#sh ip int bri
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES NVRAM down down
GigabitEthernet0/0.1 192.168.1.100 YES NVRAM down down
GigabitEthernet0/1 unassigned YES NVRAM down down
Dialer1 unassigned YES NVRAM up up
NVI0 unassigned YES unset administratively down down
Virtual-Access1 unassigned YES unset up up
Cisco1#

Regards, John.

HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to john51
said by john51:

Just to prove the point, I have removed the HWIC-1VDSL module, and eth0/0/0 has gone:

Never seen that before... and I don't own a 1921 / WIC card to test myself.

Should be able to crib a DSL config from the forum FAQ or from Cisco to start.

If you need VLANs on your LAN, then keep what you have on Gi0/0.1, otherwise,
it doesn't really serve a functional purpose.

Other thing I can think of is if you're getting your IP from your ISP dynamically, you don't need
this block

ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 217.32.142.104
 

Try that and let us know.

Regards

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9

Never seen that before... and I don't own a 1921 / WIC card to test myself.

I had to think about that for a minute, too. That's the VDSL interface in PTM mode. It would be an ATM interface in ATM mode. (not sure how/if it's switchable.)

He isn't running any VLANs. A single subif configured as "native" means no packets on that interface are being tagged. Unless there's a lot more going on here that isn't being explained, there's no reason to configure G0/0 like that -- other than "because I can".

The configuration using the provider modem is using a private address and no PPPoE. This suggests NAT and PPPoE are occuring at the modem. Someone will have to figure out how the modem is configured and setup the E0/0/0 interface to match. It should be pretty much exactly the same as with an ADSL ATM interface.

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
reply to john51
Ok. I got it slightly backwards...

G0/0 is your LAN. There's still no reason to configure it that way. (as far as the info has been provided)

G0/1 goes to the ISP modem. It gets an address by dhcp and runs pppoe. (?)

If E0/0/0 is the VDSL link replacing the modem, it should be configured the same as G0/1. Thus, "ip nat outside" and "ip address dhcp".

Only one default route is needed. "ip route 0.0.0.0 0.0.0.0 217.32.142.104" is not needed, and likely isn't even being used. The interface route will get everything rolling, but with the local VDSL interface, it won't be necessary as the interface coming up will cause it to "dial". (or it does for ATM based DSL. won't hurt either way.)

bigsy

join:2001-07-18
ireland
kudos:1
»www.cisco.com/en/US/docs/routers···wic.html gives details on how to configure the HWIC-1VDSL.

cramer See Profile is (of course!) completely correct about the ethernet PTM interface.

I have one of the combo ADSL/VDSL EHWIC-VA-DSL-A cards in the office 1921 and it is switchable from ATM to PTM. Currently it is still on ADSL but I'm hoping to make the switch to BT Infinity VDSL in the new year and get a chance to configure the VDSL interface. I'll post back with any results.

HELLFIRE
Premium
join:2009-11-25
kudos:18
...Learn something new every day. Thanks for the link bigsy

Regards

john51

join:2010-02-27
reply to john51
Hi, Guys, thanks for the replies.
I copied the Nat and dhcp settings from g0/1 to the vdsl card, and have tried out the suggested settings in the config from Cisco for the card, with no result.
Unfortunately there are probably things in the Cisco config that need changing, but I have insufficient knowlege to do.
Here is a section:
hostname router
!
boot-start-marker
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/2
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
ip multicast-routing
!
!
ip host dirt 223.255.254.254
multilink bundle-name authenticated
!
!
!
!
license udi pid C3900-SPE150/K9 sn FHH123000JN
!

Could someone please explain what a "Host dirt" is, I am aware that the Ip address after it is the last one available, is this important?
Next section:

archive
log config
hidekeys
!
!
controller VDSL 0/0/0
!
!
!
!
!
interface GigabitEthernet0/0
ip address 2.7.20.11 255.255.0.0
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
mac-address 0000.0000.0004
mtu 3000
ip address 200.0.0.150 255.255.255.0
ip pim sparse-dense-mode
load-interval 30
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Ethernet0/0/0
ip address 5.0.0.10 255.255.255.0
ip pim sparse-dense-mode
load-interval 30
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 1
dialer-group 1
no cdp enable
!
ip forward-protocol nd
!
ip pim bsr-candidate Ethernet0/0/0 0
ip pim rp-candidate Ethernet0/0/0
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 45.0.0.0 255.255.255.0 5.0.0.202
ip route 223.255.0.0 255.255.0.0 2.7.0.1
ip route 223.255.254.254 255.255.255.255 2.7.0.1

Do you see the ip address of the e/0/0/0 in this case?
If I connect VDSL I get showtime synch, and the card goes admin and protocol up, and I can ping the ip of e0/0/0 but no further.

I have tried to research "pim" and get the impression it's a multi-protocol setting, but I'm unsure of that, and also the many static ip routes.
Sorry about this, but there's no rush, I'm unlikely to try again until Jan 2012.

Many thanks for the help thus far guys!

John.

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
PIM == protocol independent multicast (multicast routing) I'm not sure why it's enabled on an Internet link.

You still haven't provided any information on how the ISP provided modem is setup.

If you're running PPPoE, then the ip address of the vdsl interface is meaningless. Check that dialer1 is active and has an address...

blue-gw#show int di1
Dialer1 is up, line protocol is up (spoofing)
Hardware is Unknown
Description: ...
Internet address is a.b.c.d/32
...
Interface is bound to Vi2
...
Bound to:
Virtual-Access2 is up, line protocol is up
...

(that's an ATM / ADSL interface, but that doesn't matter.)

bigsy

join:2001-07-18
ireland
kudos:1

1 edit
reply to john51
BT Infinity is supposed to be used with the supplied modem and is not a 'wires only' service. There is therefore currently no official guidance for configuration of third party VDSL modems and it is most definitely not supported.

There is potentially helpful information on the Draytek UK website which suggests that the 'WAN VLAN ID should be set to 101': »www.draytek.co.uk/support/kb/kb_···tup.html.

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
So that would be E0/0/0 at a default configuration (no ip, etc.) and an "E0/0/0.101' subif configured for dot1q and pppoe.

Interesting. I shall have to experiment with this using my 1721. (the vlan + pppoe, not VDSL)

john51

join:2010-02-27
Looks like the way to go.I can't find out any more about the provided modem, only that it's being hacked and modified to provide stats!
Here's a copy of the Draytec page:
Click on [WAN] > [Multi-VLAN] and set the settings as shown. With BT Infinity the WAN VLAN ID should be set to 101:

Apparently BT have dropped the enforcement to use their modem from the T&Cs, I'm not surprised after what the BT engineer who brought my second replacement told me "These are Sh*te!"
I will try a vlan setup on e0/0/0 as well.

Can somebody please tell me what "ip host dirt" means?

ladino

join:2001-02-24
USA
kudos:1
The host called 'dirt' has been mapped to IP address

»www.cisco.com/en/US/docs/ios/12_···p1108949

john51

join:2010-02-27
Thanks.

john51

join:2010-02-27
reply to john51
My latest config:
no aaa new-model
!
!
!
!
no ipv6 cef
no ip source-route
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
!
!
!
license udi pid CISCO1921/K9 sn FCZ1432C6XG
!
!
!
redundancy
!
!
controller VDSL 0/0/0
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
no mop enabled
!
!
interface GigabitEthernet0/1
no ip address
ip virtual-reassembly
no ip route-cache
ip tcp adjust-mss 1412
duplex auto
speed auto
!
no routing dynamic
!
interface Ethernet0/0/0
no ip address
no ip route-cache
!
!
interface Ethernet0/0/0.101
encapsulation dot1Q 101
ip address dhcp
ip nat outside
ip virtual-reassembly
no ip route-cache
ip tcp adjust-mss 1452
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
no ip unreachables
ip mtu 1492
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname bthomehub@btbroadband.com
ppp chap password 0 route
ppp pap sent-username bthomehub@btbroadband.com password 0 route
ppp ipcp dns request
no cdp enable
!
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any
!
!
!
!
!
snmp-server community public RO
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password gable1
login
!
scheduler allocate 20000 1000
end

And the dialer1 :
Dialer1 is up, line protocol is up (spoofing)
Hardware is Unknown
Internet address is 109.149.80.87/32
MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Closed, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Interface is bound to Vi2
Last input never, output never, output hang never
Last clearing of "show interface" counters 01:36:45
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/16 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 42 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
4 packets input, 48 bytes
4 packets output, 48 bytes
Bound to:
Virtual-Access2 is up, line protocol is up
Hardware is Virtual Access interface
MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: IPCP
PPPoE vaccess, cloned from Dialer1
Vaccess status 0x44, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
Interface is bound to Di1 (Encapsulation PPP)
Last input 00:00:08, output never, output hang never
Last clearing of "show interface" counters 00:00:49
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
23 packets input, 417 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
22 packets output, 317 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions

Question:
As the dialer has:Internet address is 109.149.80.87/32
surely something must be getting through via the VDSL?

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
That is correct. However, you still have a ton of junk making things not work.

• Routing is disabled. ("no ip routing") It will not forward packets from interface to interface in that mode.
• CEF is disabled. ("no ip cef") This will *significantly* reduce it's forwarding rate.
• Route-cache is disabled. ("no ip route-cache" under every interface.) This will absolutely kill throughput.

E0/0/0.101 is not an IP interface. It should not have any IP configuration set... no ip address, no nat, no adjust-mss.

Di1 is not a NAT'd interface... it's neither inside nor outside. As such, when routing is enabled, you will be sending traffic into the internet using private addresses. This, obviously, will not work.

BUT, you're getting an address, so you've gotten that part of the magic figured out.

john51

join:2010-02-27
Working fine, now:

no aaa new-model
!
!
!
!
no ipv6 cef
no ip source-route
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
!
!
!
license udi pid CISCO1921/K9 sn FCZ1432C6XG
!
!
!
redundancy
!
!
controller VDSL 0/0/0
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
no mop enabled
!
!
interface GigabitEthernet0/1
no ip address
ip virtual-reassembly
ip tcp adjust-mss 1412
duplex auto
speed auto
!
no routing dynamic
!
interface Ethernet0/0/0
no ip address
!
!
interface Ethernet0/0/0.101
encapsulation dot1Q 101
ip virtual-reassembly
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname bthomehub@btbroadband.com
ppp chap password 0 route
ppp pap sent-username bthomehub@btbroadband.com password 0 route
ppp ipcp dns request
no cdp enable
!
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any
!
!
!
!
!
snmp-server community public RO
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password gable1
login
!
scheduler allocate 20000 1000
end

If anybody can see any improvements, please say so.
I intend to use the config pro security audit next, I bet that stops it working!!

bigsy

join:2001-07-18
ireland
kudos:1
Good to hear.

Would you post the output of 'sh contr vd 0/0/0' as I'd like to see what's reported?

john51

join:2010-02-27
Here you go:

Controller VDSL 0/0/0 is UP

Daemon Status: Up

XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0xA1B7
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0xA1B7
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: FOC151311CY 1921/K9 15.0(1)M
Serial Number Far:
Modem Version Near: 15.0(1)M
Modem Version Far: 0xa1b7

Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2)
TC Mode: PTM
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
Line Attenuation: 0.0 dB 0.0 dB
Signal Attenuation: 0.0 dB 0.0 dB
Noise Margin: 23.3 dB 23.4 dB
Attainable Rate: 109436 kbits/s 32426 kbits/s
Actual Power: 12.3 dBm -12.6 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 1.9 4.8 12.2 0.1 5.2 7.4 N/A
Signal Attenuation(dB): 1.9 4.8 12.2 0.0 N/A 6.3 N/A
Noise Margin(dB): 23.4 23.3 23.3 23.3 N/A 23.4 N/A
Total FECS: 0 0
Total ES: 0 0
Total SES: 0 0
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0

Full inits: 0
Failed full inits: 0
Short inits: 0
Failed short inits: 0

Firmware Source File Name (version)
-------- ------ -------------------
VDSL embedded VDSL_LINUX_DEV_01212008 (1)

Modem FW Version: 090929_1033-4.02L.01.AvC011b.d21j1
Modem PHY Version: AvC011b.d21j1

DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 39998 0 10000
Reed-Solomon EC: 0 0 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0 0 0 0
Actual INP: 0 0 0 0

Training Log : Stopped
Training Log Filename : flash:vdsllog.bin

Cisco1#

Thanks to all for the help thus far!

john51

join:2010-02-27
Just had a problem logging onto Internet banking and ip's webpage...
added a line ip tcp adjust-mss 1350 to g0/0 (lan facing)

I saw this on another config, by the way.

Now faster than old provider's hardware 31.5 up, 6.3 down.


HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to john51
Faster's always good, how fast were you getting with the ISP supplied gear, and how stable is
the connection? Nothing like running multiple streams of traffic for several hours on end
and seeing if anything chokes or not

Regards

john51

join:2010-02-27
I spoke too soon!!!
I have now got an apparent dns resolution problem, i.e. https are fine, but domain names won't open in I.E 8 with Bitdefender AV, enabled or no..

I have read up a little on adjust-mss, and ip mtu and tried various settings, including increasing mtu on the lan nic, to no avil.

Is it possible that I need a vlan both sides of the router?

Do I possibly need a static route to lan facing g0/0?

regards

HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to john51
said by john51:

I have now got an apparent dns resolution problem, i.e. https are fine, but domain names won't open in I.E 8 with Bitdefender AV, enabled or no..

Can you clarify this problem further? Is it certain webpages (both http and https) intermittently
not displaying, or no http pages at all?

Intermittent webpage problems + a DSL connection usually is an MTU problem. For chuckles, from your
PC ping a website address with the "-l 1500" and "-f" options. Adjust the -l size up and down as
needed to rule this out.

Regards

john51

join:2010-02-27
I'll reply fully soon re the mtu, but also a problem is that a Netgear
WG302 is not working properly with the cisco setup. (via Netgear Gig switch)
It recieves an address via dhcp, but is not reachable by wireless devices for data, although it can be logged onto, I think I need to try it with a fixed ip when I get a minute.
I will try to explain the browser problem again. It appears to be only with Google.uk. The anti-virus programme (bitdefender) annotates sites as safe, but, suggested sites fromr a google search will not open if selected from ordinary text, but if selected from the ticked area, ie http, or https addresses they will open.
This does not apply to Amazon ads regardless of how they appear, or suggested sites via Yahoo search engine which also work. As you can see, I have large gaps in my knowledge!

No rush, guys, I've got a lot to do on my site.

Happy New Year everyone!!


TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5
reply to john51
I should imagine you can use an MSS of 1452. With PPPoE you typically end up with a useable MTU of 1492, as 8 additional bytes are required for PPPoE headers. Then, adjusting for 40 bytes of IP headers, you should be able to run 1452 bytes of payload through.

The lower you drop your MSS, the more packets your data has to be broken up into, which could have performance "implications".

ladino

join:2001-02-24
USA
kudos:1
reply to john51
Add the following global command...ip tcp path-mtu-discovery

Remove the MTU & all the mss statements & the 'ip unreachables' on the Dialer. Then find your MTU with the ping -f command. Put the new MTU on your Dialer interface. Add the MSS statement after subtracting 48 from the MTU you found.

Why does the WAN interface have a .101 sub-interface?

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
Read the entire thread... a VLAN tag is required on the VDSL interface.