dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
14
share rss forum feed

haggaret

join:2011-11-30
Stittsville, ON
reply to haggaret

Re: Everything MLPPP

Well I've successfully bonded two DSLs together as of tonight. I still need to pick up a third modem to add the last one into the mix. I still get the messages about the link being terminated, but everything is working so not sure what to make of that.

So far speed tests aren't great - especially in the downstream direction - not sure what is going on there. Upstream is about as expected, so that's good news.



Mersault

join:2007-10-26
Toronto, ON

Sad to hear about the Sangoma situation. I've generally liked them, and it's a local company which is awesome. But I've only ever worked with their voice gear.


haggaret

join:2011-11-30
Stittsville, ON
reply to haggaret

My attempt to move from 2 to 3 bonded connections isn't going smoothly unfortunately.I don't see it stating a PPP session on eth3 as expected (see below).

Here is the output of db_dump:

root@Bonder-HDP:/opt/mlppp/bin# ./db_dump
ppp0_username=xxxxxx@yyyyyyy.com
ppp0_defaultroute=1
ppp0_multilink=eth0,eth2,eth3
ppp0-key=6674C145
ppp0-link=11348
ppp0_multilink_top=3
ppp0_remote_endpoint=local:34.36.30.38.33.32.30.30.32.36.00.00.00.00.00
_ppp0-0_lcp_status=1
_ppp0-1_lcp_status=1

Starting the connection:

root@Bonder-HDP:/opt/mlppp/bin# ./pppoe_start ppp0
Plugin rp-pppoe.so loaded.
Plugin rp-pppoe.so loaded.
root@Bonder-HDP:/opt/mlppp/bin# Plugin rp-pppoe.so loaded.
PPP session is 12280
Starting negotiation on eth0
PPP session is 3538
Starting negotiation on eth2
PAP authentication succeeded
peer from calling number 00:90:1A:A0:A2:7A authorized
Using interface ppp0
ioctl(PPPIOCSFRAG): Invalid argument (line 775)
New bundle ppp0 created
Terminating on signal 15
Connection terminated.
local IP address xxx.xxx.xxx.xxx
remote IP address xxx.xxx.xxx.xxx
primary DNS address 206.248.154.22
secondary DNS address 206.248.154.170
Terminating link on signal 2
Link terminated.
Timeout waiting for PADO packets

The other weird thing is that if I reboot the system, it all goes to hell. It doesn't start up automatically, and I had to re-copy over the /var/run/mlppp directory to get anything going.

Anyone have any experience with this that would be willing to help me out? Like I said - 2 seems to work fine, but trying to get to 3 isn't going so well.

Thanks

ziggy89

join:2009-12-16
London, ON

We currently are setup on single line MLPPP, and plan on having a dry loop line installed so we can set up up 2-line mlppp

I'm a little unclear about the physical setup. I'd really appreciate it if someone could clarify a few things for us.

Router is Linksys WRT54GL flashed with TOMATO

I'm thinking it would be set up this way:

Note: Router is Linksys WRT54GL flashed with TOMATO

Line 1 ( Our current DSL connection ) --> Modem 1 --> WAN port on Router

Line 2 ( Dry loop DSL line ) --> Modem 2 --> a LAN port on the Router

LAN2 ---> PC1
LAN3 ---> PC2

Then configure Tomato for 2 line MLPPP

Thanks