dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2191
share rss forum feed


Barrowhill

@virginmedia.com

Echolink Setup

Hoping one of you can give me some advice. I'm not a Radio Ham myself but my friend, who is, asked me for help setting up his desktop and laptop to run echolink

His desktop is new, running windows 7 64bit edition. His lap is older running windows XP. Both use AVG 2012 Free Edition as AV software and thus both Use Windows Firewall. His router is a BT Home Hub 2.

I remotely connected to him last night and eventually set up his desktop (win 7) to use echolink (the router instructions were somewhat dated. The router/firewall test option passed all UDP and TCP tests and I was able to connect to the Echolink Test Server and send (and receive) test messages.

One down, one to go. I thought the laptop (XP) setup would be simple as the router had been successfully setup via the desktop. However, whilst it passes the TCP test it fails all the UPD tests with receive error 10060. I've checked the firewall exceptions list and echolink is listed. I've even input ports 5198 and 5199 seperately just to be assured. I still can't get the UDP tests to pass. I've switched off firewall but UDP tests still fail

Would certainly appreciate any advice as to what I might of missed. Perplexed that desktop echolink functions OK but laptop doesn't. Only differences are OS and perhaps version of windows firewall



Robotics
See You On The Dark Side
Premium
join:2003-10-23
Louisa, VA

Have you tried this:

First, be sure you have Windows XP Service Pack 2 installed. The instructions below apply only to SP2. (You can verify this by right-clicking the My Computer icon on your desktop.)

1. Click Start and then click Control Panel.

2. In the control panel, click Windows Security Center.

3. Click Windows Firewall.

4. In the General Tab, be sure that the option "On (recommended)" is selected. If not, click it.

5. Be sure the checkbox "Don't allow exceptions" is not checked.

6. Click the Exceptions tab at the top.

7. Click Add Program... (near the bottom). A list of programs on your computer is displayed.

8. Locate EchoLink in the list of programs. Highlight it and click OK.

9. Click OK again to complete the Windows Firewall setup.
--
Long you live and high you fly, and smiles you'll give and tears you'll cry,
and all you touch and all you see, is all your life will ever be.



barrowhill

@virginmedia.com

Yes. I've been to the Exceptions list in Windows Firewall and can confirm that Echolink is shown and enabled. All other criteria as you mention is confirmed.

One thing has occurred to me and my friend has not yet responded on the issue; Would there be a problem if the Echolink program was up and running on the Desktop machine whilst I was trying to test on the laptop??? I can't remember if I closed the program on the Desktop before I started on the laptop. I've asked my friend to rerun firewall/router test from laptop with Desktop off.



battleop

join:2005-09-28
00000

Did you change your port forwards from the desktop to the laptop?



barrowhill

@virginmedia.com

Change ?? Having used the desktop to set up the router port forwarding, I switched to the laptop (assumed I switched off echolink on desktop to a) confirm XP windows firewall settings correct, and b) to test router/firewall settins.

What (else) would I of had to change with the laptop ??



alphapointe
Don't Touch Me
Premium,MVM
join:2002-02-10
Columbia, MO
kudos:2
Reviews:
·Socket Internet ..

When you're behind a NAT router, you can only run echolink on the machine you forwarded ports 5198 and 5199 to. You can't run echolink on more than one machine behind NAT (even when they are not running at the same time... if you use a different machine, you have to point 5198 and 5199 to that machine)



ds5v50

join:2003-01-22
Fremont, OH

said by alphapointe:

When you're behind a NAT router, you can only run echolink on the machine you forwarded ports 5198 and 5199 to. You can't run echolink on more than one machine behind NAT (even when they are not running at the same time... if you use a different machine, you have to point 5198 and 5199 to that machine)

Unless there is the availability of upnp in the router. If there is that will solve the issue with using the two machines to connect to Echolink. But you can only have 1 machine on echolink at a time. so if by chance one was running while you tried the other then no it will not work. There is also the possibility of using a proxy on one of the machines. then you would be able to run two copies of echolink on the same network.
--
Fremont, Ohio Weather
»www.Fremont-OH-weather.com