dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1287
share rss forum feed

davidmark

join:2011-12-03

Static IP challenge on Linksys PAP2 VoIP ATA

Click for full size
DHCP set-up
Hi,

I'm using freephoneline.ca in Canada and so far it's working fairly well. 100% success on outbound calls but when people call us, about 2 out of 3 times we can hear them - but they can't hear us. (If they call back, they can typically hear us on the 3rd attempt.)

I spoke to tech support at freephoneline.ca and they suggested I set-up port forwarding on my router - and that that should solve everything. (forward to 5060-6061 and 10000-20000). I successfully set-up port-forwarding on the router - but it has also been advised that I should set a static IP address on the ATA.

I set-up the static IP on the ATA (see attached screenshot) and I see it in my router. However, the phone light indicator on the ATA is off and no dial tone... I tried setting the static IP without using port forwarding and I get the same result.

So, when I have DHCP turned on, my phone works - but those calling us have a challenge hearing us 2 out of 3 times. When I turn DHCP off and set a static IP address, the phone doesn't work at all.

I'm clearly missing some crucial step in the set-up - perhaps on the router - but perhaps in the ATA.

Any direction would be greatly appreciated.

Thanks,

Dave


dcurrey
Premium
join:2004-06-29
Reviews:
·Time Warner Cable
·Cincinnati Bell
·ViaTalk
Probably best to leave dhcp on and have router set the same ip address on the ata. Usually this is done by mac address. Different setup with each router.

Second you need to set your primary and secondary dns servers. Match your isp settings or use a public dns like googles 8.8.8.8 and 8.8.4.4 Thinking this is your problem.

Last make sure you have your ips match with routers. A lot use 192.168.0.x. Same subnet and such. Some routers have problems if you try to assign a static ip inside the routers dhcp range.

davidmark

join:2011-12-03
said by dcurrey:

Probably best to leave dhcp on and have router set the same ip address on the ata. Usually this is done by mac address. Different setup with each router.

Second you need to set your primary and secondary dns servers. Match your isp settings or use a public dns like googles 8.8.8.8 and 8.8.4.4 Thinking this is your problem.

Last make sure you have your ips match with routers. A lot use 192.168.0.x. Same subnet and such. Some routers have problems if you try to assign a static ip inside the routers dhcp range.

Thanks for the response.

This is my interpretation of what you're saying:

1) I should NOT assign a static IP address to the ATA.
2) I should set-up port forwarding on the router to the IP address the router assigned to the ATA.
3) If I do 1) and 2) above, even after I reboot the router...I don't need to worry about the ATA being assigned a different IP address and consequently "mess-up" the port forwarding.

In terms of setting primary and secondary dns servers, is this necessary if I haven't set a static IP? If it in necessary, do I just pu 8.8.8.8 in the primary DNS field and 8.8.4.4 in the secondary? Or, do I put 192.1.168.1.1 in the primary field and 8.8.8.8 in the secondary - or am I completely out to lunch!

My presumption is that your last paragraph is NOT necessary if I am using a dynamic IP address.

Thanks again in advance for any help you might be able to give.

Dave


dcurrey
Premium
join:2004-06-29
Reviews:
·Time Warner Cable
·Cincinnati Bell
·ViaTalk
reply to davidmark
1, The only real advantage of leaving the ata in dhcp is if router fails and you replace it. Might be a little more work getting the ata matched to new router. But either way it can work.

2. Correct set port forwarding to whatever the router assigns the ata to. On dlink its called "Dhcp reservation" ATA is still set as dhcp but router will always give it the same ip address. This address is what you would setup forwarding to.

3. If the ata is using dhcp the dns servers will be set automatically by your router. No need to enter them.

As far as manually setting the dns servers if your router relays dns server request you could set primary as the 192.168.1.1. Dlink 655 had some serious issues with relay so I never have used it.

Stewart

join:2005-07-13
kudos:25
reply to davidmark
If you set static IP in the ATA (as shown in your screenshot) you must also set DNS servers. I recommend 8.8.8.8 and 4.2.2.2

If your router has a static DHCP feature, you can use that instead, eliminating the need for any special settings in the ATA.

davidmark

join:2011-12-03
Thanks for both of your responses. I think I'll stick with DHCP for now and see how it goes. If I'm still having issues, I'll consider setting a static IP on the ATA or the router and making sure I get the DNS configured properly. That might be the only thing that was causing the issue.

Thanks again for your assistance!

Dave