dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1690
share rss forum feed

litobro

join:2011-12-02
Edmonton, AB

[AB] Actiontek V1000h .55 Optik High Speed Turbo Port Forwarding

Hi everyone,

I have been frustrated with Telus for quite some time now but I am really trying to get the port forwarding to work now. Unfortunately I am on the Telus Optik TV with High Speed Turbo internet plan for another year or so on contract and they refuse to let me use my own router instead of theirs. I admit my naivety in terms of networking but I am an experienced computer service technician and know my way around a home or small business network, surely a simple port forward couldn't defeat me?

Well it appears that it has, I have tried running a web service on various ports(listen 80, 81, 8080, 777, 666 etc.) And every time I am able to access the service within the LAN but not from the WAN. I have attempted to port forward the individual ports, a range of ports around the port, and have placed the server system on a DMZ as well. Nothing seems to help. Now I have tried this with two different systems, my primary Windows 7 desktop and my spare Ubuntu server I have in a corner. I even went so far as to try the experiment again with an FTP server on different ports. I am aware that port 80 and port 21 should be blocked which is why I tried the different ports. Any further advice would be much appreciated.

Thanks,

Litobro

RD5

join:2012-02-01

Re: [AB] Actiontek V1000h .55 Optik High Speed Turbo Port Forwar

Assuming this applies the same to home DSL as business DSL packages - Telus is blocking these connections - it is not your port forwarding/configuration.

This won't work until you add a static IP to your account (even possible for home users?).

litobro

join:2011-12-02
Edmonton, AB
reply to litobro
Well I did some additional testing while at work and found something VERY interesting. I can appear to use port forwarding properly from the WAN(assuming a non-blocked port is used) but only when outside of the network that is being port forwarded. I can seemingly use my apache server fine on a non-standard port but only if I attempt to access my external IP from a different network. Why TELUS does this I do not know. It had worked fine from within the LAN to WAN before on my old Shaw setup but I had started to dislike Shaw and jumped ship. Well for now this is quasi-solved... It just makes testing extremely difficult.

couttsj

join:2010-07-29
Vernon, BC
Think about it for a moment. Your equipment is on a Local Area Network (LAN) utilizing private addresses, and is connected to the Wide Area Network (WAN) through a gateway router. The gateway router sits on the WAN using a public address, and on the LAN using a private address. Most home routers do not have a loopback address like your computer does. To access another machine on your private network you must use private addresses (eg. 192.168.xxx.xxx). The outside world using the WAN must use the public address assigned to the router. When you ask for a DNS translation, you get the public address, which you cannot access from the Local Area Network.

To get around the problem, add the fully qualified domain name to your HOSTS file, as it takes precedence over DNS.

TheMG
Premium
join:2007-09-04
Canada
kudos:3
Reviews:
·NorthWest Tel
reply to litobro
It's exactly as couttsj explained, what you're experiencing is due to your router.

I ran into the same situation many years ago.

said by litobro:

they refuse to let me use my own router instead of theirs.

You can, but you'll have to look around for a Cellpipe VDSL modem that is compatible with Telus. They can be a little tricky to obtain but they do exist.

You don't have to use the Telus-provided unit as long as you can find a compatible alternative.

litobro

join:2011-12-02
Edmonton, AB
reply to litobro
Hmm, that's really interesting. Do you think you could give an example of something compatible to Optik TV as well? Thanks,

Litobro

Lesaonar

join:2000-07-25
Victoria, BC
»[FS] Telus Alcatel Cellpipe 7130 for sale
--
Anon filter enabled. Register an account if you want to be taken seriously.


EdmMark

@telus.net
reply to litobro
How did you get that to work? I've been trying with no success to be able to access my test server from the outside but no luck. You're the first that seems to have been able to do that.

litobro

join:2011-12-02
Edmonton, AB
Ahh, I thought I had it working, which it did for a day. And then I shut off my testing machine and put it in a closet. And POOF! My setup stopped functioning. I was and still am thoroughly frustrated...

bluenote73

join:2009-02-17
V4N6A5
reply to litobro
I just set this up a couple days ago and it only took a short while, but there are a couple gotchas.

This isn't as hard as you're making it, at least, it wasn't for me.

1) Use the DMZ
2) Ensure that the DMZ IP is still valid and pointing to the correct box (because to my newb eyes, there's no guarantee your internal box or router is going to get the same IP it did before)
3) Lan - Wan - Lan doesn't work for me either, but I'm double natted behind a router now, so I didn't really expect it to work, although single natted lan-wan-lan did work with shaw previous just like you.
4) Some ports are blocked. there's a FAQ somewhere. I'm using port 8000 no problem.

Good luck

litobro

join:2011-12-02
Edmonton, AB
Well, I'll do some more tests but it really doesn't seem to work for me -.- And I've set my IP manually so it won't change.