dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1877
share rss forum feed


DerekJP

@rr.com

[Equipment] Viatalk and Tomato router

I've been a ViaTalk customer for several years and I've always had my phone adapter (Grandstream) behind my router (DD-WRT) and in the DMZ and it's worked fine. I was having some issues with DD-WRT so I decided to flash to Tomato, left the Grandstream in the DMZ, but I was having sporadic issues with incoming calls not connecting, no audio on outgoing calls, etc. ViaTalk sent a few config changes to the adapter, but it wouldn't start working again normally. I swapped the physical setup so the Grandstream was between my cable modem and router, and everything started working fine again.

Unrelated, I got a new router (Linksys E3000) and flashed it to TomatoUSB. I went back to my original physical setup (Cable modem > Router > Grandstream) and put the Grandstream back in the DMZ. It worked fine for about a week (I didn't enable QoS), then within a day of turning QoS back on the phone problems started again. I turned off QoS, but it didn't fix the phone problems so I swapped it back to sit between the cable modem and the router and it seems to be working fine again.

Anyone else see a similar issue with Tomato? I'm considering flashing back to DD-WRT to see if that fixes the issue definitively, but I like Tomato better.



unknvoip
RIP goose
Premium
join:2006-07-25
Rochester, NY
kudos:1
Reviews:
·ViaTalk

I have my PAP2 behind my E3000 running Tomato with QoS on for over a year without issue. Prior to that I was running Tomato on a WRT54GL for several years in a similar configuration, although I did run DD-WRT for a time too. My PAP2 is set to use ports 5080 and 5081 so I have a port forwarding rule for them in Tomato to forward to the device. DMZ is off.

Hope this helps


Peteypoo

join:2005-06-16
Lincroft, NJ
reply to DerekJP

I've been running Tomato F/W on my router with the PAP2 coming out of it, but logically in the DMZ.
It's been rock solid for about four years.



DerekJP

@rr.com

Hmm... strange. All ViaTalk support says is "it should work". Although I did have it disconnect once while sitting before the router this past week, but a quick reset and it was working fine again. I'm at a loss as to why it keeps crapping out when it's behind the router.