dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1735
share rss forum feed

northbear

join:2012-02-11
Saint Paul, MN

2 edits

[Config] Config Help: 2801, Qwest DSL

I'm looking for a little feedback regarding my Cisco config file.

My basic setup is as follows:
Cisco 2801
Assigned /29 block from Qwest (ISP)
No NAT, just looking to use assigned block of IP addresses for servers.
DSL modem (in bridge mode) connected to FastEthernet 0/1
Switch connected to FastEthernet 0/0

It looks as if the router is logged in with the ISP, it pulls my assigned gateway IP. (199.199.199.182) But beyond that, nothing. What am I missing? This is my first cisco config I have done... I've looked at a lot of examples and this is the best I can come up with. Any feedback appreciated.

Here is my config.

no parser cache
no service pad
service timestamps debug uptime
service timestamps log uptime
!
hostname r1
!
logging buffered 4096 informational
!
ip subnet-zero
!
bridge irb
!
no ip dhcp-client network-discovery
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!!!!!! This is attached to the switch/servers
interface FastEthernet0/0
no shut
no ip address
bridge-group 1
hold-queue 32 in
!
!!!!!! This is facing the modem (ISP)
interface FastEthernet0/1
no shut
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
!!!!!! The ISP's given IP address will be configured via d1
interface Dialer1
ip address negotiated
!!!!!!
ip mtu 1492
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname myqwestusername
ppp chap password myqwestpasswd
ppp pap sent-username myqwestusername password myqwestpasswd
ppp ipcp route default
bridge-group 1
!
interface BVI1
no ip address
!
dialer-list 1 protocol ip permit
bridge 1 protocol ieee
bridge 1 route ip
!
no cdp run
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
length 0
!
scheduler max-task-time 5000
end

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
bridge a ppp dialer interface??? There's something I've never seen before

I'll have to give that a try to see just what sort of mess it creates. I'm a little surprised it'll even take such a config.

northbear

join:2012-02-11
Saint Paul, MN
reply to northbear
Not sure, if I can't bridge the dialer interface, is there another way to do it?

Looks like it is logging in to Qwest without any problems, pulls my assigned IP.

Here are some print outs from the router if anyone wants to see them.

ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 207.207.207.235 to network 0.0.0.0

199.199.199.0/32 is subnetted, 1 subnets
C 199.199.199.182 is directly connected, Dialer1
207.207.207.0/32 is subnetted, 1 subnets
C 207.207.207.235 is directly connected, Dialer1
S* 0.0.0.0/0 [1/0] via 207.207.207.235

------------

Dialer1 is up, line protocol is up (spoofing)
Hardware is Unknown
Internet address is 199.199.199.182/32
MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Interface is bound to Vi2
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:01:50
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/16 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 42 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
5 packets input, 181 bytes
15 packets output, 210 bytes
Bound to:
Virtual-Access2 is up, line protocol is up
Virtual-Access2 is up, line protocol is up
Hardware is Virtual Access interface
MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 4/255, rxload 4/255
Encapsulation PPP, LCP Open
Listen: BCP
Open: IPCP
PPPoE vaccess, cloned from Dialer1
Vaccess status 0x44, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
Interface is bound to Di1 (Encapsulation PPP)
Last input 00:00:04, output never, output hang never
Last clearing of "show interface" counters 00:01:58
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 1 packets/sec
5 minute output rate 1000 bits/sec, 1 packets/sec
425 packets input, 31517 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
428 packets output, 31819 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
--More--

FastEthernet0/0 is up, line protocol is up
Internet protocol processing disabled
FastEthernet0/1 is up, line protocol is up
Internet protocol processing disabled
BVI1 is up, line protocol is up
Internet protocol processing disabled
Virtual-Access1 is up, line protocol is up
Internet protocol processing disabled
Virtual-Access2 is up, line protocol is up
Peer address is 207.207.207.207
Dialer interface is Dialer1
Dialer1 is up, line protocol is up
Internet address is 199.199.199.182/32
Broadcast address is 255.255.255.255
Address determined by IPCP
MTU is 1492 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default

Interface IP-Address OK? Method Status Prot
ocol
FastEthernet0/0 unassigned YES manual up up

FastEthernet0/1 unassigned YES manual up up

BVI1 unassigned YES manual up up

Virtual-Access1 unassigned YES unset up up

Virtual-Access2 unassigned YES unset up up

Dialer1 199.199.199.182 YES IPCP up up

aryoba
Premium,MVM
join:2002-08-22
kudos:4
From your description it looks like you have two separate subnets, one is for the WAN (the router's interface Dialer1) and another is for the LAN (your servers). In typical ISP setup (including Qwest), they just do routing for both subnets. Therefore you do not need to bridge the two router interfaces (the FastEthernet0/0 and Dialer1); in fact by bridging them your configuration won't work.

For the sake of discussion, let's assume your assigned /29 block (the LAN subnet) is 1.1.1.0/29. Here is what I suggest to see if it works.

* Remove all bridging-related configuration; including bridge-group, bridge 1 protocol ieee, bridge 1 route ip, interface BVI1, and bridge irb commands.
* Configure the router's FastEthernet0/0 interface to have 1.1.1.1 IP address with subnet mask of /29
* The router's FastEthernet0/0 1.1.1.1 IP address will be your servers' default gateway
* Use 1.1.1.2 to 1.1.1.6 IP addresses for your servers

northbear

join:2012-02-11
Saint Paul, MN
Thank you, Aryoba. Config works great after removing all bridging-related items.