dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2758
share rss forum feed

Sonict

join:2012-03-17

[Internet] Trying to get TP-link 8816 working on Bell Internet..

Hi, guys.

I am running into an annoying issue here.

I currently have the 2wire 2701HG-G modem. I want to take it down and instead, use my own modem (TP-link 8816) to connect to my new Wireless N router which is the reason why I am doing this as I don't want to fiddle with turning it into a bridge.

First, I want to make sure I can even connect to the Internet using the modem before I attach the router so from reading various posts on here. I have done this:

Made PVC0 use VPI 0 VCI 35.
Setup the connection for PPPoE using a username and password...

The modem detects the ADSL line and gets the correct sync profile. The issue is that it fails to login at all.

I use the "b1xxxxnn" username and the password and I know they are right as I had to change the password since I lost the sheet that had it.

The modem gave an error like this:
1/1/2000 0:14:58> netMakeChannDial: err=-3000 rn_p=804c0ed0
1/1/2000 0:15:8> Last errorlog repeat 5 Times
1/1/2000 0:15:8> Call Failed


Then, according to a person that I know over the internet, he thought according to a link on the Bell Website, I had to add @bellnet.ca to the username to get it to work.

I tried and instead, it gives me "bad username/password" which is better, but I dunno if that is correct since I do know the Bell ID and password. Is there another "@" that I am suppose to use? :/

So this is where I am stuck. I know I am close to getting this. The router that I'll be using will be an ASUS RT-N56U. Hopefully I won't get the WAN disconnect issues from it once I solve this issue.

Help!


Chuck sTruck

@teksavvy.com

Re: [Internet] Trying to get TP-link 8816 working on Bell Intern

You have to set a static ip address to your ethernet card. Under internet protocols (TCP/IP) Properties. Set an IP address of 192.168.1.2 with a subnet mask of of 255.255.255.0 then click on ok. With that router you're better off running the modem in bridge mode and letting the router do the pppoe.

kovy

join:2009-03-26
kudos:8
reply to Sonict
Bell user name only uses b1xxxxnn with nothing else and password.

Password should be between 6 and 8 letters/numbers... don't forget caps if u have some.

I would try to connect with test@test password test, or else try a pppoe connection in Windows see if it works.

InvalidError

join:2008-02-03
kudos:5
reply to Sonict
said by Sonict:

I tried and instead, it gives me "bad username/password" which is better, but I dunno if that is correct since I do know the Bell ID and password.

A while ago, I had a weird authentication error where I got "incorrect login/pw" error no matter which login pair I used... my login simply mysteriously stopped working in the middle of the afternoon without me changing anything. Called tech support, spend half an hour getting told I must have mistyped something before they finally opened a ticket and the next morning, all the logins that I had allegedly mistyped mysteriously started working again.

Calmuser

join:2011-10-27
Canada
reply to Sonict
thats weird. My 3rd party modem just worked. After I set the correct VCI, etc.

i'm running it in bridge mode through my Linksys wrt310n with Tomato, initiating the PPPoE

Zoom 5760 Modem.


Thane_Bitter
Inquire within
Premium
join:2005-01-20
Reviews:
·Bell Sympatico
reply to Sonict
You might have mistyped the password or username (it might be case sensitive) and Bell has locked you at for a short time.

Why not just clear out the password from the TPLink and let your ASUS router do the PPPoE login instead (the downside of course is you will not be able to access the modems GUI if you wanted to check line stats).

Sonict

join:2012-03-17
reply to Sonict
I was actually doing the PPPoE connection from the modem since it can do it, not the computer. Like I said in my post, I am trying to make sure I can connect to the internet first before I connect the router and let it do the connecting.

Maybe it still wants my old password. :/

I guess I'll try this again later, but I have a feeling it is going to hate me.

Thanks for replying, guys.

RickStep
Premium
join:2002-11-25
Hamilton, ON
kudos:1
reply to Sonict
A router behind a 2Wire works very well.

You might want to read through this link from mid December last year:

»Connect my Dlink to 2wire

The message from Bell Router Behind Router Detected may only show up with some versions of the 5.xxx.xx firmware and I don't get the message anymore with version 6.xxx.xx firmware.

However; the 2Wire firmware sets itself up to work properly.

Keep in mind that the 2Wire wireless setting defaults to on with little or no security. If you reset the 2Wire you will have to disable wireless.

Rick

Jurjen

join:2010-08-18
Montreal, QC

1 recommendation

reply to Thane_Bitter
said by Thane_Bitter:

the downside of course is you will not be able to access the modems GUI if you wanted to check line stats

If you can write firewall rules (e.g. if you flashed the router with DD-WRT), you can include the modem's IP address in the LAN and make it accessible, while keeping the modem in bridge mode.
Works fine here.


Thane_Bitter
Inquire within
Premium
join:2005-01-20
Reviews:
·Bell Sympatico
said by Jurjen:

If you can write firewall rules (e.g. if you flashed the router with DD-WRT), you can include the modem's IP address in the LAN and make it accessible, while keeping the modem in bridge mode.
Works fine here.

Finally a more elegant solution!

The other way is a creative use of cabling which shunts WAN traffic into the LAN switch of a router and then back out into the WAN port of the router.
»/r0/download/1···back.jpg

Jurjen

join:2010-08-18
Montreal, QC

2 edits

1 recommendation

Administration --> Commands

iptables -t nat -I POSTROUTING -o `nvram get wan_ifname` -j MASQUERADE
 

Save to Firewall.

My LAN is subnet 192.168.1.x, my modem is 192.168.2.1

/edit: might need to add this rule to the startup script:
ifconfig `nvram get wan_ifname`:0 192.168.2.2 netmask 255.255.255.0
 

I'll see if I can find back my original source for this code.

/edit 2: yup, that's it!
»www.dd-wrt.com/wiki/index.php/Ac···guration