dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2745
share rss forum feed

divemedidrb

join:2012-04-14
Mount Prospect, IL

Windows Home Server behind Ultra Router / Gateway

Hello all,

I'm new here! Howdy!

I've searched this and other forums extensively over the past few weeks trying to find a solution to my problems with my network and internet since the install of WOW Ultra. So far, no luck.

I have a Windows Home Server machine on my network. Previously, with the WOW Cable Modem (pre-Ultra) and my Linksys WRT610N router, I had plug-n-play functionality on the server and network. The main feature that worked, without fiddling, was the Remote Access. The server could be accessed at »mydomain.homeserver.com without issue. This was because the Linksys router was UPnP enabled and the Home Server was able to configure itself and the router without intervention (including port forwarding).

WOW Ultra was installed, my old Linksys router was connected to the Ultra Gateway, and life on my network continued to be good… until I tried to get to my Home Server from off the network (at the »mydomain.homeserver.com). The page was unavailable. I looked at the Home Server and noticed that it had an error message about the “Router no longer being configured correctly.” I plugged the home server into the Ultra Gateway directly, made sure the WOW Ultra Gateway had UPnP turned on, and checked the server again (refresh, fix this problem, set up router, etc etc). Still no luck “Router not set up correctly” and “Remote web service unavailable.” OK! Fail.

Went to manually configure the WOW Router and open up ports 80 (HTTP), 443 (HTTPS), 4125 (Remote Desktop).
On the WOW Router I did this by entering the following:
Description: Http
Inbound port: 80 to 80
Format: TCP
Private IP: ###.###.###.### the Static IP of my Home Server
Local Port: 80 to 80
Repeated for the other ports as well.

So now I think I’ve set up my router manually and everything should work, but my Home Server still says everything is broken & unavailable. I still could not access the Home Server from outside of my Network.

Can anyone suggest why this may be and what else needs to be adjusted to make servers available through this new WOW Ultra Router?


mix

join:2002-03-19
Utica, MI
Firstly, you need to remove the second router, otherwise you are doing double nat translation, which causes all types of problems. UPnP will not work in a double nat situation. Second, I highly doubt you can use ports 80 and 443 for anything unless you have a business class internet account, because these are blocked by WOW. Third, even if ports 80 and 443 weren't being blocked at the ISP level, the Ultra Router probably uses them to serve it's internal web server which is serving it's configuration web pages. Thus there is no way to remap these ports.

I don't have a Windows Home Server machine, and have never used whatever mydomain.homeserver.com is. But I suspect it works like this: Your machine opens a port for remote desktop using UPnP. Your machine also contacts some Microsoft server and from that Microsoft can see your external ip address, and possibly you even report to it the port that is supposed to be open for remote desktop (3389 has been the default remote desktop port for every version of remote desktop I have ever used, I don't know where you got 4125 from). This is basically similar to a dynamic dns service.

If UPnP is really broken with this router, you should be able to forward port 3389 on the ultra router to your windows home server internal ip address port. You could forward port 3389 to port 3389, or 4125 to port 3389 or whatever the hell you want as long as the remote desktop service is listening on whatever port you pick. Again, assuming that port forwarding even works correctly with the Ultra router. There are all kinds of reports claiming all kinds of problems with this router on this message board.

hudiat

join:2011-10-13
You need 4125 and 3389. 4125 is the web workplace port, 3389 is remote desktop.

divemedidrb

join:2012-04-14
Mount Prospect, IL
reply to mix
Hey Mix

Thanks for the reply, however, it doesn't really solve the problem. You essentially said "stop tinkering and you're SOL."

Well, I'm not quite ready for the towel just yet. The solution I'm currently utilizing is this:
1. Connected the Linksys to the WOW via the Linksys Internet (WAN) port
2. Gave the Linksys router a static IP (set on the Linksys, with the static IP being in the WOW IP range)
3. The Linksys is serving an entirely different set of IPs (separate network) but is still getting internet from the WOW gateway. So the Linksys is a Static IP device on the WOW network, serving it's own network.
4. I put the Linksys router (which of course has it's own firewall/protection) in the DMZ on the WOW router.
5. The linksys router is now serving internet through the WOW gateway, completely un-influenced by the WOW gateway.
6. Everything works on the Linksys network and I can access my devices, server, open ports, etc.

The FAIL is that the WOW and Linksys networks are separate and, as such, I lose the mildly useless media streaming features that WOW Ultra provides from my PCs.

It would be ideal for all to be on the same network, playing nicely together. So that's why I'm asking....HOW DO YOU GET IT TO WORK. Not "How to give up and throw in the towel." haha.

Thanks though for the input!. I really do appreciate the time you took to respond.

Doug


mix

join:2002-03-19
Utica, MI

1 edit
You are only SOL if both UPnP and port forwarding are broken on the Ultra TV router gateway device. I guess what I don't get here is why you want to do double nat? Why do you want to use two routers? It's like you don't understand what I said, which is what you are trying to do doesn't work with double nat.

divemedidrb

join:2012-04-14
Mount Prospect, IL

2 edits
Remove the Linksys router from the equation.

I tried plugging the Home Server into the WOW router directly. The Home Server threw that fit (described above) about not being able to configure the router (WOW Ultra) and that remote web services were not available (and they weren't). Of course, UPnP on the WOW was enabled (as you can't disable it), yet Home Server was not playing nicely.

So that's where manual configuration came in (again, described above) manually opening those 3 ports. Home Server still didn't recognize the router or play nice... of course, since port forwarding has nothing to do with how devices play nice together. But the port forwards still did not allow access to the Home Server.

Potential port forward problem on the router?
Potential config issue on the server?
Potential UPnP issue on the router?
Potential firewall issue on the router?

Even putting the Home Server in the WOW router DMZ didn't equal a successful connection. There's something more to it....

Anyway, see these two resources to better understand the issue:
1. What I'm trying to accomplish (end result) through the WOW router:
»www.addictivetips.com/windows-ti···e-cloud/

2. The directions for manual config of the router. Followed the generic port forwards on the WOW router, but still not playing nice. What else is broken?
»social.technet.microsoft.com/wik···tup.aspx

Jeremy W

join:2010-01-21
reply to mix
said by mix:

even if ports 80 and 443 weren't being blocked at the ISP level

They're not.

sgc

join:2011-11-02
Naperville, IL
reply to divemedidrb
You could enable uPnP in the gateway's settings. I do know, however, that there is some lingering issue regarding uPnP and the Ultra TV gateway.


barakandl

@wideopenwest.com
reply to divemedidrb
Initially i had the gateway run to a router in my room (with NAT off and just running in switch mode basically) and i still could not get DNLA to work over the network.

I swapped the extra router for a switch and then it would work. The UPNP did not work right with double router.

richardk

join:2012-07-15
reply to divemedidrb
divemedidrb, Did you ever come up with a solution for this? I just had WOW installed over the weekend, and having similar issues. I have a windows home server running hmailserver for emails. I don't have a problem accessing the home server from mydomain.homeserver.com from outside of my network, i.e. at my office. But i can not access mydomain.homeserver.com from inside my home network. Does wow block a loopback dns? I can ping my wan ip from outside my network, but again, not from my network??