dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
533
share rss forum feed


acadiel
Press fire to begin
Premium
join:2002-06-22
61705
kudos:2

Apt-Mirror and Ubunu - issues loading after mirroring

Brand new 12.04 system here (x86_64), and trying to initially set up a apt-mirror repo where I can load a complete system. I'm new to Ubuntu, been using RHEL forever, so this is a little bit of a learning curve.

I setup apt-mirror, edited /etc/apt/mirror.list and put the following in it:

deb »archive.ubuntu.com/ubuntu precise main restricted universe multiverse
deb »archive.ubuntu.com/ubuntu precise-security main restricted universe multiverse
deb »archive.ubuntu.com/ubuntu precise-updates main restricted universe multiverse

Ran apt-mirror and it happily downloaded almost 40GB of mirror files...

Configured Apache and have a virtual directory at »server/ubuntu that points to the repository. I see a "dists" and "pool" directory inside of there, so it looks close to the »us.archive.ubuntu.com/ubuntu/ directory, except my mirror doesn't have the "indices", "ls-LR.gz", and "project" directories.

So far, so good.

Next, I boot up the Ubuntu distribution and tell it to choose a mirror (manual) per the snapshots here as guidance: »www.howtoforge.com/local_debian_···irror_p3 - using my server's FQDN (which I can verify via ping in a maintenance shell), and the /ubuntu directory.

However, I can't get further than this.. I get a "Download Installer components" screen and "The installer failed to download a file from the mirror" error prompting me to retry, cancel, or change mirror.

Hopefully this is easy, but it's been driving me nuts all morning.

Anyone know how to fix this?

Thanks!