dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
551
share rss forum feed

mythology
Premium
join:2002-10-16
Seneca, SC

Mobile help

Simple table with multiple images. Displays fine in FF and IE. Load it up in Android and the table and links are there but the images are hidden. I`ve removed the width, used % and px. Not sure whats causing it.

»www.clemson4wheel.com/page.cfm/P···012.html



stray

join:2000-01-16
Warren, NJ

Missing DOCTYPE at the beginning of your webpage source.


mythology
Premium
join:2002-10-16
Seneca, SC

That wont cause images not to show on mobile devices. It doesnt on the rest of the site. I see no reason why it would on this one.



stray

join:2000-01-16
Warren, NJ
reply to mythology

Click for full size
You might also look at the javascript error shown above which affects anchors.

said by mythology:

That wont cause images not to show on mobile devices. It doesnt on the rest of the site. I see no reason why it would on this one.

That seems like a good reason not to declare a DOCTYPE. Don't know if it's some humongous effort or something, but I'd give it a try...
--
3D Movies and Virtual Reality

mythology
Premium
join:2002-10-16
Seneca, SC

1 edit

Cost a $100 to add a doctype. Radiant CPOnline is moving to the open source magento platform Q3 this year so we cant justify the expense now for adding a doctype. It should already be there but its not and they charge $100 to add it. Is what it is. =-)

I played around with it this morning. For some strange reason I can take everything off of that page. Add just images and only the first image will show up on Android`s browser. I gave up. Cponline sucks atm and offers no real mobile support and hardly even qualifys as legitimate html. Magento offers mobile support and doctypes out of the box. Looking forward to it.

The javascript tab code you referenced is for the home page center column menu. Strange enough this table on the home page with the multiple images displays just fine on Android and if I put the same code on the page I`m having troubles with it displays just fine.



cdru
Go Colts
Premium,MVM
join:2003-05-14
Fort Wayne, IN
kudos:7
reply to mythology

I pulled it up using both Dolphin as well as the built in browser on my android phone and both render as it does in FF on my PC. I'm running CyanogenMod 9 which is ICS so maybe it looks different on Gingerbread or older versions. I can check tonight with my wife's phone.

One thing that you might want to do is not have "poker" in the image name. That might flag content filters and adblocks that are blocking gambling-related images. I've built sites in the past where I wasn't thinking and created an image with an innocent name but happened to have "ad" or "banner" and it takes me a while to figure out why the image doesn't show up.


mythology
Premium
join:2002-10-16
Seneca, SC
reply to mythology

I fixed it Wed afternoon. The images i re-sized with Corel wouldn't show up in Outlook or mobile devices. I reset my Corel PP to default settings and re-re-sized the images and they work fine now.

The only thing i could figure out is i had corel set to 300dpi when i resized the images the first time. When i reset corel it reset the DPI to 72. Not real sure why that would cause them to not be displayed as they are tiny images to begin with. Strange.



cdru
Go Colts
Premium,MVM
join:2003-05-14
Fort Wayne, IN
kudos:7

Being higher resolution images, were they print-ready CMYK images, or RGB?


mythology
Premium
join:2002-10-16
Seneca, SC
reply to mythology

Think RGB. Not sure.